EEVblog Electronics Community Forum

General => General Chat => Topic started by: tyguy2 on August 16, 2018, 07:20:48 pm

Title: Currently fuming over Altium
Post by: tyguy2 on August 16, 2018, 07:20:48 pm
(Not sure if I should've posted this in the PCB Section, but since it's not a design question, I figured it probably belonged here)

Bit of a rant

So I've been using Altium Circuit Maker for the past 3 years now (first mistake, I know). Honestly loved the software, despite the cloud storage feature. Anyways, I go to login to my account, and, huh, password doesn't work. Click reset password and it spits out an error. Check the projects tab on the website, my designs still appear on search results, but trying to open them results in a 404, page not found. Consider me spooked at this point. I email their service email, no reply, their twitter doesn't accept messages, and according to the rep on the Altium Support line, "This is not a supported product."  :wtf: (No to mention their forums are barely active) So now I'm sitting here with no recourse, and no access to any of my designs. I understand this is the danger of using the "Cloud" but this is ridiculous. Anyways, if anyone has any advice, I'm all ears.  |O
Title: Re: Currently fuming over Altium
Post by: onesixright on August 16, 2018, 07:33:02 pm
Aren’t your designs public?


Sent from my iPhone using Tapatalk
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 16, 2018, 07:34:36 pm
Yeah, you can search them, and they do come up in search results. I tried creating a new account and just forking the designs over, but whenever I click to open them, the page gives a 404
Title: Re: Currently fuming over Altium
Post by: onesixright on August 16, 2018, 08:23:01 pm
I tried it as-well, also a 404.

Did you deactivated your account by accident?

Other projects are available ... so has to be something with your account ?

Whats the error on the password reset?
Title: Re: Currently fuming over Altium
Post by: onesixright on August 16, 2018, 08:25:14 pm
I logged out and tried to reset my password, but for me it works. I receive a reset email.
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 16, 2018, 08:28:41 pm
I definitely did not deactivate my account. The error I got when I went to reset my password was a simple "Unable to reset password." I went back through the sign up, and it allowed me to reset my password, but my projects are still gone. 
Title: Re: Currently fuming over Altium
Post by: onesixright on August 16, 2018, 08:35:34 pm
I definitely did not deactivate my account. The error I got when I went to reset my password was a simple "Unable to reset password." I went back through the sign up, and it allowed me to reset my password, but my projects are still gone.

Vey weird. Did you signup again? Like a new account?

The 404 indicates not found, a indicating that the files are simply gone (deleted?). Somebody hacked your account?
Title: Re: Currently fuming over Altium
Post by: onesixright on August 16, 2018, 08:38:47 pm
Did you in your profile changed your URL name?
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 16, 2018, 08:40:10 pm
I went to the sign up to see if it would drop me back to the password reset, which it did, but after that, it said I had no projects. What confirms that I did reset the password on my account is that the search results that bring up my projects that produce the 404's link back to the account with the new password.
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 16, 2018, 08:41:07 pm
The URL is completely unchanged, it's the same account
Title: Re: Currently fuming over Altium
Post by: onesixright on August 16, 2018, 08:43:18 pm
Yeah, under your profile is says 0 projects, but when you search your name in projects it finds them, with a thumbnail.

Sorry m8, not a clue!
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 16, 2018, 08:46:52 pm
It's ludicrous. And what's worse is that no one at Altium will help me. I was considering getting Designer with a student discount, but at this point, I wouldn't use their products if they paid me, if their support service is always like this.
Title: Re: Currently fuming over Altium
Post by: onesixright on August 16, 2018, 08:54:55 pm
Try posting it in their forum, maybe there are mod's that can help. I never used (still had the old account). But sharing and everything in the cloud is not my thing.

I got Circuit Studio. :/
Title: Re: Currently fuming over Altium
Post by: tautech on August 16, 2018, 09:02:31 pm
Search forum members for this guy: JamesH-AltiumOfficial
Send him a PM with a link to this thread and give him a serve privately.
Good luck.
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 16, 2018, 09:21:31 pm
PM Sent, here's to hoping  :-\
Title: Re: Currently fuming over Altium
Post by: tom66 on August 16, 2018, 09:27:00 pm
For what it's worth, the files are often cached on your machine (see attached for example.)

It should be possible to import them in to a new instance of CircuitMaker or use Altium to open them.

I am really not sure what Altium is doing with CircuitMaker.  They seem to have partially abandoned it but there are still software updates here and there.  I'm not sure that they really know what to do with it at this point.
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 16, 2018, 09:58:23 pm
For what it's worth, the files are often cached on your machine (see attached for example.)

It should be possible to import them in to a new instance of CircuitMaker or use Altium to open them.


Joke's on me, I restarted my computer a week ago  :-- All I have is a few files there, none of which are the kind I need, thanks for the tip, though.
Title: Re: Currently fuming over Altium
Post by: ttelectronic on August 16, 2018, 10:22:02 pm
Personally I am staying away from all this cloud stuff. Sure it has it's uses, but damn it sure can screw up someones work flow.  :palm:
Title: Re: Currently fuming over Altium
Post by: Mr. Scram on August 16, 2018, 10:25:41 pm
It unfortunately does to be a poignant example of why relinquishing control to someone else isn't always to your advantage. Of course, that's little help to OP. It's quite annoying Altium isn't responding to requests for help.
Title: Re: Currently fuming over Altium
Post by: DimitriP on August 16, 2018, 10:42:29 pm
Personally I am staying away from all this cloud stuff. Sure it has it's uses, but damn it sure can screw up someones work flow.  :palm:

...and "A whopping 80 percent of the 400 IT decision-makers who participated in IDC’s 2018 Cloud and AI Adoption Survey..."  agree with you in some way or another :)

https://www.crn.com/businesses-moving-from-public-cloud-due-to-security-says-idc-survey (https://www.crn.com/businesses-moving-from-public-cloud-due-to-security-says-idc-survey)
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 16, 2018, 10:50:32 pm
It unfortunately does to be a poignant example of why relinquishing control to someone else isn't always to your advantage.

Would have gone with Circuit Studio, but I didn't have $500 to invest in it at the time, and once I finally did, I was already heavily invested in Circuit Maker and didn't really see a reason to switch (until now, of course).
Title: Re: Currently fuming over Altium
Post by: xjordanx on August 16, 2018, 11:34:03 pm
Hi Ty,

I work for Altium and with CM and Upverter. I am not normally on this forum, but one of our other social media people saw this and pinged me. It's true that only development team members support the free tools at this time - unlike the rest of Altium which has dedicated support enigneers for the paid products, CM and Upverter don't have any support staff. It's entirely up to whomever cares and happens to notice. I am sorry for the hassle and have personally followed up with developers to find out what's going on with this.

There are one or two other users having the same problem. We'll get to the bottom of it.

Mean while please PM me links or names of your projects and I will try to see if I have any magical powers for getting them back to you.
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 17, 2018, 12:10:33 am
Appreciate it, PM sent
Title: Re: Currently fuming over Altium
Post by: xjordanx on August 17, 2018, 12:25:53 am
Received. I confirm the same behavior. Passing project details to R&D who are looking at this.

It's evening here where I am and I'm about to leave for the night but will keep an eye on this issue for you.
Title: Re: Currently fuming over Altium
Post by: james_s on August 17, 2018, 12:53:17 am
Experiences like this certainly bolster my decision to avoid the whole cloud and SaaS thing at nearly any cost.

Maybe this should be motivation to migrate over to KiCad, migrating is always a headache but when the additional freedom offered by open source software can save a lot of troubles.
Title: Re: Currently fuming over Altium
Post by: ludzinc on August 17, 2018, 01:25:01 am
Sad to hear that.

I'm a CM user and Fan, but can see the writing on the wall......  It's a shame as I like sharing my work, almost as much as I hate KiCAD.

(*IF*) You can download a release, you can then import into a current version of Alitum.

BBL - doing that right now with my stuff!
Title: Re: Currently fuming over Altium
Post by: ANTALIFE on August 17, 2018, 06:43:36 am
Have you seen this post:

https://www.eevblog.com/forum/altium/busted-altium-deliberately-crippling-circuit-maker/ (https://www.eevblog.com/forum/altium/busted-altium-deliberately-crippling-circuit-maker/)
Title: Re: Currently fuming over Altium
Post by: xjordanx on August 17, 2018, 08:47:56 pm
We found the issue - was a script deactivating some users from the Altium Designer CRM system that had apparently not been used, yet they were for a handful of CM accounts early on during open beta, and it is those users who were affected.

R&D are restoring those within the next few hours.

Sorry for the PITA this caused anyone.
Title: Re: Currently fuming over Altium
Post by: tyguy2 on August 18, 2018, 04:20:47 pm
All the projects are back up, but my original account still gives a 404. I'll just fork everything until that gets sorted.