Author Topic: Rigol DS1000E series: Possible error/fail in Sin(x)/x interpolation?  (Read 33961 times)

0 Members and 1 Guest are viewing this topic.

Offline dfnr2

  • Regular Contributor
  • *
  • Posts: 233
  • Country: us
Re: Rigol DS1000E series: Possible error/fail in Sin(x)/x interpolation?
« Reply #50 on: March 28, 2011, 08:06:51 pm »
I have do some amount of work with Rigol for inspect this issue and issue (what I talk in this thread is absolutely "error" in Sin(x)/x (there is not any real Sinx, there is only simple filter nearly as "smooth".) If do Sinx there is not any reason to "hide" real sample point. Example some Tektronix model highlight real points in sinx display (and this highlight can select off/on. Why? Becouse Tektronix know what is oscilloscope and what is Sinx)

There sure is such a thing as sinc interpolation.  Or more correctly, a windowed sinc interpolation.  As you say, it could be implemented as an FIR filter (convolution), with a windowed sinc impulse response.  I suppose if they try to use a different filter for the convolution, then it wouldn't be a sinc interpolation, but rather, for example, a Butterworth interpolation, or such. It can also be implemented in the frequency domain, although I doubt so in this case.

For Hantek I have not yet make enough isnpections. Only what I have look is spectrum analyze sampling clock (9288 signal ENCx) and it is not bad. Phasenoise and "jitter" I have not check but with my "eyes" and simple method look... not very bad.

To examine the DAC timing, a spectrum analyzer is not very helpful.  You will need another--higher performance--scope, preferably equipped with a jitter/timing analyzsis package.

But with simple method it can look if situation is very bad or not. All you need for this is read littlebit about how these machines work and example some nice articles from example Agilent library.


There is some good stuff in the agilent library, especially the older stuff.  Interestingly, on searching it, I found an article on just this artifact in the agilent library. Here's the link to a PDF, and also a video (didn't check the video; it requires registration).  While it contains marketing material about why agilent is better than LeCroy or Tek, it does explain the phenomenon clearly, and also includes description on how you can analyze the waveforms to characterize the distortion.  It also explains the extra harmonics in the FFT, noted by Saturation.

http://cp.literature.agilent.com/litweb/pdf/5989-5732EN.pdf.  

http://event.on24.com/eventRegistration/EventLobbyServlet?target=lobby.jsp&eventid=199821&sessionid=1&key=6AA1B51DB51B7425AC75D3E8CA7B7490&eventuserid=47823303  

Just same: Hantek DSO5102B is 100MHz oscilloscope. Stay below 100MHz and no big problem at all.

But the DSO5202B is a 200 MHz scope, and should have no problem with a 100-150 MHz signal.

What I have think... maybe these economy class scopes give less problems if they do analog front end BW as "brick wall". There go away many small problems.(do not open it more wide... reject it better. ;) )
I don't think that aliasing is a factor here.  With a sufficiently pure sinewave, signal BW, scope BW, and aliasing shouldn't be a factor.


« Last Edit: March 28, 2011, 08:26:41 pm by dfnr2 »
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 21206
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Rigol DS1000E series: Possible error/fail in Sin(x)/x interpolation?
« Reply #51 on: January 02, 2016, 06:32:52 am »
Sorry guys for bumping this thread that I only discovered today and it's nothing at all about the brand involved but the now missing imagery and as most of the members that posted are still active, is there any chance the image links can be restored?
Or placed on Dave's server?

Anyway it's a brilliant read for anybody with a DSO.  :-+

Thanks in advance.
Avid Rabid Hobbyist
 

Offline jahonen

  • Super Contributor
  • ***
  • Posts: 1046
  • Country: fi
Re: Rigol DS1000E series: Possible error/fail in Sin(x)/x interpolation?
« Reply #52 on: September 17, 2018, 09:07:07 am »
Hello All,

I have restored the links to my images so they should work now. Sorry for not remembering to fix this.

Regards,
Janne
 
The following users thanked this post: MrW0lf


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf