Author Topic: Need help in RTP area  (Read 1084 times)

0 Members and 1 Guest are viewing this topic.

Offline blueskull

  • Supporter
  • ****
  • Posts: 12647
  • Country: cn
  • Power Electronics Guy
Need help in RTP area
« on: March 23, 2016, 11:34:58 pm »
Hi,

Is there any X99/2011-3 computer owner living in eastern North Carolina and is willing to help me? I have a E5 2696v3+X99 build that will not post. I visited local Intrex and BestBuy, and none of them carry X99 or 2011-3 processors.
I will be very appreciate if anyone owning this platform can help be cross diagnose whether my CPU or mobo is DOA. I already ruled out the possibility of other parts being broken.
My location: Raleigh, I am willing to drive to your place, any place within 4 hours of driving.



Thanks in advance!!!
 

Offline evb149

  • Super Contributor
  • ***
  • Posts: 1666
  • Country: us
Re: Need help in RTP area
« Reply #1 on: March 24, 2016, 01:13:13 am »
Unfortunately I am not in the area and I don't have any specific experience with that type of hardware, but in case it is helpful I'll mention a few of the things that I have encountered in the past with PCs that would not finish POST in case something by chance could help.

(a) Sometimes I have had the battery backed memory settings that hold the BIOS HW configuration become corrupted or get set into some state that would not let it work due to some BIOS bug.  In such cases I have had to use the "clear CMOS / clear battery backed RAM" instructions for the motherboard when the motherboard was unplugged from mains AC power (usually there is a memory reset / settings clear jumper for this purpose though sometimes just removing the battery for a few minutes is needed).  After clearing the memorized HW configuration it was possible to enter the BIOS configuration screens and set the necessary parameters for future use.

(b) Sometimes due to BIOS bugs some perfectly reasonable seeming BIOS parameter settings would sometimes cause a hard lockup of the PC during POST.  Usually associated with the behavior of a certain peripheral that would be in a state different than the PC had previously worked under.  Example: USB mass storage boot mode being enabled and some USB flash drive or USB device which wouldn't have a valid OS on it would still cause it to lock up while trying to parse the partition or boot information that wasn't supposed to be valid anyway.  Example: USB peripheral of some type or configuration that would crash the USB probing routines in the PC BIOS -- USB HUB, USB scanner, USB KVM switch, monitor with built in USB HUB,  could be anything.  Trying to access IDE/SATA drives that were reformatted or not ready or simething.  Other than resetting the BIOS settings to try to access as little peripheral as possible, it was often useful for diagnosis to unplug *every* peripheral possible (sometimes even keyboard / mouse) and see if that helped. 

(c) even without the use / presence of some peripheral some BIOS options would just cause the PC to run unstably or lock up.  Obviously any incorrect timing / voltage settings could do it, but also sometimes just functions that were buggy in some way or which don't behave as expected / remembered.  BIOS monitoring your CPU / system FAN speeds against a threshold and some fan inputs are disconnected or not in range?  BIOS montioring system temperature and the temperature is read as out of range and causes a halt?  BIOS configured for certain RAM settings that aren't possible or reliable?

(d) Defective or improperly inserted DRAM DIMMs.  Remove, clean the contacts, reinsert properly all memory.

(e) CPU socket malfunction, check for partially or incorrectly inserted CPU.  Sometimes the heatsink-fan assembly could cause the shifting of the CPU in the socket or maybe the socket ZIF wasn't latched fully or something.

(f) Some peripheral with a short circuit or overcurrent condition that causes the PSU voltages to be out of specification.  Try disconnecting disc drives, SSDs, adapter cards, USB, SATA, audio, video peripheral connections and if a connection is essential to reach POST then try some temporary replacement.  Often just RAM, Keyboard, and possibly GPU are enough to get a PC to at least start to post.  Some PCs can post even with no GPU (which often can fail due to their extreme complexity and fragility vs. thermal and cooling problems).

(g) Bad PSU with some out of specification power rail.  Maybe even fine until some load is applied.  Or maybe some PSU output that is intended for a special / limited power purpose (e.g. FAN power) is connected to some other essential load like drive or GPU or whatever.  Maybe just bad connection, reseat all connectors.

(h) GPU auxiliary PSU connections not connected or bad GPU or GPU not properly seated in slot.

(i) If the CPU / RAM speed is adjustable in the BIOS settings some buggy BIOS auto-adjustment or auto-detection routines can cause crashes, or a marginally stable configuration is not reliable now for some reason.  Change all frequencies to at or below the minimum guaranteed operational level and try that.  Maybe try with only mininal RAM installed.

(j) Defective mains AC power cord, or defective internal PSU cable or something like that. 

(k) Some misconfiguration of where the PC POST / console output is going.  Sometimes PCs can pick one possible GPU display (internal motherboard vs. one of the external GPU ports or whatever) which is not right and POST / system output cannot be seen.  Sometimes monitor connections and monitor power saving modes and monitor EDID settings can play a part in the confusion / erroneous operation.  Try another monitor type / configuration / display output port.

(l) Some internal chassis cabling problem.  The "soft on/off" power switch, the reset switch, the fan / temperature sensors, and many vital control signals are often connected to the motherboard by some easily misconfigured / dislodged jumper style or flex circuit cabling.  Inspect all cables going to the motherboard and chassis and reseat them all in the verified correct positions.  Check for bad wires on critical paths.

(m) Check for defective / misconfigured UPS or mains socket or power strip.

(n) Make sure the PC isn't set to boot from network card or peripheral card or something it cannot.

(o) Sometimes something locks up and has to have a cold reset without even standby power present.  Unplug all mains cables from the PC and all peripherals for 10 minutes.  The RESET or soft power switch may not be enough.

(p) Sometimes ground loops or ground potential differences can be problematic.  Try to unplug unecessary peripherals and power all essential ones from the same physical UPS / power strip / wall outlet.

(q) Sometimes the RESET / power switch breaks...

Sometimes if you try to smell the various components you might notice the odor of a burned component if something has failed. 

That's what comes to mind for the moment, probably useless, but some things I have spent hours debugging thinking they were so unlikely as to not be worth considering yet sometimes that's actually the problem.
 

Offline blueskull

  • Supporter
  • ****
  • Posts: 12647
  • Country: cn
  • Power Electronics Guy
Re: Need help in RTP area
« Reply #2 on: March 24, 2016, 01:42:25 am »
Thanks for the reply, but I think this problem is more weird than you thought.

(a) Cleared several times, both with CMOS clearing button and jumpers.

(b) Nothing connected, only PSU, mobo, CPU, GPU and RAM.

(c) At least it should post, and displays error or beeps.

(d) Swapped 5 different sticks with 3 different types.

(e) It is not a ZIF, it is a LGA package. I wiped the connections with IPA for a couple of times.

(f) Tested with no SSD, no USB, not PCIe, even no GPU, still the system reboots.

(g) PSU verified with my Fluke.

(h) With or without GPU it does not even beep.

(i) 8GB single stick still won't boot, CMOS cleared.

(j) PSU is working, power cord is working and swapped.

(k) X99 requires external GPU, and I have tried 2 cards.

(l) I removed all headers and use a screwdriver to turn on the computer.

(m) Directly powered from the wall.

(n) It does not even post.

(o) I've been doing this for the past 3 days.

(p) Nothing plugged in.

(q) I removed all headers and use a screwdriver to turn on the computer.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf