EEVblog Electronics Community Forum

General => General Technical Chat => Topic started by: PetrosA on March 09, 2010, 03:46:32 am

Title: Still getting timeout errors when I try to post or respond
Post by: PetrosA on March 09, 2010, 03:46:32 am
I don't know whether this is something at my end or what, but 3 out of 4 times when I go to respond to a post or to post something new, I get a timeout error. I can go back to the posting page and preview my post fine, but it won't post then at all and I end up having to cut/copy, return to the blog page, respond again, paste and hit Post fast for it to work. Anyone else having this problem? Firefox 3.6 on WinXP SP3.
Title: Re: Still getting timeout errors when I try to post or respond
Post by: EEVblog on March 09, 2010, 06:00:09 am
Check-1-2

I do occasionally get an email from the forum saying here is a database error, but have no clue as to what that means.

The whole site also gets speed throttled occasionally, but that should not affect posting I would think.

Dave.
Title: Re: Still getting timeout errors when I try to post or respond
Post by: migsantiago on March 09, 2010, 03:30:08 pm
I have been using an SMF forum for almost 5 years (www.todopic.com.ar/foros). We have had some serious problems with the database, problems that have collapsed the forum for hours.

The problem with some web hosting services is that they use one server for several web sites and services (php, html, asp.net, etc.). When other websites receive lots of petitions, the smaller websites (such as eevblog forums) are affected aswell.

The database error is most likely occasionated by the server cpu load.

We had to move to a faster web hosting company.
Title: Re: Still getting timeout errors when I try to post or respond
Post by: Simon on March 09, 2010, 05:19:44 pm
I've noticed the page has not loaded sometimes when I've tried to view a topic. I am fast starting to hate all webhosting comapnies, you use one it's great your really please and then just as you renewal time comes up their service becomes crap because they are cattering for too many users, when I'm spending £ 50 a year plus being ripped off 7-10 pounds for every domain i resgister i do start to take exception. I'm seriously thinking of looking into setting up my own server
Title: Re: Still getting timeout errors when I try to post or respond
Post by: EEVblog on March 09, 2010, 10:50:45 pm
I use Hostmonster.com for all my sites on the one plan (about $7/month) and it seems to have no problem hosting all the streaming Podcast videos etc.
I use fxdomains.com for all my domains names. Although there are cheaper ones, I've consolidated there. If you are paying more than say $7/year for a domain you are being ripped off. The general rule is don't register domain names through hosting companies, as they usually charge a big premium.

I can't see how you could possibly beat someone like hostmonster.com by using your own server. You just get so much for your money without any hassle, it's incredible.

Dave.
Title: Re: Still getting timeout errors when I try to post or respond
Post by: joelby on March 10, 2010, 06:03:08 am
The only problem with cheap shared hosting is that you're occasionally at the mercy of all of the other users.

The next step up is cheap virtual server hosting! From about $25 a month you can have a server all to yourself, with better isolation, resource contention, and configurability.

Of course it all depends on how much time you have to fiddle around with these things.
Title: Re: Still getting timeout errors when I try to post or respond
Post by: Simon on March 10, 2010, 07:49:02 am
well after the cockup justhost made of all of my billing I am planning on moving my domains to start with, I just don't want to loose my emails during the changeover. Oh yes and by the way DO NOT use justhost they suck, they send you adverts all the time make a general nuisance of themselves trying to get you to upgrade and are that incompetent they will bill you for something you already paid for.