Author Topic: Server Error Reports  (Read 220489 times)

0 Members and 1 Guest are viewing this topic.

Offline tggzzz

  • Super Contributor
  • ***
  • Posts: 12986
  • Country: gb
    • Having fun doing more, with less
Re: Server Error Reports
« Reply #350 on: November 22, 2020, 06:12:58 pm »

Just wait till the security software gets smart enough to actually look at the pictures!  :D

I thought all that mattered was how much pink there is in the pictures.

Quote from: Terry Pratchett, The Colour of Magic
The box said, "It's no good. I've run out of pink."

A hitherto unnoticed door opened in front of his eyea. A small, green and hideously warty humanoid figure leaned out, pointed at a colour-encrusted palette in one clawed hand, and screamed at him.

"No pink, See?" screeched the homunculus."No good you going on pressing the lever when there's no pink, is there? If you wanted pink you shouldn't of took all those pictures of young ladies, should you? It's monochrome from now on, friend. Alright?"
There are lies, damned lies, statistics - and ADC/DAC specs.
Glider pilot's aphorism: "there is no substitute for span". Retort: "There is a substitute: skill+imagination. But you can buy span".
Having fun doing more, with less
 

Offline bd139

  • Super Contributor
  • ***
  • Posts: 17560
  • Country: gb
Re: Server Error Reports
« Reply #351 on: November 22, 2020, 06:15:44 pm »

People will just upload smurf porn instead.
 
The following users thanked this post: mnementh

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 2610
  • Country: dk
  • Country: Broken Britain
Re: Server Error Reports
« Reply #352 on: December 21, 2020, 05:36:11 pm »
Login password failed twice, even though I'd made the characters visible. :-//

Checked there were only the two failed login emails, came back and then the same EEV password worked. :-//

Is it just me. :)
CML+  That took much longer than I thought it would.
 

Offline Vince

  • Frequent Contributor
  • **
  • Posts: 536
  • Country: fr
Re: Server Error Reports
« Reply #353 on: December 23, 2020, 08:23:47 pm »
Hi,

Sorry if this isn't the place to post this, but it's by far the best I can find...

I am having problems attaching pictures to my topics.

Had the problem for the first time a few days ago. Took a few pics in a row of the setup on my workbench, repairing a CD player, so all pics are technically identical : dimensions, file format (JPG) , compression ratio etc.. only the data / contents of the pictures change. Yet, some pictures will upload just fine, but some will not. No matter how many times I try... it just refuse to attach them. It uploads them, but once uploaded I guess it runs some clever AI to "look" at the pictures... and decides it doesn't like that particular pic, and returns the following message :



Code: [Select]
" Your attachment has failed security checks and cannot be uploaded. Please consult the forum administrator ".

"failed SECURITY checks " ?!  :o  How dangerous and threatening can a broken 30 year old CD player be ?! .................

The latest failure was a few minutes ago, tried to upload a screenshot of my oscilloscope to show a waveform :

https://www.eevblog.com/forum/repair/vintage-cd-player-repair-philips-cdc-486-6-disc-changer/msg3383122/#msg3383122

Would love to attach the picture for you to look at it, run whatever test on it to see what triggers the server, but of course can't attach it, chicken and egg !  :P

Tried to fool the server by changing the file extension fro PG to HEX, hoping that would keep it from being "analyzed" but no luck, even as  hex file it gives the same error message...

I guess I could send it to directly via e-mail to bypass the forum, if you have one you are willing to trust a random user with ?  I am not a spam robot, I swear...  ;D

Hoping this temperamental behaviour can be fixed, not being able to upload pictures reliably on a forum in 2020 feels rather weird  :(

Regards,

Vince
 

Offline Vince

  • Frequent Contributor
  • **
  • Posts: 536
  • Country: fr
Re: Server Error Reports
« Reply #354 on: December 23, 2020, 08:41:36 pm »
Found a work-around, so here goes the offending picture... what's wrong with it ?


I converted it from JPG to PNG and the forum accepts it now. However this is not a "solution" because the file size goes up by a factor of 10 or so, no less. That's unacceptable  :(



 
The following users thanked this post: SilverSolder

Offline SilverSolder

  • Super Contributor
  • ***
  • Posts: 3700
  • Country: 00
Re: Server Error Reports
« Reply #355 on: December 23, 2020, 09:23:44 pm »
Found a work-around, so here goes the offending picture... what's wrong with it ?


I converted it from JPG to PNG and the forum accepts it now. However this is not a "solution" because the file size goes up by a factor of 10 or so, no less. That's unacceptable  :(

Maybe you can zip the offending JPEG file and attach?
 

Offline Vince

  • Frequent Contributor
  • **
  • Posts: 536
  • Country: fr
Re: Server Error Reports
« Reply #356 on: December 23, 2020, 09:28:02 pm »
Yes that's an idea ! Let's try that... it worked !  :D
 

Offline SilverSolder

  • Super Contributor
  • ***
  • Posts: 3700
  • Country: 00
Re: Server Error Reports
« Reply #357 on: December 23, 2020, 10:00:08 pm »
Yes that's an idea ! Let's try that... it worked !  :D

 :-+

There have been other reports of JPEGs getting flagged for security issues.  Wonder if this is just some kind of anti-virus fingerprinting snafu?
 

Offline McBryce

  • Super Contributor
  • ***
  • Posts: 1813
  • Country: de
Re: Server Error Reports
« Reply #358 on: December 24, 2020, 10:01:49 am »
This has something to do with the Forum software being used, because I get that issue on another Forum too that uses the same software. I've found that certain programs cause the issue. If I save a jpg with Irfanview 64 they often get rejected. If I save the same picture using MSPaint the error goes away.

McBryce.
 

Online beanflying

  • Super Contributor
  • ***
  • Posts: 5268
  • Country: au
  • Toys so very many Toys.
Re: Server Error Reports
« Reply #359 on: December 24, 2020, 10:10:14 am »
Using the same version of Irfanview for the last year+ and same issue with me and JPG's in the last week so yep PNG's to solve this bug. I suspect it is a permissions issue with maybe a new release or a new version of a mod that Dave has installed that needs a tweak.
Coffee, Food, R/C and electronics nerd in no particular order. Also CNC wannabe, 3D printer and Laser Cutter Junkie and just don't mention my TEA addiction....
 

Offline floobydust

  • Super Contributor
  • ***
  • Posts: 3973
  • Country: ca
Re: Server Error Reports
« Reply #360 on: December 27, 2020, 10:51:10 pm »
I keep getting the "Your attachment has failed security checks and cannot be uploaded. Please consult the forum administrator.", then the Modify Message goes into a coma.
But weird- it's even for .jpg's that are already posted a year or more ago, same file. Only the Russian hackers are embedding badness in jpg's.

edit I have a pic "34470a ref.jpg" successfully uploaded in 2017 at https://www.eevblog.com/forum/metrology/ultra-precision-reference-ltz1000/msg1315334/#msg1315334
that lately won't upload without the error message. I tried a few times to upload it here in this post and it failed, then it's working fine. UGH
« Last Edit: December 28, 2020, 06:10:42 am by floobydust »
 

Offline bd139

  • Super Contributor
  • ***
  • Posts: 17560
  • Country: gb
Re: Server Error Reports
« Reply #361 on: December 27, 2020, 11:18:46 pm »
Had the same. Given up  :-//
 

Online MK14

  • Super Contributor
  • ***
  • Posts: 2738
  • Country: gb
Re: Server Error Reports
« Reply #362 on: December 31, 2020, 12:32:44 am »
I'm sometimes intermittently getting, the following:
(At a VERY approximate rate, of 1 in every 10 Forum page accesses).

Quote
Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

E.g. About 1 minute ago. 12:31 AM UK time.
Which in UTC is:

Quote
00:31
Thursday, 31 December 2020
Coordinated Universal Time (UTC)

(Yes, identical, at this time of year).
« Last Edit: December 31, 2020, 12:36:27 am by MK14 »
 
The following users thanked this post: tautech, SilverSolder, kcbrown

Offline tautech

  • Super Contributor
  • ***
  • Posts: 20030
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #363 on: December 31, 2020, 12:39:35 am »
Me too and Quote doesn't work.  :-//

In some thread thumbnails are not loading yet the link for them is there.  :-//

Maybe SMF has got on the happy new year juice a bit early.  :-DD
Avid Rabid Hobbyist
Come visit us at EMEX 15th - 17th February. Hall 1 Stand 1002
https://www.emex.co.nz/
 

Offline tautech

  • Super Contributor
  • ***
  • Posts: 20030
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #364 on: December 31, 2020, 09:25:19 am »
Me too and Quote doesn't work.  :-//

In some thread thumbnails are not loading yet the link for them is there.  :-//

Maybe SMF has got on the happy new year juice a bit early.  :-DD
Forum can be a right PITA with these connection issues.
Somethings not right.   :horse:
Avid Rabid Hobbyist
Come visit us at EMEX 15th - 17th February. Hall 1 Stand 1002
https://www.emex.co.nz/
 

Offline bd139

  • Super Contributor
  • ***
  • Posts: 17560
  • Country: gb
Re: Server Error Reports
« Reply #365 on: December 31, 2020, 10:19:21 am »
Yeah getting irritating now. Have multiple persistent issues now.

https://youtu.be/ps28uqkfsUw
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1210
  • Country: au
Re: Server Error Reports
« Reply #366 on: December 31, 2020, 10:37:37 pm »
Can someone please provide one of the offending files so I can investigate? Seems SMF added some very primitive and poorly implemented security checking code for infected files.

Code: [Select]
preg_match('~(iframe|\\<\\?|\\<%|html|eval|body|script\W|[CF]WS[\x01-\x0C])~i', $prev_chunk . $cur_chunk) === 1)
The final match in this is likely to trigger on tons of stuff, a very dumb move.

Edit:

I have re-written the check logic, it should be far more reliable and also yield better protection. This should also stop people from being able to upload forum breaking images.
Test images attached :)
« Last Edit: December 31, 2020, 11:04:49 pm by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 
The following users thanked this post: MK14, Jacon, bd139, beanflying

Online beanflying

  • Super Contributor
  • ***
  • Posts: 5268
  • Country: au
  • Toys so very many Toys.
Re: Server Error Reports
« Reply #367 on: December 31, 2020, 11:02:14 pm »
Formerly Failed Jpeg. Dropbears are a real threat.  >:D

Unless you changed something Gnif this same picture was failing the security check last time I tried it as a jpeg so???

Edit of my edit  :-+ seems to be ok again then - good work  :)
« Last Edit: December 31, 2020, 11:05:33 pm by beanflying »
Coffee, Food, R/C and electronics nerd in no particular order. Also CNC wannabe, 3D printer and Laser Cutter Junkie and just don't mention my TEA addiction....
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1210
  • Country: au
Re: Server Error Reports
« Reply #368 on: December 31, 2020, 11:16:05 pm »
I'm sometimes intermittently getting, the following:
(At a VERY approximate rate, of 1 in every 10 Forum page accesses).

Quote
Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

E.g. About 1 minute ago. 12:31 AM UK time.
Which in UTC is:

Quote
00:31
Thursday, 31 December 2020
Coordinated Universal Time (UTC)

(Yes, identical, at this time of year).

I resolved this last night, the 'thanks' plugin was at fault, it generates the `'top 10` stats in a very very poor way for the forum stats page and was bogging the database down. I don't think whoever wrote that plugin had forums the size of EEVBlog in mind. For now (perhaps forever) I have disabled the code causing the issue, as such the top 10 is blank now.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 
The following users thanked this post: tautech, MK14, 2N3055, Jacon, bd139

Offline tautech

  • Super Contributor
  • ***
  • Posts: 20030
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #369 on: December 31, 2020, 11:23:27 pm »
Certainly the Stats page loads in an instant now whereas before the sever always took some time to think about it.

Good job gnif !  :clap:
Avid Rabid Hobbyist
Come visit us at EMEX 15th - 17th February. Hall 1 Stand 1002
https://www.emex.co.nz/
 
The following users thanked this post: gnif, MK14

Offline bd139

  • Super Contributor
  • ***
  • Posts: 17560
  • Country: gb
Re: Server Error Reports
« Reply #370 on: December 31, 2020, 11:31:48 pm »
Big improvement. Nice one  :-+
 
The following users thanked this post: MK14

Offline tautech

  • Super Contributor
  • ***
  • Posts: 20030
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #371 on: January 01, 2021, 12:00:00 am »
Now the only real nuisance that needs attention is the first attachment in a reply when for some reason another attachment you've previously uploaded gets added to your post instead of the one you wanted.  :-//

For some time we've been skipping the 1st attachment and only using 2nd and subsequent which results in bypassing this problem.  :phew:
Avid Rabid Hobbyist
Come visit us at EMEX 15th - 17th February. Hall 1 Stand 1002
https://www.emex.co.nz/
 
The following users thanked this post: MK14

Offline Vince

  • Frequent Contributor
  • **
  • Posts: 536
  • Country: fr
Re: Server Error Reports
« Reply #372 on: January 01, 2021, 02:06:38 am »
I have re-written the check logic, it should be far more reliable and also yield better protection. This should also stop people from being able to upload forum breaking images.
Test images attached :)

Wow, thanks a lot !  :-+

Glad to see there is someone here that knows this forum stuff, well done  :)
 
The following users thanked this post: gnif, MK14

Offline mnementh

  • Super Contributor
  • ***
  • Posts: 10343
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #373 on: January 01, 2021, 02:24:48 am »
*Airmails gnif a New Year's toast*

Thanks!

mnem
:clap:
 
The following users thanked this post: gnif, MK14

Offline gnif

  • Administrator
  • *****
  • Posts: 1210
  • Country: au
Re: Server Error Reports
« Reply #374 on: January 01, 2021, 03:49:45 am »
Now the only real nuisance that needs attention is the first attachment in a reply when for some reason another attachment you've previously uploaded gets added to your post instead of the one you wanted.  :-//

For some time we've been skipping the 1st attachment and only using 2nd and subsequent which results in bypassing this problem.  :phew:

I have some time today to try to track this one down.... see what bad thing SMF did to break this too :(
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 
The following users thanked this post: MK14


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf