Author Topic: Server Error Reports  (Read 260007 times)

seronday and 1 Guest are viewing this topic.

Online tautech

  • Super Contributor
  • ***
  • Posts: 21157
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #375 on: January 01, 2021, 05:49:12 am »
Now the only real nuisance that needs attention is the first attachment in a reply when for some reason another attachment you've previously uploaded gets added to your post instead of the one you wanted.  :-//

For some time we've been skipping the 1st attachment and only using 2nd and subsequent which results in bypassing this problem.  :phew:

I have some time today to try to track this one down.... see what bad thing SMF did to break this too :(
IIRC it was associated with a plugin that gave problems and Dave disabled. That also killed the pic insertion feature so everyone had to go back to using IMG flags.
Not such a problem for those of us that have been around here for a few years where it was just standard practice.

Maybe a few pages back in this thread you can find Daves comments and actions about this.
Avid Rabid Hobbyist
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1241
  • Country: au
Re: Server Error Reports
« Reply #376 on: January 01, 2021, 08:28:56 am »
We must be thinking about different issues then, I am talking about the one where the full size image gets replaced by a future image post. My investigation points to an issue with GlusterFS.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 
The following users thanked this post: MK14

Offline gnif

  • Administrator
  • *****
  • Posts: 1241
  • Country: au
Re: Server Error Reports
« Reply #377 on: January 01, 2021, 01:47:24 pm »
Sorry about the short outage people, doing some quite extensive server upgrades to allow us to upgrade GlusterFS

Edit: Please be aware that this is still in progress, minor interruptions are to be expected
« Last Edit: January 01, 2021, 10:57:33 pm by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 
The following users thanked this post: EEVblog, MK14, Jacon, bd139, DrG

Offline gnif

  • Administrator
  • *****
  • Posts: 1241
  • Country: au
Re: Server Error Reports
« Reply #378 on: January 02, 2021, 05:56:42 am »
Work has been completed, if there are any further issues please as usual post the details here and I will do what I can :)
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 
The following users thanked this post: SilverSolder, MK14, bd139, beanflying

Offline S. Petrukhin

  • Super Contributor
  • ***
  • Posts: 1031
  • Country: ru
Re: Server Error Reports
« Reply #379 on: January 02, 2021, 07:10:20 pm »
We must be thinking about different issues then, I am talking about the one where the full size image gets replaced by a future image post. My investigation points to an issue with GlusterFS.
Is this fixed yet?
And sorry for my English.
 

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 2884
  • Country: ro
Re: Server Error Reports
« Reply #380 on: January 02, 2021, 07:18:25 pm »
I didn't noticed any downtime, but right now each page has a terrible slow response.  It takes 2-3 seconds to return a page.  The pages were loading without any noticeable lag in the previous days.

Browsing from Bucharest/Romania/EU.  Other sites are working just fine, only EEVblog takes many seconds to return a forum page.

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 4592
  • Country: nl
Re: Server Error Reports
« Reply #381 on: January 02, 2021, 07:21:44 pm »
It was quite slow for me until yesterday but it's all good now. YMMV of course.
Keyboard error: Press F1 to continue.
 

Offline SilverSolder

  • Super Contributor
  • ***
  • Posts: 4915
  • Country: 00
Re: Server Error Reports
« Reply #382 on: January 02, 2021, 08:42:39 pm »

I am also seeing slow page response times on initial load.
 

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 4592
  • Country: nl
Re: Server Error Reports
« Reply #383 on: January 02, 2021, 08:46:12 pm »
Yeah, never post 'all good now' because after that it slowed down again  :(
Keyboard error: Press F1 to continue.
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1241
  • Country: au
Re: Server Error Reports
« Reply #384 on: January 02, 2021, 11:05:37 pm »
We must be thinking about different issues then, I am talking about the one where the full size image gets replaced by a future image post. My investigation points to an issue with GlusterFS.
Is this fixed yet?

It should be, time will tell.


I am also seeing slow page response times on initial load.

Performance metrics show the website is loading about 5% faster then prior to the upgrade, it's likely due to your geographical location.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 2884
  • Country: ro
Re: Server Error Reports
« Reply #385 on: January 03, 2021, 12:17:17 am »
The speed seems back to normal right now.  The lag is gone, thanks.

Offline S. Petrukhin

  • Super Contributor
  • ***
  • Posts: 1031
  • Country: ru
Re: Server Error Reports
« Reply #386 on: January 03, 2021, 11:00:41 am »
Another small bug: it seems that if the user did not specify the country, the place of the flag is displayed crookedly.
[attachimg=1]
And sorry for my English.
 

Offline S. Petrukhin

  • Super Contributor
  • ***
  • Posts: 1031
  • Country: ru
Re: Server Error Reports
« Reply #387 on: January 03, 2021, 11:02:46 am »
And I still can't attach the inserted full-size image. See previous post: I specified inline full-size, but it still inserts as a tumb.
And sorry for my English.
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1241
  • Country: au
Re: Server Error Reports
« Reply #388 on: January 03, 2021, 11:06:53 am »
Neither of which are server issues but rather quirks of SMF sorry.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 4592
  • Country: nl
Re: Server Error Reports
« Reply #389 on: January 03, 2021, 11:09:09 am »
And I still can't attach the inserted full-size image. See previous post: I specified inline full-size, but it still inserts as a tumb.

The plugin was disabled, the options still show but they do nothing. I think it was disabled in search of the mysterie picture swapping.
If it stays disabled it would be best to remove the options too.
Keyboard error: Press F1 to continue.
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1241
  • Country: au
Re: Server Error Reports
« Reply #390 on: January 03, 2021, 11:11:17 am »
And I still can't attach the inserted full-size image. See previous post: I specified inline full-size, but it still inserts as a tumb.

The plugin was disabled, the options still show but they do nothing. I think it was disabled in search of the mysterie picture swapping.
If it stays disabled it would be best to remove the options too.

I will suggest to Dave to re-enable it as I am pretty confident it was not the cause.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 

Offline S. Petrukhin

  • Super Contributor
  • ***
  • Posts: 1031
  • Country: ru
Re: Server Error Reports
« Reply #391 on: January 03, 2021, 11:24:14 am »
And I still can't attach the inserted full-size image. See previous post: I specified inline full-size, but it still inserts as a tumb.

The plugin was disabled, the options still show but they do nothing. I think it was disabled in search of the mysterie picture swapping.
If it stays disabled it would be best to remove the options too.

But I can see how other users display full-screen images...
And sorry for my English.
 

Offline S. Petrukhin

  • Super Contributor
  • ***
  • Posts: 1031
  • Country: ru
Re: Server Error Reports
« Reply #392 on: January 03, 2021, 11:27:01 am »
Neither of which are server issues but rather quirks of SMF sorry.

Can someone fix this? It seems to me that there is simply no file 00.gif in the directory with flags.  :)
And sorry for my English.
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1241
  • Country: au
Re: Server Error Reports
« Reply #393 on: January 03, 2021, 11:29:43 am »
Neither of which are server issues but rather quirks of SMF sorry.

Can someone fix this? It seems to me that there is simply no file 00.gif in the directory with flags.  :)

You're posing into `Server Error Reports`, not `Forum Error Reports`. I am the server admin, not forum admin, this is up to Dave
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 4592
  • Country: nl
Re: Server Error Reports
« Reply #394 on: January 03, 2021, 11:31:27 am »
But I can see how other users display full-screen images...

Attach the image to your post and save, then copy the link for the full-sized image, edit your post and put the link between img tags.
Anyway, this thread is not for this stuff, so I will not post more. If you can't work it out ask in general.
Keyboard error: Press F1 to continue.
 
The following users thanked this post: gnif, MK14, S. Petrukhin

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 2884
  • Country: ro
Re: Server Error Reports
« Reply #395 on: January 06, 2021, 10:32:01 am »
Not really an error, but it is very slow and very laggy again.  Text is reasonably OK, but pics are unusable slow to me.

Took about 10-20 seconds to open the two attachments here https://www.eevblog.com/forum/metrology/software-for-automated-testing-(scpi)/msg3402554/#msg3402554 (less than 200k).

This happens only with EEVblog forum, other websites are as snappy as last year.   :-//

Happens with all the pics, these took 3-5 seconds to open each:
https://www.eevblog.com/forum/testgear/rigol-dsxxxx-gel-firmware-file-format/msg3402398/#msg3402398

Even the forum elements, like the black grid with circles background seems slow, in the sense that it feels like the page is waiting for them.
« Last Edit: January 06, 2021, 10:37:29 am by RoGeorge »
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1241
  • Country: au
Re: Server Error Reports
« Reply #396 on: January 06, 2021, 10:35:02 am »
Loading extremely fast for me, and I am not local (AU vs US) to the server. Local route or ISP issue for you sorry.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 2884
  • Country: ro
Re: Server Error Reports
« Reply #397 on: January 06, 2021, 11:18:40 am »
I'm seeing a lot of weird "pagespeed" URL's, don't know if a week or so ago, when the forum was working great, was the same.

https://stackoverflow.com/questions/13113383/weird-pagespeed-url-for-png-image

Already deleted all caches and cookies, and it is as bad as before deletion.
Does by any chance Google Pagespeed was somehow turned on this year?  Usually browsing from a desktop with latest Kubuntu/Firefox.

Just tested moments ago with Pale Moon, and EEvblog forum is almost unusable, will install just for a quick test Chromium...

Offline gnif

  • Administrator
  • *****
  • Posts: 1241
  • Country: au
Re: Server Error Reports
« Reply #398 on: January 06, 2021, 11:20:34 am »
I'm seeing a lot of weird "pagespeed" URL's, don't know if a week or so ago, when the forum was working great, was the same.

https://stackoverflow.com/questions/13113383/weird-pagespeed-url-for-png-image

Already deleted all caches and cookies, and it is still very bad.
Does by any chance Google Pagespeed was somehow turned on this year?  Usually browsing from a desktop with latest Kubuntu/Firefox.

Just tested moments ago with Pale Moon, and EEvblog forum is almost unusable, will install just for a quick test Chromium...

We have had pagespeed installed and active on the server for well over 2 years now. This is not the cause of any issues you are having. I collect performance metrics from 4 countries every 2 minutes across all of Dave's cluster, at current, there is not, nor has there been any degradation in performance and all pages are rendering correctly. If you are experiencing issues it is on your end.
« Last Edit: January 06, 2021, 11:23:38 am by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 

Offline Ranayna

  • Frequent Contributor
  • **
  • Posts: 417
  • Country: de
Re: Server Error Reports
« Reply #399 on: January 06, 2021, 01:50:44 pm »
For what it's worth: The forum was really slow for me intermittently today as well. At the moment it's better, but still somewhat slow.

EDIT: Debatable whether this is a server issue or a forum issue  :-//

What i see in the network tab of Chrome, is that mainly external stuff takes long to load. The main culprit seems to be supplyframe.com. Almost all requests to them take 500 to 1000 miliseconds to load, and there are quite a few of them.
« Last Edit: January 06, 2021, 02:00:34 pm by Ranayna »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf