Author Topic: Server Error Reports  (Read 335409 times)

0 Members and 3 Guests are viewing this topic.

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 3197
  • Country: ro
Re: Server Error Reports
« Reply #425 on: April 08, 2021, 03:12:52 pm »
From the other topic I understand the current setup after the fire is not final, so this is just FYI, not a complaint.

- From here many pages (about 1 out of 10 clicks or so) return "502 Bad Gateway nginx" at the first click.  At a second try or after an F5 page refresh, it works.
- Pages are much slower than before the fire.
 
The following users thanked this post: SilverSolder

Offline dcac

  • Frequent Contributor
  • **
  • Posts: 336
Re: Server Error Reports
« Reply #426 on: April 08, 2021, 11:27:48 pm »
I realize we're not yet fully up and running. But just FYI I'm having strange problems staying logged in - I just made a post in this thread: https://eevblog.com/forum/testgear/hantek-cc-65-acdc-current-probe-teardown-and-testing/

And it went fine - but if I now enters that thread again I immediately get logged out - if I log back in I get directed to here: https://www.eevblog.com/forum/testgear/?wwwRedirect

Entering any other thread seems to work fine. I tried deleting my cookies for EEVBlog - but that did not change any thing.

Also if I deliberately jump between those two url's - I'm showed as logged out in the cc-65 thread but as logged in the other and as it seems most other threads too.

UPDATE: after making this post I rechecked the behavior and it's still the same. However I can enter this thread without any problems and i.e. make this update to my post.

UPDATE-2: If I now try to log in while I'm in the cc-65 thread I get this error:
Code: [Select]
An Error Has Occurred!
Unable to verify referring url. Please go back and try again.
« Last Edit: April 08, 2021, 11:54:38 pm by dcac »
 

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 3197
  • Country: ro
Re: Server Error Reports
« Reply #427 on: April 08, 2021, 11:57:15 pm »
I can enter to that topic just fine, but only if I manually insert WWW into the URL.

with www
https://www.eevblog.com/forum/testgear/hantek-cc-65-acdc-current-probe-teardown-and-testing/
- I can see it as a logged user

without www
https://eevblog.com/forum/testgear/hantek-cc-65-acdc-current-probe-teardown-and-testing/
- I can see it as a not logged visitor, even if I am logged into the www version
- if I return to a page starting with www, I am still logged into www.eevblog.com/forum

Looks to me like the login from "WWW.eevblog.com" is not valid in "eevblog.com".
The WWW address is working just fine for me.  I didn't try to log into 'eevblog.com', since I am usually using the www prefix.

Why are you trying to use the address without the leading www?
 
The following users thanked this post: dcac

Offline dcac

  • Frequent Contributor
  • **
  • Posts: 336
Re: Server Error Reports
« Reply #428 on: April 09, 2021, 12:13:53 am »
Thanks for testing.

I entered the thread from my usual bookmark which has the leading WWW. I didn't realize that had disappeared when I then maneuvered between the links.

But I think I've solved it now. In Firefox I've now used 'Forget about this site' on (www).eevblog - interestingly after that the cc-65 thread was still present in my history - likely as you pointed out it was missing the WWW - so I used forget about those links too and now after logging in everything seems to be working fine. And when using my same old bookmark the www now remains in the links.
« Last Edit: April 09, 2021, 12:15:35 am by dcac »
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 22071
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #429 on: April 09, 2021, 01:08:14 am »
Possibly another little server problem in that email notification of PM's does not seem to be working.  :-//

Normally email notification of PM's is almost instant.......unless Gmail has some problem.

Anyone else seeing this ?
Avid Rabid Hobbyist
 

Online xrunner

  • Super Contributor
  • ***
  • Posts: 5499
  • Country: us
  • hp>Agilent>Keysight>?
Re: Server Error Reports
« Reply #430 on: April 09, 2021, 01:10:29 am »
Possibly another little server problem in that email notification of PM's does not seem to be working.  :-//

Normally email notification of PM's is almost instant.......unless Gmail has some problem.

Anyone else seeing this ?

Yes I am.
My friends say they're procrastinators. I say I've been meaning to tell them for years, but I just keep putting it off.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 22071
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #431 on: April 09, 2021, 02:12:50 am »
Possibly another little server problem in that email notification of PM's does not seem to be working.  :-//

Normally email notification of PM's is almost instant.......unless Gmail has some problem.

Anyone else seeing this ?

Yes I am.
:-DD
Yes your PM arrived without email notification which had me wondering and it might seem like my reply didn't get to your email either.
Poor gnif....isn't it like he has enough to do already !
Avid Rabid Hobbyist
 

Offline beanflying

  • Super Contributor
  • ***
  • Posts: 6576
  • Country: au
  • Toys so very many Toys.
Re: Server Error Reports
« Reply #432 on: April 09, 2021, 03:33:40 am »
Likely will need to reconfigure SMF as it treats the email notifications on the periphery so depending on where it was pointed to send from likely tweakage needed. I had a major  |O when I set up an SMF forum in the past on AWS because of this. So anyone suggesting Amazon as the solution here consider yourself pre :horse:
Coffee, Food, R/C and electronics nerd in no particular order. Also CNC wannabe, 3D printer and Laser Cutter Junkie and just don't mention my TEA addiction....
 

Offline EEVblog

  • Administrator
  • *****
  • Posts: 33272
  • Country: au
    • EEVblog
Re: Server Error Reports
« Reply #433 on: April 09, 2021, 05:44:58 am »
Likely will need to reconfigure SMF as it treats the email notifications on the periphery so depending on where it was pointed to send from likely tweakage needed. I had a major  |O when I set up an SMF forum in the past on AWS because of this. So anyone suggesting Amazon as the solution here consider yourself pre :horse:

Anyone else seeing a broken Thanks button?

 
The following users thanked this post: Yansi, 2N3055, beanflying

Offline beanflying

  • Super Contributor
  • ***
  • Posts: 6576
  • Country: au
  • Toys so very many Toys.
Re: Server Error Reports
« Reply #434 on: April 09, 2021, 06:27:50 am »
Likely will need to reconfigure SMF as it treats the email notifications on the periphery so depending on where it was pointed to send from likely tweakage needed. I had a major  |O when I set up an SMF forum in the past on AWS because of this. So anyone suggesting Amazon as the solution here consider yourself pre :horse:

Anyone else seeing a broken Thanks button?



Only related to time out issues I think. Took maybe 10 seconds to get it done  |O
Coffee, Food, R/C and electronics nerd in no particular order. Also CNC wannabe, 3D printer and Laser Cutter Junkie and just don't mention my TEA addiction....
 

Online Cerebus

  • Super Contributor
  • ***
  • Posts: 8328
  • Country: gb
Re: Server Error Reports
« Reply #435 on: April 09, 2021, 08:15:03 am »
Likely will need to reconfigure SMF as it treats the email notifications on the periphery so depending on where it was pointed to send from likely tweakage needed. I had a major  |O when I set up an SMF forum in the past on AWS because of this. So anyone suggesting Amazon as the solution here consider yourself pre :horse:

Anyone else seeing a broken Thanks button?



My brain initially parsed that screenshot as saying "There was an error while thinking" - there are posts of mine where I could have made good use of that button. New feature request?  :)

And I could "thank" your message without any problems, and withdraw it without any problems.

Or are you just trawling for a little bit of extra approval after a hard week?  :)
Anybody got a syringe I can use to squeeze the magic smoke back into this?
 

Offline MK14

  • Super Contributor
  • ***
  • Posts: 2921
  • Country: gb
Re: Server Error Reports
« Reply #436 on: April 09, 2021, 01:34:00 pm »
Likely will need to reconfigure SMF as it treats the email notifications on the periphery so depending on where it was pointed to send from likely tweakage needed. I had a major  |O when I set up an SMF forum in the past on AWS because of this. So anyone suggesting Amazon as the solution here consider yourself pre :horse:

Anyone else seeing a broken Thanks button?



No, seems to be working just fine.

It always (for me), did that "error while thanking" thing, around 5% to 15%, of the time BEFORE the disaster/fire/reconstruction. But I just assumed it was an occasional poor connection on my part, or somewhat rare/minor problem with the EEVblog server.
« Last Edit: April 09, 2021, 01:39:21 pm by MK14 »
 

Online bd139

  • Super Contributor
  • ***
  • Posts: 20502
  • Country: gb
Re: Server Error Reports
« Reply #437 on: April 09, 2021, 03:50:53 pm »
Yeah was always borked randomly.

Also "insert quote" appears to periodically not do anything at the moment since the outage as well.
 

Offline AlfBaz

  • Super Contributor
  • ***
  • Posts: 2133
  • Country: au
Re: Server Error Reports
« Reply #438 on: April 09, 2021, 10:38:42 pm »
Working fine here but its always displayed exactly that on the mobile version of the site
 

Offline EEVblog

  • Administrator
  • *****
  • Posts: 33272
  • Country: au
    • EEVblog
Re: Server Error Reports
« Reply #439 on: April 11, 2021, 05:24:32 am »
FYI, new account activation emails and moderator report email seems to be down due to the private network in the datacentre not back online yet. No ETA for that yet.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 22071
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #440 on: April 11, 2021, 05:25:48 am »
FYI, new account activation emails and moderator report email seems to be down due to the private network in the datacentre not back online yet. No ETA for that yet.
PM emails not working either.
Avid Rabid Hobbyist
 

Offline T3sl4co1l

  • Super Contributor
  • ***
  • Posts: 17735
  • Country: us
  • Expert, Analog Electronics, PCB Layout, EMC
    • Seven Transistor Labs
Re: Server Error Reports
« Reply #441 on: April 12, 2021, 04:49:36 pm »
Been getting session timeouts on reply -- think this was a setting, maybe just wasn't reloaded properly?

Tim
Seven Transistor Labs, LLC
Electronic design, from concept to prototype.
Bringing a project to life?  Send me a message!
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1278
  • Country: au
Re: Server Error Reports
« Reply #442 on: April 13, 2021, 12:04:40 am »
Until we get both servers back up we will continue to see such issues. GorillaServers did upgrade our hardware as part of the restoration however we are still operating on a single server, and the setup is not tuned to take advantage of the higher performance processors. I am continuing to tune the setup however we have to be careful to not overload the single server (process/memory exhaustion) as doing so would cause things to exponentially slow down. Each setting tweak needs 24 hours of verification through server metrics to ensure that during peak loads (Lunch in the US) we don't exceed the server's capabillity.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 
The following users thanked this post: xrunner, beanflying, DrG

Offline SilverSolder

  • Super Contributor
  • ***
  • Posts: 5145
  • Country: 00
Re: Server Error Reports
« Reply #443 on: April 13, 2021, 12:48:25 am »

I've noticed significantly better performance today, overall.  Looks like recovery is under way!
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1278
  • Country: au
Re: Server Error Reports
« Reply #444 on: April 13, 2021, 12:54:29 am »
Unfortunately not yet, this is a result of server tuning :)
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 
The following users thanked this post: EEVblog, tautech, SilverSolder, Jacon

Offline gnif

  • Administrator
  • *****
  • Posts: 1278
  • Country: au
Re: Server Error Reports
« Reply #445 on: April 14, 2021, 01:34:11 pm »
Another outage! Looks like power to BOTH of the current working EEVBlog servers was interrupted. Waiting for GS to explain this one.

https://twitter.com/HostFission/status/1382325389813485570

Edit: Multiple reports on WebHostingTalk of others experiencing the same issue, servers powered off and needing to be manually turned back on via IPMI, etc... No news from GS on the cause yet though.
« Last Edit: April 14, 2021, 01:36:59 pm by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission
https://twitter.com/Geoffrey_McRae
 
The following users thanked this post: EEVblog, MK14

Offline SilverSolder

  • Super Contributor
  • ***
  • Posts: 5145
  • Country: 00
Re: Server Error Reports
« Reply #446 on: April 14, 2021, 02:41:34 pm »

I guess that after the backup generator burned, they are vulnerable to external power interruptions?
 

Offline Bud

  • Super Contributor
  • ***
  • Posts: 4907
  • Country: ca
Re: Server Error Reports
« Reply #447 on: April 14, 2021, 02:47:33 pm »
Another outage! Looks like power to BOTH of the current working EEVBlog servers was interrupted. Waiting for GS to explain this one.

https://twitter.com/HostFission/status/1382325389813485570

 :-//
Facebook-free life and Rigol-free shack.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 22071
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #448 on: April 19, 2021, 01:01:10 am »
Forum PM email notification now working.  :)
Avid Rabid Hobbyist
 

Offline EEVblog

  • Administrator
  • *****
  • Posts: 33272
  • Country: au
    • EEVblog
Re: Server Error Reports
« Reply #449 on: April 19, 2021, 01:13:58 am »
Forum PM email notification now working.  :)

Yep, we had to revert back to the forum email system directly. So this may result in some systems detecting it as spam. But at least it's all working again  :phew:
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf