Author Topic: Server Error Reports  (Read 757160 times)

0 Members and 2 Guests are viewing this topic.

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 6464
  • Country: ro
Re: Server Error Reports
« Reply #625 on: June 17, 2023, 04:16:38 pm »
I've just tried a post from LibreWolf, and didn't work.
Then alt+tab to this brand new Brave and it worked.  This was posted with Brave.

Since nobody else sees the same error, maybe it's something on my side.
Will try in the next days from other live OS's, more browsers and more addresses, and let you know the results.

Thank you for the help.  :-+

Offline gnifTopic starter

  • Administrator
  • *****
  • Posts: 1691
  • Country: au
Re: Server Error Reports
« Reply #626 on: June 17, 2023, 04:17:29 pm »
Sorry but it needs to be a PM as this is the code I have patched
 

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 6464
  • Country: ro
Re: Server Error Reports
« Reply #627 on: June 17, 2023, 04:22:12 pm »
I have made a change to the code to log additional information, can you please re-try the PM post. I need it to generate the error so I can see what is going on, feel free to spam me until it occurs again.

Sent you this
Quote
PM sent to regenerate the error, as you requested

 from LibreWolf (didn't work) same " The following error or errors occurred while posting this message:

    Your session timed out while posting. Please try to re-submit your message.

"
I hope you can see it in the logs.  For now this Brave login seems 100% reliable.

Offline gnifTopic starter

  • Administrator
  • *****
  • Posts: 1691
  • Country: au
Re: Server Error Reports
« Reply #628 on: June 17, 2023, 04:22:24 pm »
I just saw the attempts, unfortunately there wasn't enough information logged and I need it again now I have added some additional logging.
 
The following users thanked this post: RoGeorge

Offline gnifTopic starter

  • Administrator
  • *****
  • Posts: 1691
  • Country: au
Re: Server Error Reports
« Reply #629 on: June 17, 2023, 04:25:06 pm »
Ok, it's actually not a server side issue :)

The reason for the failure is `session_verify_fail` which is because you're switching browsers, SMF checks your logged in session is using the same user agent as it was logged in with. The only way this can really happen is if your two browsers are sharing the same cache/store so they are using the same cookies with the session ID in them.



Going to a VPN changes your IP, so your session is completely invalidated and restarted.
« Last Edit: June 17, 2023, 04:28:49 pm by gnif »
 
The following users thanked this post: RoGeorge, MK14

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 6464
  • Country: ro
Re: Server Error Reports
« Reply #630 on: June 17, 2023, 05:29:27 pm »
That was strange.  Will logoff from all browsers and clean all cookies just to be sure.  The err didn't happen before yesterday.  Maybe one of these browsers updated themselves yesterday.  I always thought LibreWolf and Firefox were completely independent from each other.

Sorry for taking your time with this, and thank you for finding the cause.
 
The following users thanked this post: gnif

Offline gnifTopic starter

  • Administrator
  • *****
  • Posts: 1691
  • Country: au
Re: Server Error Reports
« Reply #631 on: June 18, 2023, 02:19:23 am »
Just an update, one of the packages upgraded seems to be causing an issue with the database backup procedure which runs each night at 22:00 UTC. The database is being locked during the backup which should not occur, which is causing a brief outage while the backup happens.

I have implemented what I hope is a fix to this issue and running another backup to see if it's resolved.

The fix worked and this has been resolved.

I noticed that my /unread/ list gets cleared randomly since maybe yesterday. I think it first happened after some outage (database connection error, bad gateway), but now it happened again without any outage that I noticed.

Now I have had more time to think on this, this backup issue actually explains this also. We are using ProxySQL to load balance between the servers, but all writes still are directed to one server to avoid issues with SMF's inability to handle mysql errors for retry correctly when there is an ID clash due to a insert record race (SMF is simply not designed for clustered setup). The only writes that are not directed to a single server are those of temporary tables which is what the /unread/ feature uses. ProxySQL tracks which server your connection is on if your session makes a temporary table and pins you to it.

When I need to service a MySQL backend often it involves restarting the service, which then causes ProxySQL to redirect you to the working server. At this point the temporary table associated with your session is gone and thus, your unread list is cleared until SMF has decided enough time has elapsed to re-create the table. This timeout is to avoid overloading the back end as it's quite an intensive operation to generate this list.

Because the backup process was locking the backend for writes, ProxySQL was treating the server as offline and invalidating all sessions on it.
 
The following users thanked this post: magic

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 6464
  • Country: ro
Re: Server Error Reports
« Reply #632 on: June 18, 2023, 09:05:12 am »
Just FIY, found what was causing the misbehave in my Firefox and LibreWolf browser.  It's a Firefox plugin called 'Dark Reader' (it was installed and enabled in both browsers).  The plugin is automatically changing colors and backgrounds, so it turns light webpages into "night-mode" dark colored webpages.

If I enable 'Dark Reader' for EEVblog.com, I get the error and can not post, if I disable Dark Reader (for EEVblog only) then click post, I can post just as usual.

Now, I don't know if 'Dark Reader' extension is compromised and trying to hijack my session IDs, or maybe it is something else.  What I've tested twice, including while sending this, is that I can not post while 'Dark Reader' is active but if I disable Dark Reader for EEvblog then click Post again, it will work.  There are no other open browser, and I've closed all pages already, logout, and delete all cookies then restart FF and login.

Are there any graphical elements sent from EEVblog, and linked to the user session ID, such that a color changing plugin as 'Dark Reader' might alter and thus compromise the session ID?

Offline gnifTopic starter

  • Administrator
  • *****
  • Posts: 1691
  • Country: au
Re: Server Error Reports
« Reply #633 on: June 18, 2023, 09:14:41 am »
Are there any graphical elements sent from EEVblog, and linked to the user session ID, such that a color changing plugin as 'Dark Reader' might alter and thus compromise the session ID?
No

The addon per-chance altering your browsers useragent?

Logs show the following user agents have been used today from your IP:

Code: [Select]
Mozilla/5.0 (Windows NT 10.0; rv:114.0) Gecko/20100101 Firefox/114.0
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.0.0 Safari/537.36
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/114.0
« Last Edit: June 18, 2023, 09:19:04 am by gnif »
 
The following users thanked this post: RoGeorge

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 6464
  • Country: ro
Re: Server Error Reports
« Reply #634 on: June 18, 2023, 10:49:37 am »
I don't know if Dark Reader (or something else) is messing with the reported user agent.  AFAIK I have nothing installed to masquerade the browser type or the OS.  Never tried to hide them.

I've posted today once from Brave 1.52 (Chromium 114.0.5735)/Kubuntu 22.04.2 LTS, and the rest from Firefox (114.0.1 snap from canonical)/same Kubuntu OS.

It certainly happens something weird on my side, because I didn't fire up a Windows OS in months.  ???
Thanks for the log feedback.  Will investigate what's wrong with my PC.
 
The following users thanked this post: gnif

Offline T3sl4co1l

  • Super Contributor
  • ***
  • Posts: 21974
  • Country: us
  • Expert, Analog Electronics, PCB Layout, EMC
    • Seven Transistor Labs
Re: Server Error Reports
« Reply #635 on: June 22, 2023, 06:17:48 pm »
Uh oh, image cache / sync discrepancies may have returned?
https://www.eevblog.com/forum/beginners/is-this-the-right-capacitor/
At least from my end at time of writing, I see one thumbnail (closeup of a board?) in the OP attachment, but the expanded image is identical to the attachment three posts below.

(I don't know offhand if this might just be a case of the OP editing their attachment, maybe a mod/admin can tell?)

Tim
Seven Transistor Labs, LLC
Electronic design, from concept to prototype.
Bringing a project to life?  Send me a message!
 

Offline gnifTopic starter

  • Administrator
  • *****
  • Posts: 1691
  • Country: au
 

Offline drakejest

  • Regular Contributor
  • *
  • Posts: 200
  • Country: 00
Re: Server Error Reports
« Reply #637 on: June 24, 2023, 08:22:16 pm »
Hello I would like to add that i have also been unable to post,comment, login, and logout. It is just now that im trying again ( not tried posting again yet), with the same error as others did

Quote
The following error or errors occurred while posting this message:
Your session timed out while posting. Please try to re-submit your message.

I tried using chrome, and firefox and i was using dark reader on both (not tried disabling it). it happened sometime in the last 7 days

edit: It is still happening now, and i tried disabling dark reader this time and was able to post this comment. Have we already know whats happening because i would like to continue using dark reader, light mode just hurts my eyes.
« Last Edit: June 24, 2023, 08:23:57 pm by drakejest »
 

Offline gnifTopic starter

  • Administrator
  • *****
  • Posts: 1691
  • Country: au
Re: Server Error Reports
« Reply #638 on: June 24, 2023, 08:34:43 pm »
As per the prior diagnostics performed, this is a client side issue. The server checks if your user agent changes during your login session (which should NEVER happen) as a security measure. Clear your cookies, make sure your browsers are not sharing the same cookie store, etc.
 

Offline magic

  • Super Contributor
  • ***
  • Posts: 6919
  • Country: pl
Re: Server Error Reports
« Reply #639 on: June 25, 2023, 09:57:39 am »
Just an update, one of the packages upgraded seems to be causing an issue with the database backup procedure which runs each night at 22:00 UTC. The database is being locked during the backup which should not occur, which is causing a brief outage while the backup happens.

I have implemented what I hope is a fix to this issue and running another backup to see if it's resolved.

The fix worked and this has been resolved.

I noticed that my /unread/ list gets cleared randomly since maybe yesterday. I think it first happened after some outage (database connection error, bad gateway), but now it happened again without any outage that I noticed.

Now I have had more time to think on this, this backup issue actually explains this also. We are using ProxySQL to load balance between the servers, but all writes still are directed to one server to avoid issues with SMF's inability to handle mysql errors for retry correctly when there is an ID clash due to a insert record race (SMF is simply not designed for clustered setup). The only writes that are not directed to a single server are those of temporary tables which is what the /unread/ feature uses. ProxySQL tracks which server your connection is on if your session makes a temporary table and pins you to it.

When I need to service a MySQL backend often it involves restarting the service, which then causes ProxySQL to redirect you to the working server. At this point the temporary table associated with your session is gone and thus, your unread list is cleared until SMF has decided enough time has elapsed to re-create the table. This timeout is to avoid overloading the back end as it's quite an intensive operation to generate this list.

Because the backup process was locking the backend for writes, ProxySQL was treating the server as offline and invalidating all sessions on it.

Hi gnif, I hoped this means that /unread/ behavior would return to normal, but it hasn't.
My list is still getting cleared occasionally, maybe once per day on average. It currently goes back to 6:28AM UTC today.

I am not the only one, apparently:
https://www.eevblog.com/forum/supporters-lounge/show-unread-posts-since-last-visit/


I understand that this architecture implies that database outages are likely to get my list cleared and this isn't going to change anytime soon, but it hasn't been a daily occurrence until last week.
« Last Edit: June 25, 2023, 10:00:20 am by magic »
 

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 6464
  • Country: ro
Re: Server Error Reports
« Reply #640 on: June 25, 2023, 10:17:11 am »
edit: It is still happening now, and i tried disabling dark reader this time and was able to post this comment. Have we already know whats happening because i would like to continue using dark reader, light mode just hurts my eyes.

To have a dark themed EEVblog, I keep 'Dark Reader' on, and tell 'Dark Reader' to not interact with EEVblog.  To do that, open any forum page, click on the 'Dark Reader' icon, then click on the top box in the dark reader settings where it is written "www.eevblog.com".  The "v www.eevblog.com" textbox will change into "x www.eevblog.com", and the EEVblog will become light themed, while the rest of the internet will remain dark-themed.

To make EEVblog forum dark themed (without Dark Reader), either change your forum settings to use a dark-theme (this forum used to have at least one), or do like I did, add another extension to the Firefox, called "Stylus".

With "Stylus" you can entirely redesign the appearance of the forum upon wish, including color changes.  I am using this 'Stylus/Grease Monkey' script to change the EEVblog pages into dark-themed:
Code: [Select]
h1 {font-size: 1.30em !important}
h2 {font-size: 1.20em !important}
h3 {font-size: 1.10em !important}
h4 {font-size: 1.00em !important}
h5 {font-size: 0.90em !important}
h6 {font-size: 0.80em !important}

xx-large {font-size: 1.3em !important}
x-large  {font-size: 1.2em !important}
large    {font-size: 1.1em !important}
medium   {font-size: 1.0em !important}
small    {font-size: 0.9em !important}
x-small  {font-size: 0.8em !important}
xx-small {font-size: 0.7em !important}

html, body, p, table, th, tr, td, div, a, form, frame, input, script, ul, ol, dl {
   /*font-family: Verdana !important; */
   /*font-size: 9pt !important;*/
}
pre, tt, code {
   font-family: Hack !important;
   font-size: 8pt !important;
   background: grey;
   color: yellow;
   border-radius: 4px !important;
}
blockquote, q {
   /*font-style: italic !important; */
   /*font-size: 1.0em !important;*/
}


/* EEVblog Forum */
.frame, .roundframe, .plainbox, .dropmenu a, .hslice td, .titlebg td,
.tborder>.description, .main_content>.description, #recent>.description,
#header, #content_section, #footer_section, #main_container p {
   background: #222 !important;
   color: #fff !important;
}
#upper_section, .cat_bar, .catbg, .table_grid th {
   background: #357 !important;
   border-radius: 5px !important;
}
div.title_bar, h3.titlebg {
   background: #357 !important;
   color: #fff !important;
}
div.title_barIC, h4.titlebg {
   background: #555550 !important;
   color: #fff !important;
}
div.additional_row {
   background: none !important;
}



/*
my tests begin
*/

/* also working, from MarkF
[url]https://www.eevblog.com/forum/programming/css-to-remove-eevblog-sideways-scroll-for-inline-attached-pics/[/url]

.bbc_img, .resized, [id*="thumb_"] {
   max-width: 100% !important;
}

*/

/* auto-shrink the inline attachement pics, so large pics won't need left-righ scrolling */
/* when attribute "id" starts with "thumb_", as in e.g. id="thumb_976862-0", do not overflow the width */
[id^="thumb_"] {
   max-width: 100%;
}

/*
.thumb_976862-0 {
    width:100%
}
*/

/*
CSS selector
*/

/*
#thumb_976862-0 img {
    width:100%
}
*/

/*
CSS path

html body div#wrapper div#content_section div.frame div#main_content_section div#forumposts form#quickModForm div.windowbg div.post_wrapper div.postarea div.post div#msg_3032334.inner img#thumb_976862-0
*/

/*
[attribute^="thumb"] {
    width:100%
}
*/

/*
my tests end
*/



.inner, .signature, .custom_fields_above_signature {
   border-color: #aaa !important;
}
.upperframe, .upperframe span, .lowerframe, .lowerframe span {
   height: 1px !important;
   background: #aaa !important;
   border-left: 1px solid #aaa !important;
   border-right: 1px solid #aaa !important;
}
.table_grid td {
   border: 1px solid #222 !important;
}
.hslice td {
   border: 1px solid #444 !important;
}
.info, .post, .signature h5 {
   background: inherit !important;
   color: #fff !important;
}
.forumtitle a {
   font-size: 16pt !important;
   font-weight: normal !important;
   background: inherit !important;
   color: #fff !important;
   text-decoration: none !important;
}
.greeting {
   font-weight: normal !important;
}
.username h4 {
   font-size: 14pt !important;
   background: inherit !important;
   color: #fff !important;
}
.list_posts {
   border-color: #aaa !important;
}
.lastpost, .navPages, .keyinfo h5, .floatleft h5, .windowbg td,  .windowbg2 td, .windowbg h4,
.reset a, .nextlinks a, .innerframe a, .roundframe a, .navigate_section a, .pagelinks a, .smalltext a,
.windowbg a, .windowbg2 a, .stickybg a, .stickybg2 a, .lockedbg a, .lockedbg2 a {
   background: inherit !important;
   color: #fff !important;
   text-decoration: none !important;
}
.windowbg, .windowbg span.topslice, .windowbg span.botslice,
.windowbg span.topslice span, .windowbg span.botslice span {
   background: #444 !important;
   color: #fff !important;
}
.windowbg2, .windowbg2 span.topslice, .windowbg2 span.botslice,
.windowbg2 span.topslice span, .windowbg2 span.botslice span {
   background: #333 !important;
   color: #fff !important;
}
.stickybg, .stickybg2, .title_barIC {
   background: #4c4c4c !important;
   color: #fff !important;
}
.lockedbg, .lockedbg a, .lockedbg2, .lockedbg2 a,
.locked_sticky2, .locked_sticky, .locked_sticky a, .locked_sticky2 a {
   background: #534 !important;
   color: #ccc !important;
}
.stickybg a, .stickybg2 a, .lockedbg a, .lockedbg2 a {
   font-weight: normal !important;
}
.thanks {
   font-style: italic !important;
   font-size: x-small !important;
   color: #fde18e !important;
}
.vob_protected, .vob_protected a:link, .vob_protected a:visited {
   color: #bdb !important;
}
.bbc_standard_quote {
   background: #555 !important;
}
.bbc_alternate_quote {
   background: #444 !important;
}
.bbc_standard_quote, .bbc_alternate_quote {
   /*font-size: 10pt !important;*/
   line-height: 1.2em !important;
   padding: 0.5em 1.0em !important;
   border-radius: 5px !important;
   border-color: #aaa !important;
   color: #fff !important;
}
.bbc_link:link, .bbc_link:visited {
   border-bottom: none !important;
   background: inherit !important;
   color: #ace !important;
}
.bbc_code {
   /*font-family: Consolas !important; */
   /*font-size: 10pt !important;*/
   line-height: 1.2em !important;
   padding: 0.5em 1.0em !important;
   max-height: 24.0em !important;
   border: 1px solid #aaa !important;
   border-radius: 5px !important;
   background: inherit !important;
   color: #fff !important;
}
.codeheader, .quoteheader {
   font-weight: bold !important;
   font-style: italic !important;
   background: inherit !important;
   color: #fff !important;
}
.firstlevel span {
   border: 1px solid #222 !important;
   border-radius: 5px !important;
   padding: 0em 0.5em !important;
   background: #555 !important;
   color: #fff !important;
}
.firstlevel span:hover {
   background: #e70 !important;
   border-radius: 5px !important;
}
.dropmenu a:hover {
   color: #e70 !important;
}
#upper_section input, #quick_edit_body_container textarea,
.generic_list input, .floatright input, .righttext input,
.content textarea, .content button, .content input, .content select,
.titlebg textarea, .titlebg button, .titlebg input, .titlebg select,
.plainbox textarea, .plainbox button, .plainbox input, .plainbox select,
.roundframe textarea, .roundframe button, .roundframe input, .roundframe select,
.description textarea, .description button, .description input, .description select {
   border: 1px solid #777770 !important;
   border-radius: 5px !important;
   background: #555550 !important;
   color: #fff !important;
}
.buttonlist a span, .buttonlist a.active span {
   background: none !important;
   color: #fff !important;
}
.buttonlist a {
   background: #555 !important;
   border-radius: 5px !important;
}
.buttonlist a:hover {
   background: #e70 !important;
   border-radius: 5px !important;
}
.buttonlist a.active:hover {
   background: #e70 !important;
   border-radius: 5px !important;
}
.forumtitle a:hover, .bbc_link:hover, .navPages:hover,
.reset a:hover, .nextlinks a:hover, .innerframe a:hover, .roundframe a:hover,
.navigate_section a:hover, .pagelinks a:hover, .smalltext a:hover,
.windowbg a:hover, .windowbg2 a:hover, .stickybg a:hover, .stickybg2 a:hover,
.lockedbg a:hover, .lockedbg2 a:hover {
   color: #e70 !important;
}
.arp_left {
   width: 45% !important;
}
.post img, .attachments img, .smiley {background: #eee !important;}
The script is the one made by MarkF with minor changes:  https://www.eevblog.com/forum/chat/forum-dark-theme/
I'm using that with Firefox, on a Linux desktop.  No idea if the same can be applied for phone/tablet browsers.


I've just tried to submit this post with 'Dark Reader' enabled and On for EEVblog, and got the "Your session timed out while posting" err, then forbid 'Dark Reader' to interact with EEVblog, then click Post (twice), and it worked.

Offline Monkeh

  • Super Contributor
  • ***
  • Posts: 8026
  • Country: gb
Re: Server Error Reports
« Reply #641 on: July 11, 2023, 07:30:23 pm »
Getting a session verification error when trying to unsubscribe from threads - have indeed tried turning it off and on again (and removed all cookies).

E: And now some random time later, it works again. :-//
« Last Edit: July 11, 2023, 08:26:40 pm by Monkeh »
 

Offline Karel

  • Super Contributor
  • ***
  • Posts: 2240
  • Country: 00
Re: Server Error Reports
« Reply #642 on: July 14, 2023, 07:55:22 am »
Here it never works. If I want to unsubscribe I must use the link in the email received when there's a new message in that thread.
I cleared the cache and cookies and put Firefox in "troubleshooting mode" (all addons disabled) and the problem persists.
I tried a fresh install of Chromium and have the same problem. And ofcourse, this only happens with this forum...

See also this thread: https://www.eevblog.com/forum/news/session-verification-failed/

Oh, and logging of from the forum is now always a two-step cycle. After the first attempt I get an error screen.
The second attempt works.
 
The following users thanked this post: Ed.Kloonk

Online 3apw

  • Contributor
  • Posts: 22
  • Country: ru
Re: Server Error Reports
« Reply #643 on: July 15, 2023, 07:58:55 am »
Hello EEVblog,

I have an issue with a NOTIFY function and my account in the https://www.eevblog.com/forum/testgear/phase-noise-analyzer-and-phase-noise-measurement/

System said: "Session verification failed. Please try logging out and back in again, and then try again."
According this advice I did it few times but without luck.

Could you please help with it?

Thanks, Karen
 

Online tggzzz

  • Super Contributor
  • ***
  • Posts: 20016
  • Country: gb
  • Numbers, not adjectives
    • Having fun doing more, with less
Re: Server Error Reports
« Reply #644 on: July 15, 2023, 10:13:45 am »
I've been intermittently seeing this sequence for a couple of weeks:
  • click "Show unread posts since last visit"
  • click interesting topics, opening them in separate tabs
  • spend tens of minutes reading those topics and closing their tab
  • return to "unread topics" tab, and click "mark all messages read"
  • get a session error, with the suggestion I login again [1]
  • click "Show unread posts since last visit" again; topic list reappears
  • click "mark all messages read" again, and there is no session error

Overall: a minor irritation, but might be indicative of something more significant.

[1] Session verification failed. Please try logging out and back in again, and then try again
« Last Edit: July 16, 2023, 08:36:13 pm by tggzzz »
There are lies, damned lies, statistics - and ADC/DAC specs.
Glider pilot's aphorism: "there is no substitute for span". Retort: "There is a substitute: skill+imagination. But you can buy span".
Having fun doing more, with less
 
The following users thanked this post: EEVblog

Online 3apw

  • Contributor
  • Posts: 22
  • Country: ru
Re: Server Error Reports
« Reply #645 on: July 15, 2023, 12:00:01 pm »
Thank you for the advice.  Unfortunately no luck.
 

Online FireBird

  • Regular Contributor
  • *
  • Posts: 68
  • Country: at
Re: Server Error Reports
« Reply #646 on: July 15, 2023, 09:10:29 pm »
For me it’s a bit more irritating:
  • click "Show unread posts since last visit"
  • click interesting topics, opening them in separate tabs
  • clicking on the next page of several pages of unread threads might result in a “No unread topics found since your last visit.” It’s like having clicked on “mark all messages read” which isn’t the case.
I have the feeling that the number of incidents has decreased within the some days.
 

Offline ledtester

  • Super Contributor
  • ***
  • Posts: 3109
  • Country: us
Re: Server Error Reports
« Reply #647 on: July 17, 2023, 06:10:11 am »
Here are some recent instances of thumbnails and pics not matching...

In this thread:

https://www.eevblog.com/forum/testgear/rigols-new-dho800-oscilloscope-unbox-teardown/

Reply #2
Reply #7
Reply #9
« Last Edit: July 17, 2023, 06:17:51 am by ledtester »
 

Online RoGeorge

  • Super Contributor
  • ***
  • Posts: 6464
  • Country: ro
Re: Server Error Reports
« Reply #648 on: July 17, 2023, 07:20:18 am »
This one here, too
https://www.eevblog.com/forum/projects/diy-modbus-rtu-fan-controller-coils-vs-registers/msg4964131/#msg4964131
the first thumbnail shows a screen capture with many opened windows, and when clicked it's another picture, with the printscreen of a text terminal instead.

Offline EEVblog

  • Administrator
  • *****
  • Posts: 38039
  • Country: au
    • EEVblog
Re: Server Error Reports
« Reply #649 on: July 19, 2023, 12:09:44 pm »
Here are some recent instances of thumbnails and pics not matching...

Sorry, I think that was me fiddling with a setting.
Try it again now.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf