Author Topic: Server Error Reports  (Read 201134 times)

0 Members and 1 Guest are viewing this topic.

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #200 on: June 25, 2020, 06:09:43 am »
System updates were applied which may have removed deprecated & insecure SSL cryptos.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Offline Muttley Snickers

  • Supporter
  • ****
  • Posts: 2116
  • Country: au
Re: Server Error Reports
« Reply #201 on: June 25, 2020, 06:11:31 am »
System updates were applied which may have removed deprecated & insecure SSL cryptos.
Bugger.   :palm:
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #202 on: June 25, 2020, 06:14:21 am »
The people demanded SSL, they got it, people then demanded SSL enforcement, and in the end, they got it...
Welcome to the "modern" world :P

And I am sure you understand that there is no way I am going to maintain a custom version of OpenSSL/Nginx, etc... just to re-enable old crypto algs. Sorry.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Offline Muttley Snickers

  • Supporter
  • ****
  • Posts: 2116
  • Country: au
Re: Server Error Reports
« Reply #203 on: June 25, 2020, 06:21:56 am »
No need to apologise, I am well overdue to update the TV as some other sites are not working anymore either. A friend gave me a Stick PC to resolve these issues but that gadget has been more trouble than it's worth.   :( 

https://www.eevblog.com/forum/chat/youtube-videos-no-longer-work-in-my-browser/
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #204 on: June 25, 2020, 06:27:04 am »
I recommend a RPi2 or better with LibreELEC on it.

https://libreelec.tv/

There is a Youtube addon, and even a EEVBlog one IIRC.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #205 on: June 25, 2020, 04:04:40 pm »
An alternative is FF on a FireTV. I picked up one of the older brick-style ones cheap; it's powerful enough (Quad-core, 2GB RAM, MIMO) even today, and it still supports up to 2K native streaming with all the PrimeVideo (of course) and Netflix-certified HD content working correctly (Widevine DRM, etc) and Amazon still keeps them updated.  :-+

But the big plus is that even if you DON'T root & flash (you would NEVER do that, right...?  >:D), they have the ExpressVPN client available in the Amazon App store. For me, this makes it possible to keep watching my Hulu, etc while "visiting" in the Great White North... your reasons for wanting a VPN would be none of my business.  ;)

mnem
 :-/O
« Last Edit: June 25, 2020, 04:06:54 pm by mnementh »
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #206 on: June 26, 2020, 06:16:17 am »
Happened again this afternoon. Had a post fail for new post warning; reposted seemed OK. Came back in the evening and it had gone blooey. I fixed it; not sure if you can follow the event history, but this is the post: https://www.eevblog.com/forum/testgear/test-equipment-anonymous-(tea)-group-therapy-thread/msg3105850/#msg3105850

Cheers,

mnem
 :popcorn:
 

Offline SilverSolder

  • Super Contributor
  • ***
  • Posts: 3448
  • Country: 00
Re: Server Error Reports
« Reply #207 on: June 26, 2020, 12:32:01 pm »
The people demanded SSL, they got it, people then demanded SSL enforcement, and in the end, they got it...
Welcome to the "modern" world :P

And I am sure you understand that there is no way I am going to maintain a custom version of OpenSSL/Nginx, etc... just to re-enable old crypto algs. Sorry.

I swear I spend half the day on complying with various security features on the systems I work with.   Overall, the cost is probably higher than the inconvenience of just disconnecting those systems from the Internet altogether...
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #208 on: June 26, 2020, 03:48:42 pm »
Oklay... now it seems to be getting personal. Same post: https://www.eevblog.com/forum/testgear/test-equipment-anonymous-(tea)-group-therapy-thread/msg3105850/#msg3105850; was fine last night after I fixed it, only now it's borked with a pic I just put up this AM in another thread.  |O

Should have this pic, not the screencap of a spacer that's there now:   

Lets see if this one goes blooey next time I post something with a pic...  :-\

« Last Edit: June 26, 2020, 03:59:36 pm by mnementh »
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #209 on: June 26, 2020, 03:51:56 pm »
Thanks yeah, don't fix this one if it breaks again. Each time you "fix" them I have zero information to go on.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #210 on: June 26, 2020, 04:06:17 pm »
Okay... no prob. Here's the post I just put up with the pic that seems to be going wherever it feels like: https://www.eevblog.com/forum/chat/3d-printer-yet/msg3106712/#msg3106712

So far, these are the borked posts:

https://www.eevblog.com/forum/testgear/test-equipment-anonymous-(tea)-group-therapy-thread/msg3105850/#msg3105850 <-- repeat borkee

https://www.eevblog.com/forum/chat/3d-printer-yet/msg3106050/#msg3106050 <-- newly borked

I went back a few pages before the repeat borkee post and everything there seems to be okay; but there were several posts I fixed before as well so no idea if they'll decide to get in on the fun next time I post a pic. :-//

mnem
Sorry to be so much hassle...  :palm:
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #211 on: June 26, 2020, 04:26:01 pm »
Oh, duh... should I wait until you have a chance to investigate the above borked posts to post more pics, or just go on about my business now so you can see any new trail of breadcrumbs?

mnem
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #212 on: June 27, 2020, 02:42:48 am »
Oklay... just happened again. Seems to be like... every time I post a pic, it borks one or more of my previous pics.  :wtf:

Lets see...



mnem
 |O
« Last Edit: June 27, 2020, 02:49:34 am by mnementh »
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #213 on: June 27, 2020, 02:44:20 am »
Huh...?



mnem
 |O
« Last Edit: June 27, 2020, 02:46:34 am by mnementh »
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #214 on: June 27, 2020, 02:49:16 am »
I have managed to replicate this, it seems to be caused when you try to post the message before the attachment has finished uploading, or you cancel an attachment and then upload another. Still trying to nut down the exact sequence of events that cause it.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #215 on: June 27, 2020, 02:56:58 am »
That last one was a .heic that I forgot to convert to .jpg . Of course... like we needed to add more confusion.

No, usually the progress bar completes like in half a sec; I may or may not see a thumb right then. Usually if I don't, it's because HEIC or some similar invalid filetype. I HAVE occasionally had it error out with something to the effect of "File too large or took too long to upload", even when I was only uploading a single pic like 1-1.5MB...?

Not in the last couple days, tho.  :-//

mnem
 :o
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #216 on: June 27, 2020, 03:04:29 am »
It seems to be behaving in here... for the moment.  ::)

However, this post: https://www.eevblog.com/forum/testgear/test-equipment-anonymous-(tea)-group-therapy-thread/msg3107484/#msg3107484

I added a 3rd pic after posting; 14-Manufacturer Info.jpg. It IMMEDIATELY showed up in place of the first pic in that post.

Then, just to see if it would happen again, I made another post. Then cyborg.jpg replaced both instances of that pic.  :-//

mnem
 :-[
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #217 on: June 27, 2020, 05:06:11 pm »


Seriously...? STILL behaving in here...? I've had to fix this damned pic like 6 times now in the TEA thread...  |O

mnem
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #218 on: June 28, 2020, 05:52:03 am »
I am sorry, I have had limited time of late and have not yet had an opportunity to dig any deeper into this.

There have been other higher priority issues to resolve before looking at this issue, I have spent the last few days working to get backups working after server updates, finally succeeded. Doing a remote incremental backup of the SMF attachment directory consisting of over half a million files (around 60GB) internationally is a nightmare. We are using GlusterFS which limits options with how to do this backup, otherwise, I would just mount an image over the attachment directory and snapshot its backing storage each time. (tar/gz of the directory is not an acceptable option due to server load concerns)
« Last Edit: June 28, 2020, 05:56:09 am by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Online mnementh

  • Super Contributor
  • ***
  • Posts: 9699
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #219 on: June 28, 2020, 04:01:43 pm »
Oh, man... I'm so sorry.  :-[

I didn't mean to make it sound like I was unhappy with your work; I wouldn't have your job for all the money in the world. ;) I would literally rather work HellDesk in a borg cubicle ship again.  :-DD

No, I was grousing about Murphy being a little skank; REFUSING to propagate the fault in here, where it would be easy for you to see.  :P

Carry on, sir. We all know (at least everyone I hang out with) that you're doing the best you can with limited resources.

Oh, and thanks for all the hard work. Don't think we haven't noticed you monitoring the TEA thread at 2am; we grok the dedication therein.  :-+

mnem
 :clap:
 
The following users thanked this post: bitseeker

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 2596
  • Country: dk
  • Country: Broken Britain
CML+  That took much longer than I thought it would.
 

Offline rhb

  • Super Contributor
  • ***
  • Posts: 3083
  • Country: us
Re: Server Error Reports
« Reply #221 on: July 01, 2020, 01:53:41 pm »
I tried to post 3 photos, some quoted text and a comment a little while ago.   When I hit "post" I got an "upload files" dialog and when I clicked OK it simply hung.  An attempt to post from another browser tab led to it getting posted missing my comments and 2 of 3 photos.  I had a similar experience about a week ago shortly after which the forum became inaccessible for several hours.

Reg
 

Offline DrG

  • Frequent Contributor
  • **
  • Posts: 474
  • Country: us
Re: Server Error Reports
« Reply #222 on: July 01, 2020, 02:04:43 pm »
Regarding the mysterious picture adds/replacements. I caught this problem in mid post that might give some clues to what is going on....

I am entering in a new post. I add a picture. In this case it is a picture of a mushroom in a photography focus stacking thread. I do the usual and add the pic, the post has not been sent.

In another window, I then scrolled through my old posts to find one that I intended to link into the post that is still open.

My eye caught that the pic of the mushroom had been substituted for a post of a graph in a corona virus thread - literally added to the post and when viewing the post, I can see that it was added and I could also see a notice:

There are attachments found, which you have attached before but not posted. These attachments are now attached to this post. If you do not want to include them in this post, you can remove them here.

So leaving an unattached photo (as when you are writing but have not submitted a post) is fair game to be inserted into any of ones posts that you view (not modify). Sounds nutty, but it looks like that is what just happened. I will complete the post and edit this message to see if it changes.

EDIT: as you can see, the pic in "limbo" got attached to this post. I did not add it to this post as per normal. Now that I know, I will be sure to have all my pics for a post lined up before opening any other windows or doing any other actions.

EDIT: I also see that the mushroom pic remained added to the corona virus post and bumped the original pic. I had to 'hand' correct that.

EDIT: and further, while the thumbnail pic attached to this post is the mushroom, the pic after the thumbnail is clicked, is the graph from the corona virus thread that I had to replace. I will log off hopefully clear the cache du jour and see if there is persistence....logging off/on makes no difference.

Pics in limbo are evil and get put in places that you don't want. Orphaning pics is the devils work  :)
« Last Edit: July 01, 2020, 02:35:56 pm by DrG »
- Invest in science - it pays big dividends. -
 

Offline rhb

  • Super Contributor
  • ***
  • Posts: 3083
  • Country: us
Re: Server Error Reports
« Reply #223 on: July 01, 2020, 11:43:30 pm »
Why is the quoting in this wrong?

https://www.eevblog.com/forum/testgear/scope-wars/msg3115270/#msg3115270

My response is not nested correctly.

Reg
 

Offline nuclearcat

  • Supporter
  • ****
  • Posts: 291
  • Country: lb
Re: Server Error Reports
« Reply #224 on: July 02, 2020, 12:01:52 am »
I am sorry, I have had limited time of late and have not yet had an opportunity to dig any deeper into this.

There have been other higher priority issues to resolve before looking at this issue, I have spent the last few days working to get backups working after server updates, finally succeeded. Doing a remote incremental backup of the SMF attachment directory consisting of over half a million files (around 60GB) internationally is a nightmare. We are using GlusterFS which limits options with how to do this backup, otherwise, I would just mount an image over the attachment directory and snapshot its backing storage each time. (tar/gz of the directory is not an acceptable option due to server load concerns)
Maybe restic + minio duo?
Also you can try "nice -n 19 ionice -c 3" before tar.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf