Author Topic: Server Error Reports  (Read 199760 times)

0 Members and 1 Guest are viewing this topic.

Offline mnementh

  • Super Contributor
  • ***
  • Posts: 9638
  • Country: ca
  • *Escaping The Suck*
Re: Server Error Reports
« Reply #300 on: August 13, 2020, 03:06:46 am »
FWIW I have been using the, skip the first slot, method for the last week or so and have not seen any problems yet.
Yet it seems pretty reliable other than the one hiccup I had.

That second png reports an error in PS if I try to dl it.

Wow... great. The bug borked another pic, which just messed up those three posts above AGAIN.  |O This is getting comical...

mnem
"Dying is easy; now comedy... that's hard." ~Edmund Gwenn

as does the gif @mnementh

Is corruption a new phenomenon?

Yeah... eevBlog has had a wandering singularity ever since the last software update; it randomly erases pics from our current timeline. When the singularity eats a pic, it is "unmade" as if it never existed; which makes every pic associated with a user that came after that shift down a slot in the database. ;)  Much hilarity ensues.  :-DD

The "Skip the First" slot workaround casts a warding spell which usually works unless the server daemons are especially overloaded by high numbers of visitors to a thread; the singularity seems especially attracted to the busiest threads. *

mnem
*Complete and utter fabrication purely for grins & giggles. >:D

 

Offline DrG

  • Frequent Contributor
  • **
  • Posts: 473
  • Country: us
Re: Server Error Reports
« Reply #301 on: August 13, 2020, 03:17:01 am »
FWIW I have been using the, skip the first slot, method for the last week or so and have not seen any problems yet.
Yet it seems pretty reliable other than the one hiccup I had.

That second png reports an error in PS if I try to dl it.

Wow... great. The bug borked another pic, which just messed up those three posts above AGAIN.  |O This is getting comical...

mnem
"Dying is easy; now comedy... that's hard." ~Edmund Gwenn

as does the gif @mnementh

Is corruption a new phenomenon?

Yeah... eevBlog has had a wandering singularity ever since the last software update; it randomly erases pics from our current timeline. When the singularity eats a pic, it is "unmade" as if it never existed; which makes every pic associated with a user that came after that shift down a slot in the database. ;)  Much hilarity ensues.  :-DD

The "Skip the First" slot workaround casts a warding spell which usually works unless the server daemons are especially overloaded by high numbers of visitors to a thread; the singularity seems especially attracted to the busiest threads. *

mnem
*Complete and utter fabrication purely for grins & giggles. >:D

That's a big Twinkie

- Invest in science - it pays big dividends. -
 
The following users thanked this post: mnementh

Offline SilverSolder

  • Super Contributor
  • ***
  • Posts: 3404
  • Country: 00
Re: Server Error Reports
« Reply #302 on: August 13, 2020, 01:20:55 pm »
FWIW I have been using the, skip the first slot, method for the last week or so and have not seen any problems yet.
Yet it seems pretty reliable other than the one hiccup I had.

That second png reports an error in PS if I try to dl it.

Wow... great. The bug borked another pic, which just messed up those three posts above AGAIN.  |O This is getting comical...

mnem
"Dying is easy; now comedy... that's hard." ~Edmund Gwenn

as does the gif @mnementh

Is corruption a new phenomenon?

Yeah... eevBlog has had a wandering singularity ever since the last software update; it randomly erases pics from our current timeline. When the singularity eats a pic, it is "unmade" as if it never existed; which makes every pic associated with a user that came after that shift down a slot in the database. ;)  Much hilarity ensues.  :-DD

The "Skip the First" slot workaround casts a warding spell which usually works unless the server daemons are especially overloaded by high numbers of visitors to a thread; the singularity seems especially attracted to the busiest threads. *

mnem
*Complete and utter fabrication purely for grins & giggles. >:D



Perhaps somehow 5G is to blame for this?!?  :D
 
The following users thanked this post: mnementh

Offline sokoloff

  • Super Contributor
  • ***
  • Posts: 1472
  • Country: us
Re: Server Error Reports
« Reply #303 on: August 27, 2020, 03:08:15 pm »
SSL cert expired a couple hours ago. (Time now is 11:08 AM EDT.)

 

Offline BrianHG

  • Super Contributor
  • ***
  • Posts: 4678
  • Country: ca
Re: Server Error Reports
« Reply #304 on: August 27, 2020, 06:03:43 pm »
New firefox just gave me this:
Also something with the SSL security...
__________
BrianHG.
 

Offline IanB

  • Super Contributor
  • ***
  • Posts: 9766
  • Country: us
Re: Server Error Reports
« Reply #305 on: August 27, 2020, 06:06:44 pm »
Chrome this morning has also told me the SSL certificate is not valid.

We may have to wait for the working day in Australia to start before it will be fixed.
I'm not an EE--what am I doing here?
 

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 4464
  • Country: nl
Re: Server Error Reports
« Reply #306 on: August 27, 2020, 06:07:45 pm »
There are 2 servers with a load balancer, one has an expired certificate and the other is still valid till the end of October. Which server you get depends on the dice in the load balancer.
Keyboard error: Press F1 to continue.
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #307 on: August 28, 2020, 02:11:22 am »
There are 2 servers with a load balancer, one has an expired certificate and the other is still valid till the end of October. Which server you get depends on the dice in the load balancer.

You are correct, one of the server had faulted and was not renewing it's certificate. This has been corrected.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Offline tautech

  • Super Contributor
  • ***
  • Posts: 19596
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #308 on: August 28, 2020, 02:17:18 am »
one of the server had faulted and was not renewing it's certificate. This has been corrected.
Yet Chrome is still displaying a Not Secure flag.  :-//
Same result with a manual refresh or F5 refresh.
Avid Rabid Hobbyist
 

Offline xrunner

  • Super Contributor
  • ***
  • Posts: 4920
  • Country: us
  • hp>Agilent>Keysight>?
Re: Server Error Reports
« Reply #309 on: August 28, 2020, 02:22:33 am »
All good here now!  :-+
I am a Test Equipment Addict (TEA) - by virtue of this forum signature, I have now faced my addiction
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #310 on: August 28, 2020, 02:24:08 am »
one of the server had faulted and was not renewing it's certificate. This has been corrected.
Yet Chrome is still displaying a Not Secure flag.  :-//
Same result with a manual refresh or F5 refresh.

Your end sorry mate, I just double-checked that both servers are using valid certificates now.

Edit: Note, not-secure is different to an invalid certificate. You may be trying to access resources over `http`, make sure you're hitting the site over `https` and nobody has embedded any non https content on the page you're on.
« Last Edit: August 28, 2020, 02:27:31 am by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 
The following users thanked this post: tautech

Offline tautech

  • Super Contributor
  • ***
  • Posts: 19596
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #311 on: August 28, 2020, 02:43:44 am »
one of the server had faulted and was not renewing it's certificate. This has been corrected.
Yet Chrome is still displaying a Not Secure flag.  :-//
Same result with a manual refresh or F5 refresh.

Your end sorry mate, I just double-checked that both servers are using valid certificates now.

Edit: Note, not-secure is different to an invalid certificate. You may be trying to access resources over `http`, make sure you're hitting the site over `https` and nobody has embedded any non https content on the page you're on.
Yep all good, thanks. Definitely faster browsing and loading pages now.  :-+
Avid Rabid Hobbyist
 

Offline IanB

  • Super Contributor
  • ***
  • Posts: 9766
  • Country: us
Re: Server Error Reports
« Reply #312 on: August 28, 2020, 02:49:54 am »
Your end sorry mate, I just double-checked that both servers are using valid certificates now.

Edit: Note, not-secure is different to an invalid certificate. You may be trying to access resources over `http`, make sure you're hitting the site over `https` and nobody has embedded any non https content on the page you're on.

With Chrome, if you insist on a "not secure" connection after an invalid certificate message, Chrome will remember that setting for several hours before trying again. You have to force Chrome back to an https connection manually if you don't want to wait. The best way to do that seems to be to close the current tab and then open a new one.
I'm not an EE--what am I doing here?
 

Offline tautech

  • Super Contributor
  • ***
  • Posts: 19596
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #313 on: August 28, 2020, 02:53:30 am »
The best way to do that seems to be to close the current tab and then open a new one.
Close an EEVblog tab  :o ......Never !   :-DD
Avid Rabid Hobbyist
 
The following users thanked this post: mnementh

Offline Monkeh

  • Super Contributor
  • ***
  • Posts: 6728
  • Country: gb
Re: Server Error Reports
« Reply #314 on: September 01, 2020, 03:41:55 am »
Absolutely beseiged by 502s today, is one or more of the servers suffering from a stroke, or just a lack of timely whipping?
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #315 on: September 01, 2020, 03:45:14 am »
Investigating, I was alerted to this about an hour ago, seems something is causing high I/O load.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Offline tautech

  • Super Contributor
  • ***
  • Posts: 19596
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #316 on: September 01, 2020, 03:49:53 am »
Investigating, I was alerted to this about an hour ago, seems something is causing high I/O load.
P76 of this thread:
https://www.eevblog.com/forum/testgear/siglent-sds2000x-plus-coming/
Avid Rabid Hobbyist
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #317 on: September 01, 2020, 03:50:58 am »
Yup, it's that thread... thanks for that, looking for the dud file.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Offline tautech

  • Super Contributor
  • ***
  • Posts: 19596
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Server Error Reports
« Reply #318 on: September 01, 2020, 03:53:19 am »
Yup, it's that thread... thanks for that, looking for the dud file.
Was working fine late PM yesterday NZ time and I think another file was added overnight to an existing post that caused the issues.
Avid Rabid Hobbyist
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #319 on: September 01, 2020, 04:01:45 am »
Yup,

Issue fixed, another windows bitmap uploaded with a png extension. SMF goes nuts trying to load it and just hangs consuming tons of RAM.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 
The following users thanked this post: tautech

Offline Monkeh

  • Super Contributor
  • ***
  • Posts: 6728
  • Country: gb
Re: Server Error Reports
« Reply #320 on: September 01, 2020, 04:05:27 am »
Who's posting nonsense like that?
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1179
  • Country: au
Re: Server Error Reports
« Reply #321 on: September 01, 2020, 04:09:11 am »
I replied to them in the thread
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

Note: I am NOT a moderator or arbiter of disputes, my Admin level of access is so that I can perform management of the server on behalf of Dave. Do not contact me over such issues
 

Offline Monkeh

  • Super Contributor
  • ***
  • Posts: 6728
  • Country: gb
Re: Server Error Reports
« Reply #322 on: September 01, 2020, 04:12:26 am »
Thanks for the fix. Good old SMF, chainsaws round the edges.
 

Offline Whales

  • Super Contributor
  • ***
  • Posts: 1073
  • Country: au
    • Halestrom
Re: Server Error Reports
« Reply #323 on: September 01, 2020, 04:13:43 am »
Gnif: that's a notable denial of service vuln.  Unhappy or banned users could come back and wreck all sorts of havoc. 

Is the problem in core SMF or an addon?  https://github.com/SimpleMachines/SMF2.1/issues

Offline IanB

  • Super Contributor
  • ***
  • Posts: 9766
  • Country: us
Re: Server Error Reports
« Reply #324 on: September 01, 2020, 05:59:16 am »
Issue fixed, another windows bitmap uploaded with a png extension. SMF goes nuts trying to load it and just hangs consuming tons of RAM.

Ouch. Programs like SMF should not blindly trust file extensions, they should look inside the file to determine (or verify) the actual type of content.
I'm not an EE--what am I doing here?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf