Author Topic: Crash on import  (Read 900 times)

0 Members and 1 Guest are viewing this topic.

Online Dubbie

  • Supporter
  • ****
  • Posts: 995
Crash on import
« on: July 02, 2019, 09:03:37 am »
Does anyone else get a crash upon importing a footprint?

I make most of my footprints in PCB Expert, because I can't be bothered drawing everything manually with the absolutely awful drawing tools in CM.

The first one I import works fine, then any subsequent ones crash the app. I need to restart it and import again.

This happens both at home and at work, so I don't think it's anything to do with my computer env.
 

Offline voltsandjolts

  • Supporter
  • ****
  • Posts: 806
  • Country: gb
Re: Crash on import
« Reply #1 on: July 03, 2019, 11:06:12 am »
absolutely awful drawing tools in CM.

Are you using CircuitMaker?

I use CircuitStudio and PCB Expert (free version) and haven't had any issues with the PADS import.
 

Online Dubbie

  • Supporter
  • ****
  • Posts: 995
Re: Crash on import
« Reply #2 on: July 07, 2019, 09:58:32 pm »
Oops typo.

I meant studio.

Hrmmm, I wonder why mine crashes so regularly?
 

Offline OleMi

  • Contributor
  • Posts: 11
  • Country: ru
Re: Crash on import
« Reply #3 on: August 01, 2019, 02:33:58 pm »
They have a bug in their import engine. Check for slashes and other "non-standard" symbols in the name of your footprint to be imported. Rename them all to be just Latin characters and numbers before import.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf