EDA > Circuit Studio

Designators on wrong layer after import changes to PCB

(1/1)

Kasper:
Hi everyone, CS just gave me yet another surprise.  I add components to schematic and import changes to PCB.  The components all get added to the PCB on the top layer as expected but the designators are all on bottom silk and mirrored!?

I try to click and drag to select them to no avail.  I could filter for text on bottom layer and select them all with ctrl-A but then I also select all my other designators that I don't want to change.  So I hold shift and click every new designator and then use object inspector to change them. 

Not sure if this has anything to do with it but I use the .Designator special string on footprints in PCB library for assembly text top and that seems like it still works.

Anyone know why this happens or how to fix it? 

While we are at it, anyone know how to set default height and width for designators?

voltsandjolts:

--- Quote from: Kasper on May 05, 2021, 09:27:51 pm ---While we are at it, anyone know how to set default height and width for designators?

--- End quote ---

https://www.element14.com/community/thread/76670/l/can-i-specify-the-default-designator-text-size-for-the-footprint

Kasper:

--- Quote from: voltsandjolts on May 06, 2021, 09:54:08 am ---
--- Quote from: Kasper on May 05, 2021, 09:27:51 pm ---While we are at it, anyone know how to set default height and width for designators?

--- End quote ---

https://www.element14.com/community/thread/76670/l/can-i-specify-the-default-designator-text-size-for-the-footprint

--- End quote ---


--- Quote ---Re: Can I specify the default designator text size for the footprint?
adamwebber Level 5: Faraday
adamwebber Oct 18, 2020 11:37 AM (in response to lsscythe)

If you want to change the default settings then you need to edit a file in a text editor such as Notepad++ or similar.

Start by Closing CircuitStudio or else the changes won't be saved.

First, find the location of the file you need to edit.

C:\Users\YOUR NAME\AppData\Roaming\Altium\CircuitStudio {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}

Second, create a copy of ADVPCB.DFT (to protect yourself in case you mess it up)

Open the file.

Find the Component.  Should be line 9.

Scroll to the right until you find DESIGNATOR.XXXXX.  This is where you will change all of the attributes of the component designator.  Don't go crazy here.  Change little things at a time.

Save the file and restart CS.

--- End quote ---

That did it! Thank you!  Changed text height and width following this comment and fixed the layer problem in the same line.

To get designators on the correct layer (top overlay), I went to line 9 and changed this:
FLIPPED=TRUE|FLIPPINGCHANGED=TRUE
to this:
FLIPPED=FALSE|FLIPPINGCHANGED=FALSE

I started by changing LAYER=BOTTOM to LAYER=TOP but that didn't seem to do anything, though I did keep that change when I made the other changes so maybe it was part of the solution.


Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version