EDA > Circuit Studio

Font Height error

(1/1)

jmarkwolf:
I have encountered a font height issue with some projects I imported into CS from Altium Designer..

The font height "shows" to be correct height according to the "String" dialog box (see JPG below), but it actually measures approx. 38mil in height.

The string was originally 60mil in height in Altium Designer, but now it is definitely not.

The line I drew adjacent to the "S" is indeed 60mil in length, but as you can see the "S" is definitely not the same height as the 60mil long line.

If I place new strings, they are also small even though I specify that they be 60mil in height.

Anybody have some suggestions?


T3sl4co1l:
Altium never calculated TTF heights correctly either (meaning, using the baseline to ascender dimension, which I think don't really exist in the TTF format, so Altium can hardly be blamed for that).

Did... they do away with the stroke font, completely?  Is it in the list, instead?  'Cuz stroke font is line primitives generated internally, which is why it has specified height.  If CS is forcing it to TTF, that explains that.

Simple enough fix, in any case: figure out how much smaller the TTF font is, and increase height globally by that factor (should be doable in the Inspector, or did they get rid of that..?).

Tim

jmarkwolf:
Yup, you nailed it Tim.

In all the years I've use Altium Designer, I never had a need to change the font from "stroke".

The conversion to CS converted all the PcbDoc fonts to Arial (true type as you pointed out) which mucked with the font height. "Stroke" is apparently not an option in CS PcbDoc.

It's a nuisance but I can live with it.

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version