EEVblog Electronics Community Forum

Electronics => PCB/EDA/CAD => Circuit Studio => Topic started by: limata on October 01, 2019, 12:20:34 am

Title: How to disable the 3D components model in the display?
Post by: limata on October 01, 2019, 12:20:34 am
I have 3D model for most of the components. When I check the layout, I would like to see the traces. I have trouble to disable the 3D model so they won't show up in the 3D view.
I appreciate any help. Thanks.
Title: Re: How to disable the 3D components model in the display?
Post by: ubbut on October 01, 2019, 06:15:35 am
File -> System preferences -> PCB Editor -> Display -> Show Simple 3D bodies and Show Generic 3D models

For some reason they made that incredibly complicated to find. in Designer these settings are directly accessible in the Layer options
Title: Re: How to disable the 3D components model in the display?
Post by: limata on October 01, 2019, 04:37:43 pm
Thanks. That helps a lot. This option really should under the 3D view configuration.  |O
Title: Re: How to disable the 3D components model in the display?
Post by: voltsandjolts on October 01, 2019, 08:29:33 pm
Alternate way to access that setting:
In 3D view, right-click, Options > Display > Show...
Title: Re: How to disable the 3D components model in the display?
Post by: limata on December 04, 2019, 06:39:14 pm
Just found this.
If you go to PCB -> 3D models, there are also 3D bodies display options on the bottom of the panel.
Title: Re: How to disable the 3D components model in the display?
Post by: voltsandjolts on December 04, 2019, 09:56:02 pm
Ahh, that also lets you hide individual 3D models. Quite useful for getting mechnical parts in/out of view. Thanks.