Author Topic: red X's all over my circuit?  (Read 3698 times)

0 Members and 1 Guest are viewing this topic.

Offline CopperConeTopic starter

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: us
  • *knock knock*
red X's all over my circuit?
« on: July 03, 2017, 05:28:18 pm »
WTF is this shit. I have a solid rectangle around my circuit. If I zoom in, it looks like little red circles with X's in them.

If i zoom out, it looks like a fucking red rectangle. What is this shit?

Why can't there be a feature to like get rid of annoying ass bullshit that makes the board impossible to see?

I mean, there should be a god damn machine learning thing, that just looks at a PCB and detects that well, its clogged with some kind of bullshit overlay making it impossible to look at.

Nothing else is more infuriating.  |O I can't select it, its not obvious as to what it is.  :--
 

Offline CopperConeTopic starter

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: us
  • *knock knock*
Re: red X's all over my circuit?
« Reply #1 on: July 03, 2017, 05:31:46 pm »
also, is there a hide all layers option?? So I can hide all but one.

This is SUPER useful in eaglecad.
 

Offline CopperConeTopic starter

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: us
  • *knock knock*
Re: red X's all over my circuit?
« Reply #2 on: July 03, 2017, 05:33:37 pm »
Also, if you want this program to be high quality, the program should automatically "detect" that some kind of "pattern" being used is basically blocking view of the circuit when you zoom out.

The pattern should change with zoom, so its still readable. This is garbage.  Why is there some kind of warning/overlay/some shit that only works at a particular zoom level?  :rant: :wtf: :scared: |O

It's like aliasing on a fucking oscilloscope. All the high quality scopes have alias detect, etc.

This is like using a DSO from the 90s. What are you trying to tell me with a grid of dots with X's in them????????

is my circuit sick? does it have chicken pox? I need a medicine.
« Last Edit: July 03, 2017, 05:35:52 pm by CopperCone »
 

Offline Macbeth

  • Super Contributor
  • ***
  • Posts: 2571
  • Country: gb
Re: red X's all over my circuit?
« Reply #3 on: July 03, 2017, 05:49:03 pm »
I believe you are seeing DRC violations. Check your design rules or just switch them all off  ;)
 

Offline CopperConeTopic starter

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: us
  • *knock knock*
Re: red X's all over my circuit?
« Reply #4 on: July 03, 2017, 05:59:27 pm »
Still would be nice if the error pattern scaled to prevent just.. washing out.
 

Offline CopperConeTopic starter

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: us
  • *knock knock*
Re: red X's all over my circuit?
« Reply #5 on: July 03, 2017, 06:30:29 pm »
you are right. Is there a way to disable it from popping up every time I move a rect?
 

Offline voltsandjolts

  • Supporter
  • ****
  • Posts: 2349
  • Country: gb
Re: red X's all over my circuit?
« Reply #6 on: July 03, 2017, 07:25:06 pm »
Hmm. Sounds like you might prefer to disable online DRC and just run it manually.

File > System Preferences > PCB Editor > General > Editing Options > Online DRC (untick)
 

Offline Harvs

  • Super Contributor
  • ***
  • Posts: 1202
  • Country: au
Re: red X's all over my circuit?
« Reply #7 on: July 04, 2017, 12:31:03 am »
With complex designs I think online DRC is one of the best things ever.  It's similar to modern IDE's with object oriented languages being able to pick up typo's as you go.  Saves a heck of a lot of time being able to fix problems as they happen.

Obviously everything is personal preference.

Given this is the first time you're seeing this, is it an imported design from a different package? It might be why this whole thing seems so horrific.  Through normal use I only see DRC errors popping up on individual components/traces, not all over a board (with the one exception of polygons that need repouring.)
 
The following users thanked this post: Someone

Offline JamesH-AltiumOfficial

  • Contributor
  • Posts: 40
  • Country: au
Re: red X's all over my circuit?
« Reply #8 on: July 07, 2017, 11:07:24 am »
Hi CopperCone,

Besides disabling Online DRC here are three commands that may help:

1. Shift+S toggles single layer mode (use + and - on the numeric keyboard to move through all layers or * to move through top, mid layers, bottom)

2. Home > Design Rule Check > Reset Error Markers (to get rid of them all if there are too many to see what's happening)

3. Hover the mouse over a red area, press Shift+V to see the violations under the cursor

Best regards,

James Harriman
Altium
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf