Products > Dodgy Technology

Foxess inverter ethernet data to PC data and other monitoring LIE (MODBUS)

<< < (4/6) > >>

s1977:

--- Quote from: MrMobodies on October 24, 2022, 04:32:16 pm ---No success, and this was with the other dongle plugged in?

--- End quote ---

I tried it with both the Smart LAN connected and disconnected just to rule things out. Seems unlike your case, a setting turned off which didn't reset itself even after a power cycle.  |O

MrMobodies:
Well, that is unfortunate but I am glad to hear that your contractor/installer were being cooperative.

I am going to see what happens if I disable "Remote access" later to see what happens as I think I left it on.

I am using a virtual appliance, for mine, Virtualbox on an old Duo Core but I brought a Lenovo M93P (10w idle) with Windows 10 LTSC 2019 and planning to use HyperV. It is so that I can backup and access the virtual drive image if it goes wrong and I have yet to find out about the file system it uses.

There is a glitch, I switched it off for a couple of hours before midnight and now the daily graphs don't reset to zero at midnight. I tried adjust the values in develop which apparently seem to show correctly. I installed the SQL stuff but the database Homeassistant is there but nothing in there. That's on hold until I find out what I am not doing correctly. This is so I can manually make adjustments.

Once it is all working I am going to disable the update as I want it to run long term without any disruption:
https://community.home-assistant.io/t/feature-request-block-supervisor-auto-updates/112743/58

--- Quote ---CentralCommand MikeSep 19
This entire FR is about being able to stop supervisor from auto-updating. So, supervisor? But also none of the other stuff you listed auto-updates so I’m confused by your question.

Or are you asking when it arrives in the UI? If so the answer is it doesn’t. There’s no UI toggle, its in the cli.

ha supervisor options --auto-update=false
Btw for anyone looking to do this, two important notes:

If supervisor is out of date then all updates are blocked. Core, OS, addons, none of it can be updated while supervisor is out of date. You also cannot install new addons or add new addon repositories. Something to be aware of
Only the latest version of supervisor is supported. Your system will be treated as unsupported for purpose of issues while supervisor is out of date.
--- End quote ---
To try to maintain compatibility I copy a Chrome version that works to a folder (I use Vivaldi for this which is built in chrome):
Example:
C:\Browserprofiles\Programs\Google\Chrome90\chrome.exe

I copy the profiles: C:\Users\Administrator\AppData\Local\Google\Chrome\User Data
Or don't bother as a default one will be made automatically wth the shortcut switch.

I copy the Chrome shortcut, rename and change the target to:
C:\Browserprofiles\Programs\Google\Chrome90\chrome.exe --user-data-dir="C:\Browserprofiles\user\Homeassistant"
And put a nice little ICO beside it and put into something like "C:\Browserprofiles\Ico"

I install the Adblock ABP Plus extension to hide the following stupid things that dim large parts of the screen on dialogues.
That hurts my eyes when that happens, small white dialogue or side menu the background dims and obscures and cuts me off which I find isn't very nice as I want it left alone I might be paying attention to something there.

--- Quote ---##.mdc-dialog__scrim
###sidenav-overlay
##.modal-overlay
github.com##.d-flex.js-sticky.js-position-sticky.top-0.border-top-0.border-bottom.p-2.flex-items-center.flex-justify-between.color-bg-default.rounded-top-2.is-stuck
##.d-flex.js-sticky
###ha-launch-screen
##.ha-launch-screen-spacer
##.mdc-circular-progress__indeterminate-circle-graphic
##.ajax_notification.dismissable
###loading_parent
##.ajax_notification
##.ui-widget-overlay.ui-front
--- End quote ---

The only other thing (some fixed with the KIOSK addon) which I go into developer tools in browser to unset the fixed position elements. The HeaderHiderFixer browser extension or StickyDucky don't seem to auto hide it on scroll. I get very distracted and irritated seeing the blue bar stuck there constantly large in size and especially with it coloured blue.

vladimirus:
Hello

I also followed the instructions to setup "Setup FoxESS and Home Assistant using RS485/Modbus" and everything works great apart from one thing... So I have Fox Ess H1-6.0-E connected directly to my LAN via ethernet port then using HA-FoxESS-Modbus-LAN module in HomeAssistant to scrape data from inverter's port 502 (I also connected Prometheus to scrape data from HomeAssistant so I can build more fancy graphs in Grafana but that's a different story).

Everything works, I can see all the stats in HomeAssistant pretty much in real-time which quite cool... But... Sometimes my inverter restarts, I dont know why and there is no real pattern to it. Sometimes it can restart couple of times a day, sometimes it can run for good few days before it restarts. When it does, it looses IP address completely (if i check settings About -> IP Add) then I see 0.0.0.0. The only remedy to this, is for me to manually go to "Setting -> Communication -> Ethernet -> Enable -> Set". After I've done that, everything starts to work immediately (I see all the data flowing into HomeAssistant)

Did anyone experienced this? Or know the cause or how to fix it? This is quite annoying since it requires me to be present and start DHCP at any time otherwise the stats wont be collected.

Thanks.

PlainName:

--- Quote ---and start DHCP at any time
--- End quote ---

Can you expand on what you mean there? Typically, a DHCP server runs continuously so perhaps you mean something other than a server - the DHCP setting in the equipment, maybe?

vladimirus:

--- Quote ---Can you expand on what you mean there? Typically, a DHCP server runs continuously so perhaps you mean something other than a server - the DHCP setting in the equipment, maybe?
--- End quote ---

Yes DHCP setting in the inverter...

So when the inverter restarts, it looses IP Address. If I go and check it (in the Inverter) "About -> IP Add ->" I get 0.0.0.0. So in order for the inverter to obtain an IP, I need to set in the inverter following:

"Settings -> Communication -> Ethernet -> DHCH -> Enable -> Set"

After I do the above, the IP address appears and everything works once again...

Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod