Products > Dodgy Technology

Foxess inverter ethernet data to PC data and other monitoring LIE (SOLVED)

<< < (5/10) > >>

vladimirus:
"Settings -> Communication -> Ethernet -> DHCP -> Enable -> Set"

MrMobodies:
I had the same trouble too and couldn't find out why so first of all set a static IP but found it was still doing it.

It seems a number of things trigger it.

When connecting it an standalone switch, fine, laptop fine to switch but as soon as I plug that switch in to the network/router then it would randonly stop for a while where the buttons on the inverter would become unresponsive until resetting.

I brought a USB dongle (as an additional interface on the MINIPC) and no problems since.

If you open close the connection too many times (noticed with rednode) restart the appliance I have seen that happen.

PlainName:
Wow! Getting and retaining an IP address is a rather critical part of being on a network, so this must have been tested extensively to make sure it fails so easily.

vladimirus:

--- Quote from: MrMobodies on December 14, 2022, 06:25:27 pm ---I brought a USB dongle (as an additional interface on the MINIPC) and no problems since.

--- End quote ---

I am trying to understand your setup, your inverter connected to what and how? And what does this USB dongle do?

MrMobodies:
Sorry I forgot to post some stuff but here is a diagram of my configuration:


Onboard M93p ETH0:

USB Nic ETH1:


I set static IP's for everything but static ip for the inverter and the Network card going off to the inverter is needed.

Note: I have noticed, using two or more USB nic's of  the same chipset/type where they are numbered "Local area connection 1" and "Local are connection 2" can randomly switch places at boot up, so say if they assigned to virtual machines and when this issue occurs they can switch places and go off to the wrong virtual machine.

I am uing Hyper-V to host it.
I attached some screenshots below of the network configuration with HyperV.

I have come across an issue. I find I have to insert this on every startup if I restart it or it offers updates automatically and I don't want it to auto update:

--- Quote ---supervisor options --auto-update=false
--- End quote ---

Now I tried blocking WAN traffic to the Homeassitant package (in my setup it is not going to need that) but it doesn't seem to complete start up whilst making connection attempts  to github where I think the Foxess addition is hosted. I am not entirely sure but I am going to run another copy to try and see if I can find out what is causing it and if I can do anything about it.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod