Products > Dodgy Technology

Foxess inverter ethernet data to PC data and other monitoring LIE (SOLVED)

<< < (7/10) > >>

texamicomio:
Hi @Vladimirus,
I connected the Foxess H1 inverter to my home LAN and I was able to communicate via MODBUS protocol without any problems. I'm developing a widget for Android to view real-time data directly from the smartphone's home screen. This morning, for the first time, the inverter didn't get the IP from the DHCP. I tried setting the static ip and resetting the DHCP in the inverter menu but I couldn't connect in any way.
Were you able to solve your problem?


--- Quote from: vladimirus on December 14, 2022, 05:18:28 pm ---
"Settings -> Communication -> Ethernet -> DHCH -> Enable -> Set"

After I do the above, the IP address appears and everything works once again...

--- End quote ---

I attach the preview of my widget.

MrMobodies:

--- Quote from: texamicomio on February 09, 2023, 11:50:24 pm ---Hi @Vladimirus,
I connected the Foxess H1 inverter to my home LAN and I was able to communicate via MODBUS protocol without any problems. I'm developing a widget for Android to view real-time data directly from the smartphone's home screen
--- End quote ---
Is this directly or from Homeassistant?

If more than one connection attempt is made and (disconnecting and reconnecting too fast) it will lock out for a while and eventually restart in like 10 to 20 minutes.

I'd connect the inverter directly to a separate network card or USB network dongle to the homeassistant applice and set a static ip on that and the inverter.

At first I had it connected to a switch (with DHCP by router) sharing a few virtual machines and I remember it kept on locking out and restarting as well. I am not fully sure but I suspect that could have something to do with broadcast traffic.

texamicomio:
Hi MrMobodies
I connected the inverter directly to my home LAN (through a switch and then into the router). With a scan I found the IP address and connected with a free app (Modbus TCP). I made a lot of connections and developed my own widget. This worked for 3 days then the inverter stopped connecting. Could there have been an update? I noticed that the settings menu has changed.
I would like to reset the inverter.
I don't think the problem is LAN traffic.

Thank you for your answer.

MrMobodies:
I think from my experience I had with it that it had something LAN traffic. I can't be sure as I don't want produce the steps and cause any major problems with it as it is working. Nothing has happened so far. Before I crimped the cables, first time I connected to a Draytek acting as a wireless bridge to another Draytek then into Pfsense (vlan in it's own) doing the DHCP, with one computer and it was fine. You see I want it on the lan as well so I can monitor it with the snmp monitor, Dude, program but if it is going to do that then a no go.

As soon as I put it on a switch or vlan with other stuff it would just cut out randomly and a lot. It would not work consistently. I connected it through a USB network dongle when I was experimenting with Rednode and renaming the Solax registers to one off a Foxess and got that to work. For days it was fine and with Homeassistant when I tested that too. A week later as soon as I connected back up to a different switch on a different Vlan in the cabinet doing the virtual machines the same thing happened and it would stop. So I just left it plugged into it's own network card since September and it is fine. The USB network seems pretty stable for what it is. The only change I have made is moved the appliance from a laptop to a minipc.

You do not have a "smart wifi" stick installed?

According to one commentor here it seems that when that is plugged it would cut out or something like that if I understand correctly?

Also I was told by Foxess it would auto update the inverter through the "Smart wifi stick when connected to their website/cloud whatever which is a big nono for me. I want something like that left alone without any interference from the manufacturer behind my back.

Is "Remote access" still there in the installer menu?

texamicomio:
Hi MrMobodies,
the "remote access" menu item is still available in the menu and I've a "smart wifi" stick installed.
You described well what happened to you and I understand what you mean.
Perhaps my problem could have been caused by a remote software update after I reported an incorrect behavior of the inverter to assistance: at night there was a continuous noise from the relays.
In my opinion a remote update was done and now the noise of the relays is no longer heard but access with modbus is no longer allowed.

Before the update, the connection via LAN with MODBUS protocol work without problems.
After the update the LAN port has been disabled because the IP address is not even configured (neither with DHCP nor with static IP configuration).

I'm contacting technical assistance to ask for information. If I don't solve the problem I become dissatisfied with the FoxESS brand.  >:(

Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod