Products > Dodgy Technology

Foxess inverter ethernet data to PC data and other monitoring LIE (SOLVED)

<< < (9/10) > >>

I just remembered and forgot to mention (without the wifi plugged in but with ethernet connected)...
To cause the inverter to reboot:

Just cut the power to through the isolator or fuse box, the screen may stay on as I believe it has a built in battery and it will display a fault message and the warning light will come on.

About a couple minutes restore power to it and about 10 to 20 minutes it will reset and all the relays will click and do it's diagnostics and clear the warning. That worked for me unexpectedily.

Inv Ver

--- Quote ---Master 1.24
*Slave 1.02
Comm 1.25
--- End quote ---

--- Quote ---Master 1.09
Slave 1.09
Comm 1.09
--- End quote ---

A bit odd.
This looks more realistic:

--- Quote ---In FoxCloud app (and web portal) there is:
Master 1.54
*Slave 1.02
Manager 1.56
--- End quote ---
* Looks to me like the backup firmware.
Would be interesting to see if there is a way of triggering it into loading the backup firmware.

My thoughts:
Custom firmware for their WIFI stick that eventually installs or custom when you reported the relays clicking.
(The clicking is normal when it reboots and it did this to me often with the LAN issues at first until I connected it directly. I didn't think it was a problem because I was there and knew what it was doing when it eventually restarted or when I cut and reapplied power as a test... almost forgot about that.)

They speak of Firmware version 1.56 here:

--- Quote ---Borehamwood wrote: ↑Wed Jan 25, 2023 10:02 pm
Anybody else got manager version 1.56?
Is it newer than 1.54?
--- End quote ---

--- Quote --- Dave Foster Posts: 50  Thu Jan 26, 2023 11:03 am
It is newer but Foxess don’t issue firmware release notes  :bullshit: so the updates/bugs etc.. are not known.

We do know that if you have a home assistant connected via the LAN port it will no longer work as the LAN function has been removed (you have to connect via modbus or cloud)
--- End quote ---

[So they have removed modbus over ethernet.

Take it as a lesson:
You can see why I don't leave my stuff connected up if I know it is going to update and I refuse updates willy nilly so that manufacturer's can do what they like to it. It is proof that newer update is not equals to always better and may certainly not be in your best interests.

I bet they saw thread like this one and the Youtube videos, decided they didn't like it and made the next update accordingly.

My Paranoia: Wait till they alter their wifi stick and inverter through a firmware update so any modbus converter (not their own) won't work for new users trying it.

Their stupid app, both Apple store and Playstore cloud monitoring don't seem to be doing well according to the reviews.

We haven't got enough users sign into our cloud to leave good feedback.
So what do they do, they disabled or cripple the means for successful private/inhouse data monitoring project and obstruct it through whatever means they can like now for those who have their smart "wifi stick" installed and betray the trust that the customers have installed in them by removing/denying them something that was once shown in the manual at the time of purchase and worked fine before. Making it difficult for those who are against this finite "cloud" only monitoring where they have to start looking at converters when that was all available from the ethernet port or extra equipment with clamps.

This makes Sony Other OS look good as at least they gave a choice as far as I can remember.
Update to continuing to use to the Playstation Network and loose OtherOS.
Don't update and eventually loose access to Playstation Network.

--- Quote ---force its customers to choose either to forego installing the software update or to lose access to the other OS feature,
--- End quote ---

It goes to show that now they don't force customers to choose anymore.
They just take liberties and do what they like when they can through silence like here:

--- Quote ---Dave Foster Posts: 50  Thu Jan 26, 2023 11:03 am

We do know that if you have a home assistant connected via the LAN port it will no longer work as the LAN function has been removed (you have to connect via modbus or cloud)

It is newer but Foxess don’t issue firmware release notes so the updates/bugs etc.. are not known.
--- End quote ---
That means they can do what they like when you connect it up to them through their "smart wifi" stick.
Leaving the customers in the dark and do things behind their back through the firmware updates.

1. Foxess... Lied that it doesn't work when it did as documented in the manual
2. I sent them an email proving them wrong showing that it does work with Homeassistant via addon with no problems.
3. It seems more people start doing it, a Youtube video and other forums detailing how.
4. Foxess later disables the feature.

Now how does that look for Fox-ess? Very dishonest

Joke: Anyone reading this with this inverer or inverter like it fancy throwing away their "smart wifi stick" in protest.
Any new customers refuse such a stick?

I waiting for the day when they start charging subscription fee's for their cloud nonsense for whoever they forced or got trapped into it.


--- Quote
Hello *****,

Modbus TCP is not available after the firmware 1.50.

But customers can still use Modbus RTU with RS485  :-+ . *There is no effect that customer can use their own private monitoring appliance.
--- End quote ---

I like that answer. I asked why but gave the above solution which is good enough.

I would have brought that from the start had they advised.

*Thank you very much Fox-ess for giving us a choice recommending this and taking in account our thoughts on private in house monitoring.

Greatly appreciated.

Going to order it and prepare my installation incase the inverter fails and need to switch on replacement.

I remembered being told before the contract (and before the change to one inverter) that I could void my warranty if anything goes wrong and they find things connected up to that serial port (where the dongles go) that are not approved by the manufacturer but now I got their backing so I am no longer in the dark.

I just checked the manual and it looks like the RS485 connection pins are inside a plug (Item e) that also has pins for other stuff where it needs to be wired into.

There is a CT clamp already connected inside that plug so this will be a job for the contractor when it needs to be done.

Hi MrMobodies,
I just saw that the menu on the FoxESS web portal has changed.
A "Meter Management" menu item has been added.
Maybe this news could be related to disabling the modbus TCP port?

PS: How do you post images inline on this forum?   |O

Unfortunately the image attach feature got broken from an update many years ago where it started to show attached pictures from other threads.

I attach the pictures by post and use Imgur for inline lower resolution pictures which is not ideal.

Meter Management
That looks to me like for joining up power meters like the one on Item E connector.
Maybe they are now supporting more than just two types.


[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod