Author Topic: Autorouting help in EAGLE  (Read 5190 times)

0 Members and 1 Guest are viewing this topic.

Offline SKY KALAITopic starter

  • Contributor
  • Posts: 20
  • Country: in
Autorouting help in EAGLE
« on: December 19, 2021, 02:24:09 pm »
Hi friends hope you all are doing well.

I faced a one problem in autorouter in EAGLE

How to stop that trace going through polygon?

I already make polygon where I want, then I started the autorouter, the traces are passing through the polygon |O. How do I disable it ? I attached a reference picture below.

Can anyone please help me .

Thanks  :)
« Last Edit: January 21, 2022, 04:15:04 am by SKY KALAI »
 

Offline jpanhalt

  • Super Contributor
  • ***
  • Posts: 3316
  • Country: us
Re: Autorouting help in EAGLE
« Reply #1 on: December 19, 2021, 02:54:19 pm »
It would help, if you gave the version of Eagle you are using.

Looking at your design, it appears you may have forgotten to name the net/signal for the polygon.  If it is GND, then give it that name.  There are a few ways to do that.  Most obvious is to use the "name" tool.

If that is not the case, what is its name and the names of the signals that "go through it? 
 

Offline SKY KALAITopic starter

  • Contributor
  • Posts: 20
  • Country: in
Re: Autorouting help in EAGLE
« Reply #2 on: December 19, 2021, 04:24:38 pm »
Hi sir thanks for your reply

I'm using 9.5.1 version.

You are correct the polygon is "GND", also I named it.

but in autorouting process the traces are passing through it, then I click the ratsnest the clearance make between trace and polygon.

Typically I'm new to EAGLE. I dont know how this happened? Is this happened in your experience sir?

Thanks
 

Offline jpanhalt

  • Super Contributor
  • ***
  • Posts: 3316
  • Country: us
Re: Autorouting help in EAGLE
« Reply #3 on: December 19, 2021, 05:39:49 pm »
I have attached a snippet of your PCB.  The isolated pad in the lower right is suspicious.  If it is also GND, then it should be connected to the pour, with or without thermals for heat isolation.

Double check that the pour is actually a signal.  In the command box: "show GND" (don't use quotes)   That should highlight everything named ground.  Two other attachments for a board I did recently are shown.  One, "no pour" shows the board design.  The other with pour is a similar area with ratsnest done.  Note incorporation of ground pads into the pour and isolation of traces that are not part of the GND plane.  That's normal.
 

Offline nigelwright7557

  • Frequent Contributor
  • **
  • Posts: 688
  • Country: gb
    • Electronic controls
Re: Autorouting help in EAGLE
« Reply #4 on: December 19, 2021, 06:38:42 pm »
My pcb's tend to be so complex it would be impossible to not go through copper pours.

If you cant stop it then instead of a copper pour just put down a large copper track connected to GND and that wont be invaded.

 

Offline SKY KALAITopic starter

  • Contributor
  • Posts: 20
  • Country: in
Re: Autorouting help in EAGLE
« Reply #5 on: December 20, 2021, 04:26:14 am »
Hi panhalt sir,

I named all correct sir.  I just attached a reference picture to you sir, so the parts placement are I arranged roughly.

I fix my board layer 2. I need that copper area for current flow sir. So first I make my copper area constant. then I give autoroute, the traces are passing through copper area, that's my problem. why the traces shouldn't be in bottom layer?  Is there any settings available for that? sir

Thanks
 

Offline SKY KALAITopic starter

  • Contributor
  • Posts: 20
  • Country: in
Re: Autorouting help in EAGLE
« Reply #6 on: December 20, 2021, 04:30:29 am »
Hi sir

Yeah you are right but I need a specific shape of a copper area, thats why I'm using polygon.
If I'm using a big traces while autorouting , the traces are not go through it. I will try to draw a shape of trace and then try with autorouter

Thanks
 

Offline jpanhalt

  • Super Contributor
  • ***
  • Posts: 3316
  • Country: us
Re: Autorouting help in EAGLE
« Reply #7 on: December 20, 2021, 11:02:26 am »
I think I see the problem.  There is no way autoroute will avoid those other traces, as what you got is what most people want.

Some options to avoid that:
1) Only allow autorouting on one side (say bottom).  That will be very ugly.
2) Do not use autorouting.
3) Use autorouting and rip-up the traces that cross the pour.  Then manually route just those traces and any others that need to be changed.
4) Don't use a polygon pour.  You can define that area as a "do not go" place.  Autoroute, then manually add your high current trace.
5) You might try reversing the order in #4.  That is, manually route the one wide trace.  Then autoroute, if your version allows that.

Your version of Eagle may have additional controls.  If you can't select just one side, then make the cost for the top or vias very high.  If that improves things, then manually route those signals that go into the pour.

I have never used autorouting (Eagle ver. 7.2 or 7.7) for a final design.  What I will do sometimes is use autorouting to help improve parts placement  (where such placement is not dictated by other factors), or get some ideas.  I then ripup and route manually.
 
The following users thanked this post: SKY KALAI

Offline SKY KALAITopic starter

  • Contributor
  • Posts: 20
  • Country: in
Re: Autorouting help in EAGLE
« Reply #8 on: December 20, 2021, 03:28:08 pm »
Hi jpanhalt sir,
I will try your points, I hope It will work. then I will let you know

Thanks
 

Online westfw

  • Super Contributor
  • ***
  • Posts: 4191
  • Country: us
Re: Autorouting help in EAGLE
« Reply #9 on: February 14, 2022, 09:29:56 am »
You could temporarilly draw a tRestrict polygon around the areas you don't want routed through.
But in general, if you have copper area that you absolutely want to stay there, you should draw it with actual traces rather than using a polygon.  Being "flexible" is a feature of polygons.
 

Offline jpanhalt

  • Super Contributor
  • ***
  • Posts: 3316
  • Country: us
Re: Autorouting help in EAGLE
« Reply #10 on: February 14, 2022, 10:03:10 am »
That will work, but so will setting priorities.  There can be problems when using traces too, as new users may not realize that geometries are not traces (i.e., they cannot be assigned a signal).   So, "traces" in a strict sense must be used.  A polygon is just an easy way to draw such traces* when assigned a priority of 1.

This thread is probably too old to matter.

John

*For home etching,  I used to use a polygon with very narrow (e.g., 0) width to create a negative logo.  Looked fine, until I submitted one to a board house.  The error was that traces were too narrow.

 
The following users thanked this post: SKY KALAI

Offline SKY KALAITopic starter

  • Contributor
  • Posts: 20
  • Country: in
Re: Autorouting help in EAGLE
« Reply #11 on: February 14, 2022, 05:58:34 pm »
Yeah sir first of all thanks for your reply. you are right. Some weeks ago I learnt and use of restrict layers in EAGLE.  :)
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf