Author Topic: Polygons not Filling  (Read 8943 times)

0 Members and 1 Guest are viewing this topic.

Offline sacherjj

  • Frequent Contributor
  • **
  • Posts: 993
  • Country: us
Polygons not Filling
« on: June 02, 2011, 01:39:35 pm »
I ran into this recently and thought it would be good to post something here for people who are also learning Eagle.  This is another one of those nice non-intuitive things on Eagle.

Polygons have two things that are required to work as you want.

1 - Name the polygon the same as the signal to which it should be attached.  So you can right click on a signal and see the name of N$16.  Then right click on the polygon and select Name and change to N$16.  Now the polygon will flow into that signal.

2 - Once you have the polygon drawn, it will only be dotted outline until you use the RATSNEST command.  You can type that in the command line or right click on the polygon and select Ratsnest.

It took me tons of searching to figure out these two things.  Hopefully it will help someone.

Also, if you are etching your own boards, you can define a bunch of polygons (or large GND polygons) to "use up" copper and reduce the amount you need to etch away.  This will make your etchant last longer and finish faster.
« Last Edit: June 02, 2011, 03:36:53 pm by sacherjj »
 

Offline Afrotechmods

  • Supporter
  • ****
  • Posts: 44
  • Country: 00
    • Afrotech
Re: Polygons not Filling
« Reply #1 on: June 21, 2011, 06:19:27 am »
One last thing that could trip people up, and it sort of relates to the #1 you mentioned:
If the polygon is just sitting alone on the board without a signal of the same name attached to it, you must go to the information/properties of the polygon, and check the box labeled "orphans".
 

Offline ivan747

  • Super Contributor
  • ***
  • Posts: 2013
  • Country: us
Re: Polygons not Filling
« Reply #2 on: June 21, 2011, 11:12:21 pm »
You can enable some options. Here's what I've figured out so far:
  • Use the Orphan option to fill the parts that don't have any connection. They will be floating but it helps for saving some etchant.
  • Disable the thermals option to disable those little crosses on the pads that connect to the polygon. This way will be harder to solder but will dissipate heat off components way better
  • The hatch polygon pour reduces the capacitance of a polygon in a multi-layer board. For example, if you have a sensitive trace in the top layer like a capacitive touch sensor, you can use the hatch pour to reduce the capacitance between the sensor pad and your ground plane.

I still haven't figured out what is the difference between Spacing and Isolate and don't get the concept of the Rank option.
 

Offline Afrotechmods

  • Supporter
  • ****
  • Posts: 44
  • Country: 00
    • Afrotech
Re: Polygons not Filling
« Reply #3 on: June 22, 2011, 06:57:47 pm »
The rank option determines which polygon's area gets completely filled when there are two (or more) polygons overlapping each other.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf