Author Topic: Altium Keyboard Shortcut Issues?  (Read 1520 times)

0 Members and 1 Guest are viewing this topic.

Offline strobot

  • Contributor
  • Posts: 45
  • Country: 00
Altium Keyboard Shortcut Issues?
« on: July 10, 2013, 07:28:59 pm »
I'm having a couple issues with Altium shortcuts:

Seeing all the shortcuts?
Right now, I have View->Workspace Panels->Help->Shortcuts turned on to help me learn the various keyboard shortcuts.
When I go into Interactive Routing mode (P->T) in a PCB document, the Shortcuts panel shows the relevant shortcuts, but the cursor turns into a crosshair for placing the traces and when I try to mouse over the Shortcuts panel, it turns transparent and doesn't allow me to click anything in it.  There is a scrollbar in the Shortcuts panel that I would like to access so that I can see all the available shortcuts.  Is there any way to scroll the shortcuts panel while in Interactive Routing?

Rebind Interactive Routing Shortcuts?
The second issue is that some of the shortcuts in Interactive Routing only apply to keyboards with a numeric keypad.  For example: Next Layer and Previous Layer are bound to + and - on the numeric keypad.  I'd like to bind these to something different, so that I can access them easily on a laptop keyboard without a numeric keypad.  How do I go about doing this?
I read this blog post, but I can't find those commands when I click the Browse... button in the Edit Command dialog.
http://altiumpcbdesigner.blogspot.com/2012/11/custom-shortcut-keys.html

Switch Layer for Current Trace?
The "L" shortcut under Interactive Routing for Switch Layer for Current Trace doesn't seem to do anything.  I place part of a trace on the top layer, then press L, and all I hear is the bell error sound.  Nothing happens.  Whats the deal?  Top Layer and Bottom layer are enabled in the View Configurations layer manager.


EDIT: crap, please delete.  I have posted in the correct, Altium subforum
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf