Author Topic: free routing has just become a wet lettuce  (Read 2299 times)

0 Members and 1 Guest are viewing this topic.

Offline SimonTopic starter

  • Global Moderator
  • *****
  • Posts: 17881
  • Country: gb
  • Did that just blow up? No? might work after all !!
    • Simon's Electronics
free routing has just become a wet lettuce
« on: July 11, 2023, 01:59:11 pm »
I've used freerouting for a long time but lately it seems to struggle with the simplest of tasks, or rather it will route the board to a point leaving things that are next to each other or in a clear line of sight unrouted.

Has something changed? I am launching it from kicad, does that apply particular settings?
 

Online SiliconWizard

  • Super Contributor
  • ***
  • Posts: 14892
  • Country: fr
Re: free routing has just become a wet lettuce
« Reply #1 on: July 11, 2023, 09:44:35 pm »
I haven't used freerouting in years and I thought it was dead. I have an old version of it (the last one the original author released before stopping, I think he had troubles with Zuken or something regarding IP.)

Anyway, just saw that it's still being maintained (didn't know): https://github.com/freerouting/freerouting
I don't know what version you use with KiCad. But if it's a recent version/if it updates from github, then definitely there are commits that date back to 1 month ago.
If you can reproduce the issue with a "minimal" design, maybe you can open a ticket on their github.
 

Online julian1

  • Frequent Contributor
  • **
  • Posts: 743
  • Country: au
Re: free routing has just become a wet lettuce
« Reply #2 on: July 12, 2023, 04:16:36 am »
The work done in freerouting to support multi-threading was a good performance improvement. There could be a debate about how comparable the output results are with that produced from older code forks. 
 

Offline SimonTopic starter

  • Global Moderator
  • *****
  • Posts: 17881
  • Country: gb
  • Did that just blow up? No? might work after all !!
    • Simon's Electronics
Re: free routing has just become a wet lettuce
« Reply #3 on: July 12, 2023, 08:18:50 am »
Well I ran the same board in the same freerouting but without launching it via the kicad plugin and it worked just fine. I looks like the kicad plugin may be passing some setting that causes an issue.
 
The following users thanked this post: SiliconWizard


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf