EEVblog Electronics Community Forum

Electronics => PCB/EDA/CAD => Topic started by: KhronX on March 21, 2018, 12:07:42 pm

Title: LTspice XVII disabling waveform "drag" with Ctrl depressed?
Post by: KhronX on March 21, 2018, 12:07:42 pm
I went ahead and installed the latest LTspice ("XVII") last night. For the most part, it looks and feels pretty much as the IV version.

One very irritating "feature" i've stumbled across, though, is that whenever the waveform plot window is highlighted, my mouse cursor is within its confines and i press down Ctrl (in preparation to click on the name of a waveform to have it measured), it drags the plots along  |O

Then after i notice that, i have to let go of Ctrl and wait for the waveforms to get re-drawn, then re-zoom, then place the mouse cursor on the waveform name before pressing Ctrl then clicking on it.  :wtf:  :rant:

The older version doesn't behave like that. Anyone have any idea if and how this can be disabled?  :palm:
Title: Re: LTspice XVII disabling waveform "drag" with Ctrl depressed?
Post by: PCB.Wiz on March 23, 2018, 08:34:12 pm
After Zoom-to-fit, CTRL-Mouse seems to be live, but if I click on any node name, that seems to then disable ctrl ?
Title: Re: LTspice XVII disabling waveform "drag" with Ctrl depressed?
Post by: KhronX on March 23, 2018, 08:44:24 pm
That's a good catch actually, i can confirm that. Still not what i'd call "normal", though.
Title: Re: LTspice XVII disabling waveform "drag" with Ctrl depressed?
Post by: SiliconWizard on March 24, 2018, 06:49:15 pm
Quite frankly, I've found the Waveform viewer of LTSpice XVII a huge regression compared to LTSpice IV, without any significant new feature. It's riddled with nasty bugs.

 |O
Title: Re: LTspice XVII disabling waveform "drag" with Ctrl depressed?
Post by: KhronX on March 24, 2018, 06:53:35 pm
So it's not just me, then...  :o