Author Topic: Nonzero voltage accross opamp inputs (LTSpice)  (Read 1123 times)

0 Members and 1 Guest are viewing this topic.

Offline Brutte

  • Frequent Contributor
  • **
  • Posts: 614
Nonzero voltage accross opamp inputs (LTSpice)
« on: January 15, 2017, 11:12:48 am »
I am simulating a modified follower circuit in LTSpice 4.20 (XP) and I have no idea why differential input voltage Ua-Ub jumps around by 10mV here. As a consequence in such follower an output voltage Uout=Ua does not follow input Ub..

I use a generic ideal ".include op-amp.sub" here. The GBW is 1MHz. Aol=100dB so with 10mV input the output should go to 1kV while only 10V is required here so that looks like finite Aol is not the cause. The load is an ideal current source, 1mA amplitude 1kHz sine. I expected the Uout to be near 0V.

Where does that "offset voltage" come from? Is it from LTSpice or that is the physics of an opamp?

BTW, I do not want to remove R2 but to understand where that discrepancy comes from. This is a part of bigger circuit.
 

Online Ian.M

  • Super Contributor
  • ***
  • Posts: 8194
Re: Nonzero voltage accross opamp inputs (LTSpice)
« Reply #1 on: January 15, 2017, 12:43:25 pm »
Open Loop Gain=100K, Gain*bandwidth=1MHz =>3dB Corner frequency=10Hz.
At 1KHz the effective open loop gain is only 1K (60dB).
To produce 1mA through a 10K resistor (R2) the OPAMP must output 10V (relaqtive to its - in) 10V.  At a frequency where its gain is 1K, it needs 10mV input differential to do so.
 
The following users thanked this post: Brutte


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf