Products > Embedded Computing

ST-Link V2 Virtual COM Port Not Working

<< < (5/5)

Cerebus:

--- Quote from: AndyC_772 on October 05, 2021, 06:03:49 am ---
--- Quote from: Cerebus on October 04, 2021, 11:27:22 pm ---Also the ST-LINK/V2 shows up as a USB mass storage device on both ST-LINK/V2-A and ST-LINK/V2-B, you can program the part just by copying a file to the drive (again, no drivers needed).
--- End quote ---

I thought that feature relied on a bootloader being installed in the target MCU? I've seen it on one or two Nucleo boards, but IIRC it stops working if the device is erased.

--- End quote ---

Nope, all part of the ST-LINK. It accesses the target MCU over the hardware debug interface so the target can be as blank as my expression when my other half asks if it was her or me who left the toilet roll in the holder with only 2 sheets left.

PKTKS:

Fixed mistyped word on SUB translation

Not Holtek ( iam a veteran  ^-^ )  is Heltec https://heltec.org/

and can even be mistyped again..  in 2 secs

sorry
Paul

DavidAlfa:
STlink v2 doesn't have serial port. Only v2.1.
V2.1 uses 128KB stm32, while v2 uses 64KB only, so there wasn't enough space.
Check the reported stlink version in stlink utility or similar.

PKTKS:
this folk also published a hack to workaround such odd error in windoooze...



Never tried 'caus not using windooze w/my stlink..

but the "solution" resembles the other..
press reset push again.... etc etc..

Paul

Navigation

[0] Message Index

[*] Previous page

There was an error while thanking
Thanking...
Go to full version