Author Topic: Altera ModelSim Starter edition license error  (Read 19381 times)

0 Members and 1 Guest are viewing this topic.

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Altera ModelSim Starter edition license error
« on: January 04, 2015, 08:28:49 pm »
I thought I would have a go with Altera ModelSim. I already have Quartus II 14.1 Web Edition installed and running fine, compiling my designs. However, when I try to run ModelSim, it complains with 'Fatal License Error' saying it is unable to checkout a license. I have carefully made sure that I ran the Altera Starter Edition including selecting that option during the installation process and it says that no license is required. I tried installing it on a different computer but I get exactly the same message when I try to run it. The first computer was 64 bit Windows 7, the other one was 32 bit Windows 7.

Do I need some sort of license file to keep it happy, even though Altera says it doesn't need it?
 

Offline miguelvp

  • Super Contributor
  • ***
  • Posts: 5550
  • Country: us
Re: Altera ModelSim Starter edition license error
« Reply #1 on: January 05, 2015, 12:35:47 am »
I think you have to enable the talkback for that to work. Let me check where the setting is at.
 

Offline miguelvp

  • Super Contributor
  • ***
  • Posts: 5550
  • Country: us
Re: Altera ModelSim Starter edition license error
« Reply #2 on: January 05, 2015, 12:42:07 am »
It's on: Tools->Options under General->Internet Connectivity and click on the TalkBack Options button.

Under Enable check the "Enable sending TalkBack data to Altera" it only sends metadata not your projects.

Edit: that menu is in Quartus II btw.
« Last Edit: January 05, 2015, 12:44:45 am by miguelvp »
 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #3 on: January 05, 2015, 08:32:36 am »
It's on: Tools->Options under General->Internet Connectivity and click on the TalkBack Options button.

Under Enable check the "Enable sending TalkBack data to Altera" it only sends metadata not your projects.

Edit: that menu is in Quartus II btw.

Many thanks, I am indebted to you. I don't think I would ever have found that. I did do a lot of web searching for the answer before asking here.
 

Offline miguelvp

  • Super Contributor
  • ***
  • Posts: 5550
  • Country: us
Re: Altera ModelSim Starter edition license error
« Reply #4 on: January 05, 2015, 09:09:35 am »
Not a problem, Quartus II 14.1 Web Edition is free so they do require you enable the talkback for some of the functionality including also SignalTap.

In that dialog box you can find details on what where the data that is sent is stored in case you want to know more about what it's being sent. I did look at it a while back and it didn't look too intrusive.
 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #5 on: January 05, 2015, 11:27:29 am »
Not a problem, Quartus II 14.1 Web Edition is free so they do require you enable the talkback for some of the functionality including also SignalTap.

In that dialog box you can find details on what where the data that is sent is stored in case you want to know more about what it's being sent. I did look at it a while back and it didn't look too intrusive.

Thanks. I don't have a problem with sending back data to them, I doubt if they will be that interested in what I'm  up to!
 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #6 on: January 05, 2015, 06:55:19 pm »
It's on: Tools->Options under General->Internet Connectivity and click on the TalkBack Options button.

Under Enable check the "Enable sending TalkBack data to Altera" it only sends metadata not your projects.

Edit: that menu is in Quartus II btw.

Oh dear, I tried that but still get the message saying I need a license. I made sure I could log in to the Altera website with my account so not sure what I haven't done. I tried restarting Quartus and even tried rebooting the PC but still no. Any clue as to what else I need to do?
 

Offline miguelvp

  • Super Contributor
  • ***
  • Posts: 5550
  • Country: us
Re: Altera ModelSim Starter edition license error
« Reply #7 on: January 05, 2015, 09:33:50 pm »
Are you downloading the stand alone ModelSim or the one that came with Quartus II 14.1 Web Edition?


I mean is it in C:\altera\14.0\modelsim_ase\win32aloem ?
 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #8 on: January 05, 2015, 09:53:52 pm »
Are you downloading the stand alone ModelSim or the one that came with Quartus II 14.1 Web Edition?


I mean is it in C:\altera\14.0\modelsim_ase\win32aloem ?

Yes, it's in that directory
 

Offline miguelvp

  • Super Contributor
  • ***
  • Posts: 5550
  • Country: us
Re: Altera ModelSim Starter edition license error
« Reply #9 on: January 05, 2015, 10:51:38 pm »
Strange,

I would ask support at:
http://www.altera.com/mySupport

I tried on two systems with Win7 professional 64 bit and they both work out of the box, but I never installed modelsim separately
 

Offline mkissin

  • Regular Contributor
  • *
  • Posts: 103
Re: Altera ModelSim Starter edition license error
« Reply #10 on: January 05, 2015, 11:27:56 pm »
There is a known bug with the licensing for ModelSim at the moment:

http://dl.altera.com/?edition=web

You need to apply a patch to allow it to work properly.
« Last Edit: January 05, 2015, 11:30:09 pm by mkissin »
 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #11 on: January 06, 2015, 08:28:09 am »
There is a known bug with the licensing for ModelSim at the moment:

http://dl.altera.com/?edition=web

You need to apply a patch to allow it to work properly.

Yes, I contacted Altera support and they told me of the patch - that sure does explain things! I can't try this till later but it sounds like this should fix it.

Thank you miguelvp and mkissin for your help.


 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #12 on: January 06, 2015, 06:32:53 pm »
That was it, all working now. Thanks again guys.
 

Offline andersm

  • Super Contributor
  • ***
  • Posts: 1198
  • Country: fi
Re: Altera ModelSim Starter edition license error
« Reply #13 on: January 13, 2015, 11:47:39 pm »
It seems that the ModelSim 14.1-0.01m patch is no longer available for download, and instead there's a new installer package with the same version number.

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #14 on: January 14, 2015, 02:02:50 pm »
It seems that the ModelSim 14.1-0.01m patch is no longer available for download, and instead there's a new installer package with the same version number.

That's not very clever!
 

Offline maximumsam

  • Contributor
  • Posts: 5
Re: Altera ModelSim Starter edition license error
« Reply #15 on: February 18, 2015, 07:22:19 am »
That was it, all working now. Thanks again guys.


Hi: I'm also having the exact same problem, can you please post the link to the patch? Did you have an online technical support helping you with it? since I cannot find the link to contact support staff, only documentations...
 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #16 on: February 18, 2015, 08:40:30 am »
That was it, all working now. Thanks again guys.


Hi: I'm also having the exact same problem, can you please post the link to the patch? Did you have an online technical support helping you with it? since I cannot find the link to contact support staff, only documentations...

I believe it is fixed in the latest software, have you tried downloading that? Yes, I did file a technical support question. Have you created an account on the Altera website? I see they have a beta of a new version of their website so it may have all changed since I logged in last.

 

Offline maximumsam

  • Contributor
  • Posts: 5
Re: Altera ModelSim Starter edition license error
« Reply #17 on: February 22, 2015, 07:05:42 am »
That was it, all working now. Thanks again guys.


Hi: I'm also having the exact same problem, can you please post the link to the patch? Did you have an online technical support helping you with it? since I cannot find the link to contact support staff, only documentations...

I believe it is fixed in the latest software, have you tried downloading that? Yes, I did file a technical support question. Have you created an account on the Altera website? I see they have a beta of a new version of their website so it may have all changed since I logged in last.

I downloaded the latest version along with the patch ( QuartusSetup-14.1.1.190) patched it, still getting the exact same error :(
 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #18 on: February 22, 2015, 09:30:11 pm »
Earlier in this thread someone suggested that you need to turn on talkback, did you do that?
 

Offline maximumsam

  • Contributor
  • Posts: 5
Re: Altera ModelSim Starter edition license error
« Reply #19 on: February 25, 2015, 06:27:15 am »
Earlier in this thread someone suggested that you need to turn on talkback, did you do that?

Yes I did! :-[
 

Offline maximumsam

  • Contributor
  • Posts: 5
Re: Altera ModelSim Starter edition license error
« Reply #20 on: February 25, 2015, 06:29:40 am »
Earlier in this thread someone suggested that you need to turn on talkback, did you do that?

Yes I did! :-[

I'm thinking about ask support for help, but was struggling to find the link to contact a real support staff... Is the patch posted right now the one that solved your problem? :-\
 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Altera ModelSim Starter edition license error
« Reply #21 on: February 25, 2015, 08:48:50 am »
Earlier in this thread someone suggested that you need to turn on talkback, did you do that?

Yes I did! :-[

I'm thinking about ask support for help, but was struggling to find the link to contact a real support staff... Is the patch posted right now the one that solved your problem? :-\

The patch that was posted at the time I originally reported the problem here was the one that fixed it.

Go here https://www.altera.com/myaltera/mal-signin.jsp and, if you don't have one, create an account. Then you'll be able to click on MySupport and issue a support request.
 

Offline maximumsam

  • Contributor
  • Posts: 5
Re: Altera ModelSim Starter edition license error
« Reply #22 on: February 27, 2015, 03:42:17 am »
Earlier in this thread someone suggested that you need to turn on talkback, did you do that?

Yes I did! :-[

I'm thinking about ask support for help, but was struggling to find the link to contact a real support staff... Is the patch posted right now the one that solved your problem? :-\

The patch that was posted at the time I originally reported the problem here was the one that fixed it.

Go here https://www.altera.com/myaltera/mal-signin.jsp and, if you don't have one, create an account. Then you'll be able to click on MySupport and issue a support request.

Thanks a lot man  :D
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf