Electronics > FPGA

Automated tests with Xilinx ISIM on windows

(1/2) > >>

steve_sky:
Hi all!
 
I'm doing a computer vision project on a xilinx fpga. For testing I have created a testbench; which read an image from file, processes it and then dump the result to a new file. And it works perfectly. (I’m using ISE (the FPGAs I have is not supported in vivado))
 
At the moment I’m using a .tcl script to run the testbench, with the "source test.tcl" command in ISIM. But it is getting a bit tedious having to open the ISIM gui every time I run the simulation when I’m only using the ISIM command line.
 
So I would be really nice if it was possible to run the simulation without the gui but instead with a scripting interface (e.g. a bat file or similar).
 
I have look through the "ISIM User Guide"" and "ISE Simulator (ISIM) in-depth tutorial" and google searches but without any luck. except this one: http://www.xilinx.com/support/documentation/sw_manuals/xilinx11/ism_c_modes_operation_overview.htm

But unfortunately i can’t get it to work:

* I tried the fuse command in cmd but just get this messege "'fuse' is not recognized as an internal or external command,operable program or batch file."
* I also tried to use the .exe generated by ISIM when the gui is used (projectname_isim_beh.exe). but just gives me the "projectname_isim_beh.exe has stopped working" window, where Windows tried to find a solution but with no result.I guess I'm doing something wrong or skipping a step. So if you know of any more detailed documentation or a step-by-step guide i would really appreciate it.

Best regards

6thimage:
For ISE in linux, there is a settings file you have to source that adds the xilinx folders to the system's path variable. I'm going to guess it is similar on windows (I've never used ISE on windows). So it might be worth having a look if there is a settings.bat file (or similar) in the top directory of the xilinx program folder (on linux it is at Xilinx/14.7/ISE_DS/).

steve_sky:
There is a settings64.bat (and settings32.bat) in C:\Xilinx\14.7\ISE_DS\. However adding it to the system environment PATH variable made no difference - the .exe still fails when I run it...

6thimage:
Sorry - I wasn't very clear. What you will need to do is run 'call c:\Xilinx\14.7\ISE_DS\settings64.bat' in a command prompt prior to running any of the ISE programs (fuse, isim etc.). This will need to be done every time you open a command prompt window you want to use for ISE.

This settings script will alter the path variable that the command prompt uses so the ISE programs can be found. In linux, this is called sourcing a script.

steve_sky:
That did the trick!! Thank you so much, you just saved me for a lot of tedious work  :D

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version