Electronics > FPGA

Error 0xc0000142 on Xilinx SDK



I keep getting the error, "The application was unable to start correctly" when running Xilinx's SDK. I'm on a Windows 10 machine and I'm using 2016.1 version of Vivado and SDK. I've looked at multiple forums on Xilinx's website but none of them worked for me. I'm currently running it on standalone mode as suggested by this post(http://www.xilinx.com/support/answers/53306.html) that was referenced in one of the forums. Could someone who uses Xilinx's SDK tell me if you found a workaround or how you can fix this issue?

Thanks a bunch!

The error code is from Windows, not Xilinx.  It just so happens you are using a Xilinx app but it also happens on Autocad and others.
It seems like the Xilinx app is trying to load or execute an invalid .dll's which seems to be related to the PATH variable.


I see you are part of that thread.  Did you try to clean up your path and remove other programs like avr-gcc, python and so on?

Others recommend uninstalling, deleting any left over registry entries and then re-installing.  Sounds like the definition of insanity - doing the same thing twice and expecting different results.


I also use Win 10 and, for me, the SDK seems to work just fine.  I have Arduino and Python installed so, either DLLs aren't a problem or I was just plain lucky.  By 'works just fine', I mean it loads.  I have never used it.

Why not try messing with PATH?  You can always reset it later.

Thanks for your reply!

I tried something someone posted on a similar thread which was to uninstall WinAVR. Uninstalling this helped fix the issue.


[0] Message Index

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod