Author Topic: Lattice Diamond Reveal Analyzer cable connection problem  (Read 900 times)

0 Members and 1 Guest are viewing this topic.

Offline lk.dgironi

  • Contributor
  • Posts: 25
  • Country: it
Lattice Diamond Reveal Analyzer cable connection problem
« on: June 24, 2022, 03:54:03 pm »
Hello,

I'm having problem connecting to the ispDOWNLOADER in Reveal Analyzer.
Software: Lattice Diamond 64-bit - 3.12.1.454
OS: Windows 10
Programmer: HW-USBN-2A clone

No problem during the program stage.
I can run the Revel Analyzer just once, than I have to disconnect the cable programmer and connect it again.
I end up having two errors.

[16:22:51] @SetCablePort,USB,EzUSB-0,8,0,0,1,1,0,0,0,10
[16:22:51] ERROR: failed to set cable port (cable:USB port:EzUSB-0 error:-5). <a href='file:///C:/lscc/diamond/3.12/docs/manuals/troubleshoot.pdf#FailurePoints'>See Reveal Troubleshooting Guide for more details on Failure Points (2) and (5)[/url]
[16:22:53] @SetCablePort,USB,EzUSB-0,8,0,0,1,1,0,0,0,10
[16:22:53] ERROR: failed to set cable port (cable:USB port:EzUSB-0 error:-1). <a href='file:///C:/lscc/diamond/3.12/docs/manuals/troubleshoot.pdf#FailurePoints'>See Reveal Troubleshooting Guide for more details on Failure Points (2) and (5)[/url].

Find full log attached.

Wondering if anyone has the same problem.
I've found someone here having the same problem https://hifpga.com/%E9%97%AE%E9%A2%98/37542/win10-diamond311%E9%80%9A%E8%BF%87reveal%E6%8A%93%E5%8F%96%E4%BF%A1%E5%8F%B7%E9%97%AE%E9%A2%98/
By Google translator they seems to suggest to download the version 3.10 of Diamond, but I can not find it.
Maybe someone has a copy?

Any help appreciated!

« Last Edit: June 28, 2022, 12:49:58 pm by lk.dgironi »
 

Offline mon2

  • Frequent Contributor
  • **
  • Posts: 377
  • Country: ca
 

Offline lk.dgironi

  • Contributor
  • Posts: 25
  • Country: it
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #2 on: June 27, 2022, 07:12:47 am »
Made a couple of times, no difference.
I've notice that sometimes it works twice.
I've also try to add a dealy to TCK low pulse. No luck.
 

Offline mon2

  • Frequent Contributor
  • **
  • Posts: 377
  • Country: ca
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #3 on: June 27, 2022, 08:28:09 am »
Open a support ticket with Lattice technical support. Last interaction for us was very  good with their staff in the Philippines. Continue to post your resolution here.
 

Offline lk.dgironi

  • Contributor
  • Posts: 25
  • Country: it
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #4 on: June 28, 2022, 07:09:04 am »
Unluckily mine it's a clone. I suppose they will not service me. I'll try other desktop PC to see if it works there.
 

Offline agehall

  • Frequent Contributor
  • **
  • Posts: 356
  • Country: se
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #5 on: June 28, 2022, 12:49:04 pm »
Ah, so not what you stated in your first post then. That could explain a lot. Clones typically don’t see the same QA process as real things so it may very well be that your programmer is just broken.
 

Offline lk.dgironi

  • Contributor
  • Posts: 25
  • Country: it
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #6 on: June 28, 2022, 12:51:25 pm »
Right, it may be a problem but I would like to ask if someone has this issue too.  :-//
Edited first post.
« Last Edit: June 29, 2022, 07:20:14 am by lk.dgironi »
 

Offline lk.dgironi

  • Contributor
  • Posts: 25
  • Country: it
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #7 on: June 29, 2022, 07:20:59 am »
Just thinking about this.
It's a problem of my device or it's a problem of all clone HW-USBN-2A cable programmer?
 

Offline mon2

  • Frequent Contributor
  • **
  • Posts: 377
  • Country: ca
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #8 on: July 01, 2022, 11:54:07 am »
IMHO, you are wasting valuable time.

1) Contact the vendor that sold you this tool and ask for their support. I do see many clones on the market so likely it does function or did with some release of the tools from Lattice. Consider to test against older releases of their toolchain.

2) I recall when we were experimenting with the flaky Lattice tools and poor and buggy documentation which we corrected many times - a few corrections made it to the public releases. They just had a DGF attitude unless you are a tier 1 player and can consume container loads of parts per day. We begged for a few simple questions to be answered and they denied the support. Eventually the fresh rookies on the emailed tech support attempted to help but in the end, we corrected their wrong line of logic and resolved the issues ourselves. So many broken tools out there - have seen it over and over again. In the end, we as developers suffer and so does the factory. We have millions of products in the market and could have been a diehard Lattice account but they lost out on support. Now chasing other vendors that are showing promise but the tools from the factory should work - plain and simple. Otherwise it is just crapware.

In one of my many vents to Lattice factory because our local reps were of no help and put up a firewall on the local FAE support - the folks in Oregon stated that many employees were gone and the business model was support via internet = offshore it to the Philippines or India. Don't care if the support is from Mars but there should be support for the crap you are trying to sell. If the documentation is broken and missing critical details which we are using to learn from, then the product is of no use for a new developer. Seen this from Silabs, Lattice, Efinix (they finally corrected their errors after we invested a month to convince them). Where is our compensation ? In the end, like my staff complains - 'why are we helping the factory which will allow them to sell more of their product and to our competition?'. Yup.

I do know that we dished out a large sum of money for their rev B of this Lattice tool and inside, the device is the FTDI MPSSE based controller. From the log you shared, it appears that yours is the Cypress USB controller. I would review if the tools even support the current toolchain.
 

Offline lk.dgironi

  • Contributor
  • Posts: 25
  • Country: it
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #9 on: July 01, 2022, 02:46:40 pm »
Thanks for your support and sharing of your experience.
I would like to test against Diamond 3.10 on Windows, but unluckily I can not find previous version download on their website  |O, I've ask Lattice support.
 

Offline mon2

  • Frequent Contributor
  • **
  • Posts: 377
  • Country: ca
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #10 on: July 01, 2022, 07:14:47 pm »
See attached on how you can download the older version(s).

 

Offline lk.dgironi

  • Contributor
  • Posts: 25
  • Country: it
Re: Lattice Diamond Reveal Analyzer cable connection problem
« Reply #11 on: July 04, 2022, 07:47:25 am »
Thanks!
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf