Electronics > FPGA

New Gowin board

<< < (4/6) > >>

An article with two nice projects using the Tang Nano 4K:

Just received some Tang Nano 4K boards....

Anyone using the IDE under Linux? Can't program the board without doing:

--- Code: ---sudo rmmod ftdi_sio
sudo rmmod usbserial
--- End code ---

first....the programmer wants to run "rmmod" and fails of course when IDE is launched as a regular user.

Then the programmer says it is an unknown cable...so I assume it only lists official GoWin DKs.

SRAM programming is fine then...but haven't figured out how to correctly flash the external P23Q32H. It does flash...but configuring the FPGA.

To reduce the cost of the kit or due to parts shortages, this kit is using the BOUFFALO LABS (China) CPU to emulate the FTDI FT2232H operation.

You can check the workings on Windows to confirm which device driver loads. We recently brought in the dedicated boards with the BOUFFALO LABS IC to see if it can possibly be used elsewhere. They just arrived in the past few days from Aliexpress.

We have attempted to email BOUFFALO LABS for details on the applied micro (BL702) but no reply has been received so far.

Some links:







Well..no Windows here (o;

Seems I am stuck being able to program SRAM confgiuration only.....but as the HDMI example doesn't show anything on my monitor....guess I can dump thise Tang Nano 4K boards (o;

Are you firmly seating the HDMI connector into the socket on the Tango 4K board ? Fairly confident that it worked fine for us but it has been a few weeks at least since testing.

We bought the version with the CMOS camera module and could see the camera act like a webcam and transmit onto the HDMI screen. Recall it looking like B&W output but it worked fine.


[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Go to full version