Author Topic: Quartus issue - Nios 2 Software Build Tools for Eclipse crashes on startup  (Read 189 times)

0 Members and 1 Guest are viewing this topic.

Offline zigunov

  • Newbie
  • Posts: 4
  • Country: br
Hi, all!

I'm a complete beginner to FPGA development. Trying to get started! I'm really hitting a wall here and I haven't even made it out of the tutorial! |O

I got a DE-0 Nano board, successfully installed Quartus Prime Lite and went through the simple counter tutorial. That went fine and dandy! Got the dev board to blink some LEDs and now I kinda understand some of the Verilog language. Now I'm trying to implement the NIOS 2 processor core. The tutorial given by the DE0-nano manual (https://www.terasic.com.tw/cgi-bin/page/archive_download.pl?Language=English&No=593&FID=75023fa36c9bf8639384f942e65a46f3), chapter 7, is actually rather useless because the Quartus version is too outdated. I'm following this tutorial that was actually more useful so far:
https://youtu.be/1a_cD6FBROA


The issue I'm facing is actually very simple and reproducible independently of the tutorial. I just want to open the "Nios 2 Software Build Tools for Eclipse" software. When I try to open it, NOTHING HAPPENS. Literally, nothing. No error message, no splash screen. My cursor briefly changes to a circle (indicating something is loading) and then returns to normal. It just silently crashes!

Some information that I think can help you guys help me:
1. I'm on a Windows 10 machine, so the solutions given on this topic (https://forums.intel.com/s/question/0D50P00003yyTjNSAU/nios-ii-software-build-tools-for-eclipse-is-not-openning?language=en_US) are not useful because they apply only to Linux
2. I tried the random usual things:
2.1. Run as admin, same issue
2.2. Go to the original folder - (C:/intelfpga_lite/19.1/nios2eds/bin/) and running eclipse-nios2.exe it directly from there - same issue (nothing happens)
2.3. Running eclipsec-nios2.exe from that folder, from cmd, gives me the following message: Error - failed to launch '"C:/intelfpga_lite/19.1/nios2eds/bin/eclipse_nios2/eclipsec.exe" "-pluginCustomization" "C:/intelfpga_lite/19.1/nios2eds/bin/eclipse_nios2/plugin_customization.ini" "-vm" "C:/intelfpga_lite/19.1/quartus//bin64/jre64/bin/java.exe". There's a duplicated bar in the file name. I searched through the entire quartus install folder. Did not find any file that contains that issue.
2.4. Reinstalling JRE and JDK. Current versions are JDK 13.0.2 and JRE v8 update 251 build 1.8.0_251-b08
2.5. Inside the C:/intelfpga_lite/19.1/nios2eds/bin/ folder there's a README file. I followed its instructions and unzipped the eclipse_nios2_plugins.zip file. Still nothing.


I am literally going crazy with this. Endless hours of frustration! I'm really trying to diagnose this and go through it in a coherent manner, but it doesn't give me any clue of what's going on!

Please, if you think I can do anything else, let me know! I cannot be the first to be facing this, right? =)

Thanks!

« Last Edit: April 15, 2020, 10:17:58 am by zigunov »
 

Offline zigunov

  • Newbie
  • Posts: 4
  • Country: br
OK I solved it! I'll post here for my fellow sufferers of the future. I found the bug after talking to a fellow forum user in the Intel forum. It's a bug with Quartus Prime 19.1, that feature doesn't work on Windows.  :palm:

I uninstalled Quartus 19.1, installed Quartus 16.0. Now it opens no problem. And THIS, my friends,  is why no one wants updated software!

 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf