Electronics > FPGA

Re-enabling JTAG in Altera Max3000A PLDs

(1/2) > >>


I got half a dozen of Altera EPM3032ALC44-10N PLDs from the Max3000A series off AliExpress. These are pulled out of the boards and the JTAG in them was disabled so they cannot be programmed with the Altera USB blaster in this state.
While browsing buyer reviews I found a note from a guy who literally said this: "The PLD came in with JTAG disabled. However using a simple rig feeding 10.5V to OE it was unlocked with the Altera USB blaster".
The picture that is attached was shown in that review and it's apparently the unlocking rig itself.

Could you please help me understand what is the procedure of raising the input to 10.5V on OE and what then needs to be done with the Altera USB blaster to reanable the JTAG.

Well, you might try what was done here for a functionally similar Atmel/Microchip ATF15xx series part:


Basically isolate/disconnect the OE1 pin from any other board logic (lift the pin if you have to) and drive it with +12V thru a 1K resistor.
Then just program the device normally thru the JTAG pins via your USB Blaster.
Verify might fail, but in the process of programming it resets the internal non-volatile JTAG_DISABLED flag to JTAG ENABLED mode.
Then set OE1 to back to normal value in the 0V to VCC range as your circuit requires.
Now try JTAG programming access again. It should now work normally, in theory.

Note YMMV. I HAVE NOT tried this, but am just passing it along. I personally NEVER disable the JTAG pins on a device.

I can confirm it works on microchip ATF1508 parts. Apply VCC, apply 12v with resistor, execute erase via JTAG, remove 12v.

I tried, however, with Altera 7128S with no success. I only had couple of them, so it could be just the faulty chips.

Don't know about 3000 series.

What did the listing on Aliexpress say? Brand new?

I've noticed that many Ali IC sellers including this one stopped calling what they sell 'Brand New' unless the chips are replicas but that's of course a different story altogether.

By the way is this driving of OE with 12V a documented feature or just a brute force hack that works for whatever reason?


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod