Electronics > FPGA

Simulating ISE 14.7 in Modelsim

<< < (3/3)

Bassman59:

--- Quote from: ali_asadzadeh on June 06, 2021, 10:37:11 am ---Thanks, I could do the simulation by downgrading Modelsim to 10.6d version, I think there should be something with the new version, maybe it's not compatible with ISE.

--- End quote ---

Of course it's compatible with ISE. You just need to make sure you've compiled the ISE libraries with the version of ModelSim you're using, and that the library is visible to your design.

BrianHG:
This might be better answered on Xilins' forum, or even try to google -> 'Modelsim Error: Module 'BUFG' is not defined.'

ali_asadzadeh:

--- Quote ---Of course it's compatible with ISE. You just need to make sure you've compiled the ISE libraries with the version of ModelSim you're using, and that the library is visible to your design.
--- End quote ---
That's what I have done exactly for a lower version number! the exact things I do for the new version, simply do not work.

mrflibble:
Search for a file called "compxlib.log" in your ISE install directory. That should contain a few hints on what went wrong. It also contains the command that was used for that particular compxlib run. If you want, you can use that to re-run compxlib.

AFAIK there is a separate directory with compiled xilinx code for each simulator version.
So if you have 2 different versions of Modelsim installed, you should have 2 compiled-xilinx-library sub-directories.

In general ... reading the compxlib logs should give you enough information of why things are behaving the way they are.

... Oh, and of course the ISE log messages you get when launching modelsim from ISE.

Navigation

[0] Message Index

[*] Previous page

There was an error while thanking
Thanking...
Go to full version