Electronics > FPGA

USB BLASTER (FTDI245 vs ch552x) Quartus “No Hardware”

(1/2) > >>

noQuitter:
I have clone usb blasters from aliexpress. Some use FTDI245 chips whereas others use ch552x chips. The ones that are based on FTDI245 chip work fine. But for the ch552x blasters they are not recognized by quartus

Problem with ch552x clone blaster:
-Device manger does recognize them (attached figure 1).
-Quartus shows “No Hardware” message in the programmer window (attached figure 2).

And what makes it even worse is that the ch552x based blaster seems to dominate the clone market now and it became harder to find an FTDI based clone blaster.
From what I found online is that a lot of people are sharing the same problem but I wonder if anyone has figured it out.
Please share your thoughts on this. Thanks!

Mark:
Try installing different versions of the stand-alone programmer.  I had problems with win 10 drivers and needed QuartusProgrammerSetup-23.1std.0.991-windows to make my clone blasters work. 

radiolistener:
My usb-blaster from aliexpress has PIC18F14K50.

It works ok with Quartus.

I remember that I heard some rumors that there are different usb-blasters on aliexpress and some of them didn't recognized, someone suggested to install drivers from an old Quartus version, but I'm not sure if it helps, because my one works ok just out of the box.

Wiljan:
I read somewhere that the clones does not have the same logic level as the original. That can give problems depending on the actually fpga  board connected.
I would suggest to use a scope to see happens on the jtag.

coromonadalix:
do they get recognized with the vid pid ??   FTDI had some memory on their ic to register  any vid pid you wanted

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod