Author Topic: [solved] lib_gtk+:: GTK_IS_WIDGET failed  (Read 794 times)

0 Members and 1 Guest are viewing this topic.

Offline DiTBho

  • Super Contributor
  • ***
  • Posts: 1126
  • Country: gb
[solved] lib_gtk+:: GTK_IS_WIDGET failed
« on: October 27, 2021, 08:04:31 pm »
After updating lib_gtk, gtk started reporting warning lines like these:
Code: [Select]
(rumbax:20026): Gtk-CRITICAL **: 18:50:36.197: gtk_widget_get_visible: assertion 'GTK_IS_WIDGET (widget)' failed
(rumbax:20026): Gtk-CRITICAL **: 18:50:36.214: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed

not a problem, but it's annoying.


I compiled libgtk2 and libgtk3 without "introspection" support and the problem disappeared.

I don't know exactly what "introspection" does, but for sure it doesn't work  :-//


This topic is here for those who are experiencing the same problem.
 

Offline DiTBho

  • Super Contributor
  • ***
  • Posts: 1126
  • Country: gb
Re: [solved] lib_gtk+:: GTK_IS_WIDGET failed
« Reply #1 on: October 28, 2021, 11:31:25 am »
Today I recompiled {gtksourceview, pluma, geany} with "-introspection" (feature disabled), and now they work perfectly!
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf