Products > Computers

Debian 11 (Bullseye) xfce4 with xdmcp

(1/3) > >>

I did two side by side installs, one of Debian 10 (Buster) and one was Debian 11 (Bullseye). I chose the xfce4 image as given the choices available  that is my preferred goto desktop.

After doing the base install I applied the following lightdm config:


and created a no-nag policy in polkit:
[Allow ALL Actions]

Using X-Win32 I can create a XFCE4 session without any issues using the Debian 10 install. Debian 11 it just does not work, it either fails to create the session after logging in (75% of the time), the rest of the time it brings up a partial desktop. I built xfwm4-4.14.16 and installed those and it seems better in that the partial desktop is created. I also tries exporting LIBGL_ALWAYS_INDIRECT=1 and that seemed to clear up many of the errors but then you get a desktop with no background and windows that only respond to the mouse events (keyboard is dead over XDMCP).

So I can continue to chase down errors like:
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

But I wanted to see if this was just a XFCE4 issue with Debian 11 or a desktop manager issue so I installed XMONAD which works perfectly. Also as expected with Debian "apt-get update;apt-get upgrade" does not fix anything.

GNOME is a no go and GDM3 has multiple issues with XDMCP that I don't think they will ever fix.
KDE PLASMA that just logs in, changes the background to GREY and hangs.
LXDE I've had working on Debian 11 with XDMCP
XMONAD works.

Debian 11 XFCE4 out of the box is broken. There's no issues on Debian 10 with lightdm & it's window's managers including XFCE4.

Anyone else having issues with Debian 11 & XDMCP or know of other Window managers not horribly broken in Debian 11 and  preferably that come part of the install iso. XMONAD is fine 95% of the time but floating window managers can be convenient at times. For the moment I think I will stay on Debian 10 but it may be time to look at a different distro. Debian up to now has been stable for me but theres obvious quality issues in Debian 11 + XFCE and I think it's time to part ways permanently with XFCE4.

Last week i also tried to install bullseye and then went back to buster, also due to problems with the desktop. In my case the culprit was a legacy C61 Geforce 6150SE (chipset integrated GPU) that works in buster nouveau after adding some "miscellaneous non-free firmware" package i never heard of before.
Took several days to make it work again. It plays youtube, receives EMails and displays them as text-only etc. They have come a long way.
Sorry, i can't help with bullseye insight (yet). The experts recommend combining bullseye with packages from sid. But that's going to be hardcore.

Regards, Dieter

I have all my workstations with  vanilla XDM for decades...
Pretty sure it can be set up without problems...

A decade ago I had to ditch all this nonsense promoted by
"debian leaders" sponsored by the under the hood POTTERIX folks...

Two things that definitely will bring you several major problems..
- running a systemd enabled Xsession
- running anything other than proper matched compiled stuff..
( includes lightdm, gdm kdm.. and so forth)

Setting up XDMCP protocol requires pretty much 2 or 3 config files
edited by hand.. namely:
- xdm-config
- Xaccess

and Xsetup/Xsession which more likely is where you set your WM session

Nevertheless putting a failsafe xdm up running requires you
to setup only the protocol part and  invoke the session with
proper tidbits...  if you will enable features like libGL GLX...

 :0  -depth 24 -fbbpp 32 r +bs +xinerama +iglx  -listen tcp

last param is required to listen remote stations..

So.. the bottom line since major distros started to mess X11R6
and made a hell of a mess into X11R7 is to get rid of these
parts... systemd and anything other than plain xdm...

The server should be able to startup clean listening remote connections
and with proper security mechanisms enabled.

Easier said than done..  my only advice is to get rid of systemd distros
Get the equivalent DEVUAN and try again... with plain XDM as the session manager

IT should BE BETTER  although I have ditched them all in favor
of a custom solution which is bullet proof once you get rid of this problematic shit

IT WORKS .. it has been working for me for decades...
reason why i ditched all distros based on systemd and
I am doing the same with this wayland  twist  which has been also a big problem

I have a hunch that these problems have the same common cause..
to implode and fragment X11 (XOrg) to cripple *NIX  and promote other thing..

You will also need a very careful setup of MESA (which relies on LLVM/clang)
to enable accelerated drivers..  the messages posted are related to a bad
installation of MESA...  which is not trivial.

and got worst since MESON replaced AUTOCONF.
I had  problems with same version compiled with MESON segfaulting..
while a clean AUTOCONF works perfect..

I can not even explain or understand why..
My hunch is that  MESON over simplified things that AUTOCONF never will..

My hunch.. so far my system is 100%  XDM libGL and working fine..
For how long... can not tell  :-\

Last but not least...  Slackware has now a major RC (release candidate)
that should work with plain X11 and xdm mechanisms.. once Slackware
is STILL  the far way best *NIX  based LINUX distro out there



For the record...  distros with high degree of confidence
and still faithful to *NIX in which you can pretty much
do things yourself instead of being jailed by POTTERIX...

Chances of success are far better using some of the above.
Your mileage  will vary..

These are my preferred set distros to deploy always



--- Quote from: PKTKS on November 28, 2021, 03:22:03 pm ---
These are my preferred set distros to deploy always

--- End quote ---

Thanks for the suggestions and view. I'm going to go with your suggestion of Devuan, just downloading the DVD iso now.

I like XDMCP
 and I have noticed a very deliberate move to cripple and break it. Bug reports don't get fixed. I've used lightdm because up until now it works and was simple. If I understand your response correctly you don't have lightdm installed so what desktop manager package do you have installed? I'm also not sure on the configuration you have, can you post any of your config files.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version