Author Topic: VMWare hijacking L-CTRL key  (Read 293 times)

0 Members and 1 Guest are viewing this topic.

Offline blueskull

  • Supporter
  • ****
  • !
  • Posts: 367
  • Country: cn
  • BA7LKP
VMWare hijacking L-CTRL key
« on: July 20, 2020, 10:26:12 am »
My VMWare is hijacking my L-CTRL key on host!

OS: Ubuntu 20.04 host, Win10 2004 client

Symptoms: L-CTRL key and all of its combinations fail to work on host OS, including CTRL+ALT+F keys and CTRL+ALT+DEL. I mapped CAPS also as CTRL in Ubuntu Settings, and CAPS still functions as CTRL. R-CTRL functions normally as well. Both user session and gdm login from suspend/lock screen are affected. DOES NOT AFFECT SYSTEM BEFORE FIRST VM IS STARTED. Few minutes after VM is shut down, VMWare will release the key to OS.

Attempts: tried to turn off hot keys in VMWare, no help. Tried to map hot key to shift and alt, no help, plus even after mapping shift and alt as hotkey, shift and alt still work in host OS, just don't press them together. So it seems not to be a hot key issue.

Problem: apparently, no ctrl+a/z/yc/v really ruins your day, and while CAPS is confy for most cases (that's why I mapped it in the first place), for certain keys L-CTRL is still more comfortable, notably ctrl+z.

Any ideas why it happens, and how to deal with it other than retain my typing preference?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf