Products > Computers

Repartition Hard Drive with Dual OS and Not Losing Data

<< < (15/17) > >>

Gparted didn't work, it was suggested to use Disk Genius (which I put on a thumb drive).

The original hard drive was cloned to this brand new SSD. I'm simply trying to expand into the unallocated section since the new hard drive is bigger.

Yes, and you need to shove sda4/sda5 all the way to the right before expanding either of sda2 or sda3.

I have done similar things with gparted and see no reason why it shouldn't work.

I'm resurrecting an old thread that I started as a result of a recent update.

A few weeks ago I attempted to power the laptop and an error appeared stating no disk drive or whatever; basically the BIOS wasn't seeing the hard drive.

Long story short, apparently the somewhat brand new SSD 500GB drive (purchased earlier this year and used maybe a total of twelve-hours) is dead.

Keeping in mind this is a 32-bit laptop running Ubuntu (with a partition that has run out of space), XP, and I haven't been able to allocate the spare extra drive space that I acquired after buying this larger (now broken) hard rive) to the two operating systems.

My question is: now that I'll probably buy another hard drive and copy the contents of the one prior to this broken one (thankfully I haven't added anything to the drive that the previous working drive doesn't already have), is there a way to move just the Ubuntu and XP partition over and apply the extra unallocated space to them?

Keep in mind, this drive has five (?) partitions due to Dell having their two or so hidden ones (or restore partition).

Had a similar problem where the drive was not recognised until we used the free RescueZilla ( boots on a usb stick).

If you load it up, then exit the main RescueZilla page,  it goes down to a page of  utilities that has Gparted which did  list the 'dead' drive and allow us to delete all the old partitions etc, then  it reloaded Linux  ok.

RescueZilla does both Linux and Windows backups and cloning  so it might be able to do what you want ?

Think I figured out how to repartition my drive using GParted (off a Thumbdrive using I think Systemrescue), however, the XP partition is giving errors.

When I try to expand the XP partition (after I successfully expanded the Ubuntu partition), it states the file system has errors. I ran chkdsk using XP, left it running, returned, XP was loaded, shut down, booted GParted, tried to repartition, got the same error, tried running the error check in Systemrescue, got an error, tried booting XP to run chkdsk again, and got a .dll boot error.

I don't care about the boot error or messing up the drive as I have the main drive with all the contents I need. When I screw up with GParted, I just copy the drive again.

My issue is how I can get around this file system error that causes the repartition process to abort.


[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod