Products > Computers

Teamviewer V14 is messed up

(1/6) > >>

I have been using Teamviewer for a long time, both in Windows and in Linux, and it worked fine and I really liked it.

I don't know what has happened with Teamviewer lately but first I started getting messages of "commercial use suspected" and had to email them and wait some time.

Then since V14 came out it has given me nothing but trouble and aggravation. I gather it has trouble connecting to the Internet or to its servers. So I can start it and it does not register my own ID and password. And if I try to connect to another computer it says it is not online. It seems to happen more with Linux than with Windows.

The forum at Teamviewer is worthless and provides no help. I have posted there but no response.

The Linux Mint forum just suggest returning to an earlier version but the reason I upgraded was that earlier versions were very aggressive in demanding I upgrade.

I am very much ticked off about the whole thing because I liked Teamviewer and it was one of the few programs that worked well on both Windows and Linux.

Is there any way I could test to see why it may be having problems connecting?

The software uses unknown rules to determine if your use is within the "non commercial use", for example it may be checking if you're controlling endpoints with server O.S. or more than N endpoints in one day and who else know. A sure limit it is the hourly usage: after X hours a month it's considered commercial use.
They don't reveal anything else for obvious reasons.

Once your ID become suspected of commercial use you can ask for them to correct the issue and have the limitation removed but if you continue to use it in the same way you'll be victim of that system again, after some time.

The fact is that it remains a commercial software given as free (under not so precise terms), so there is nothing to do if they decide to suspend an account.

There is nothing you can do about it (other than changing your software usage habits to occasionally).

The problem now is not "commercial use suspected". It just seems to be having trouble connecting to the internet or to its servers. And I am not the only one having this problem.

It could be a way to prevent using of the account due to suspected commercial use instead showing clearly that message.
I would try with other machines (different hardware, different account, same OS) to see if the problem can be in that "feature".

--- Quote ---And I am not the only one having this problem.
--- End quote ---
I heard many connection issues or troubles and when digging a little bit, all of them were free accounts.
I'm a paid user and except for announced maintenance, I had never a real connection issue.
They could intentionally prevent free accounts from connecting to avoid service degradation for paid users. That is something that from a commercial point of view is correct, even if I understand the frustration of the free users.

Teamviewer is stupidly expensive for what it is. Especially for use that is barely commercial.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version