Author Topic: TP-Link UH720 USB hub issues on audio devices  (Read 1157 times)

0 Members and 1 Guest are viewing this topic.

Offline GiaimeTopic starter

  • Regular Contributor
  • *
  • Posts: 71
  • Country: it
TP-Link UH720 USB hub issues on audio devices
« on: June 03, 2020, 04:52:06 pm »
Dear all,

I'm running Windows 10 Pro on an Asus Z-170A motherboard.

I just purchased the aforementioned usb hub, and tried 2 different audio devices on it (Logitech G533 wireless headphones and an old USB DAC) and they don't work, sometimes there's some crackle, sometimes the program that's playing audio freezes, sometimes the device is not recognized.

I've tried every port on both the hub and the PC (USB 2.0 on Intel usb device, USB 3.0 on Intel usb device, USB 3.1 on ASMedia usb devices - I also tried rolling back to 2018 and 2016 drivers for the ASMedia) and it still doesn't work.

Every other USB device (mouse, hdds, sticks...) works ok.

I'm asking on the forum before returning it because it works 100% flawlessy when connected to my work PC, a Dell laptop.

Am I out of luck or is there something I can try?

 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf