Products > Computers

Windows 10 randomly switching keyboard settings to deleted "default" one.

(1/1)

Miyuki:
Hi folks. Especially those who use a different keyboard layout than your windows localization default.
I know this issue from time to time pop up on windows forums but I do not find a working solution to it.

When I remove the keyboard layout what was the default for installation and replace it with other. Sometimes, randomly happens it just appears in layout selection and is active. It is not visible anywhere in the preferences settings, just in the task bar. It can happen a few times a month.

I have disabled "different input method for each App"
Yet it helped a little, it still happens from time to time

newbrain:
For me, this happens only after I remote login from my Android tablet.
When I'm back at the PC it will have US keyboard layout.

I normally use a modified Swedish layout (nothing too strange, just added some useful chars, e.g. ω Ω × π  ° etc.).

SiliconWizard:
Your keyboard layout belongs to MS. Get used to it. :-DD

Ranayna:
Check your Languages Panel: Start ->  Search for "language settings" -> Preferred Languages. I *think* that MS automatically adds any languages you have enabled here to the available keyboard layouts.
Even though i have my Windows to en-US, i'm using the german date/time format. Therfeore i also have german available in the list. I suspect that this caused german to be added into the available keyboard layouts.
If you have more than one language in the preferred languages and want to keep it that way, klick on "Keyboard"
There you have a couple of options, if you want to fix to a single language, select that one in the dropdown.

Finally you should check for keyboard shortcuts to switch between languages. Maybe you hit that accidentally. Click on "Input Language hoy keys"
There you should see a list of available layouts to switch to/between. If you have hotkeys configured, you can change or remove them here as well. The default Left Alt + Shift can be removed as well.

Miyuki:

--- Quote from: Ranayna on November 30, 2021, 11:54:05 am ---Check your Languages Panel: Start ->  Search for "language settings" -> Preferred Languages. I *think* that MS automatically adds any languages you have enabled here to the available keyboard layouts.

--- End quote ---
I have two languages/keyboards here
But!
At the "keyboard select" on the taskbar next to the clocks are Three of them  |O

After restart, there are just two as they should be but then randomly the third one just appear and activate  :scared:
It has nothing to do with switching hotkey as this keyboard shouldn't be there in the first place

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version