Electronics > KiCad

Building KiCAD on Linux Mint 12 (Lisa)


Just thought I'd post an initial link to my experiences of compiling KiCAD on Linux Mint (Lisa) this afternoon.

Please read the comments (when moderated-at the bottom-still not moderated,probably lost) here


where I detail the error messages and what I did to get round them.

I will collect the information here later on.

Please have a go yourself so that we can iron out any problems together.



P.S If you can't be bothered with compiling code here is a link with nightly builds (for now).


Better to learn how to compile the code for yourself though.

As promised

1/ First download the source code:

--- Code: ---sudo apt-get install bzr
bzr checkout lp:kicad kicad.bzr

--- End code ---

2/ Next download the build tools

--- Code: ---sudo apt-get install build-essential checkinstall cmake doxygen zlib1g-dev
--- End code ---

--- Code: ---sudo apt-get install debhelper dpatch libx11-dev libglu1-mesa-dev libgl1-mesa-dev messa-common-dev libwxbase2.8-dev libwxgtk2.8-dev libboost-dev fakeroot subversion libboost-serialization-dev
--- End code ---

--- Code: ---sudo apt-get build-dep kicad
--- End code ---

3/ Once the source code has downloaded and all the build tools are installed, go into the new source code directory:

--- Code: ---cd kicad.bzr
--- End code ---

4/ To keep things cleaner, it's suggested that you create a build directory for the build files:

--- Code: ---mkdir kicad-build
cd kicad-build
--- End code ---

5/ Kicad uses the CMake tool, so we must run that first:

--- Code: ---cmake -DKICAD_TESTING_VERSION=ON ../
--- End code ---

6/ CMake generates standard Makefiles, so we proceed in the usual way:

--- Code: ---make
--- End code ---

If you have multiple processor cores in your computer, you can do some of the work in parallel, by adding -j N to your make line. Replace N with the number of cores in your computer. My computer has two cores, so I used this command to more quickly build Kicad:

--- Code: ---make -j 2
--- End code ---

7/ Once the build is finished, install the Kicad files:

--- Code: ---sudo make install
--- End code ---

Now, you can run kicad and check that everything is working.


8/ Once a few days or weeks have passed and you want to get back up to date, start by updating your copy of the Kicad source code:

--- Code: ---cd ~/kicad.bzr
bzr update
--- End code ---

You probably want to remove all the old build files:

--- Code: ---cd build
rm -rf *
--- End code ---

Continue as before, for compiling and installing Kicad:

--- Code: ---cmake -DKICAD_TESTING_VERSION=ON ../
sudo make install
--- End code ---

We hope this guide was useful and accurate! If you run into any trouble, please leave a comment below and we’ll do our best to help you out.

If you want to also install the Kicad library of parts, you can use these commands:

--- Code: ---bzr checkout lp:~kicad-lib-committers/kicad/library kicad-library.bzr
cd kicad-library.bzr/
mkdir build
cd build/
cmake ../
sudo make install
--- End code ---

This method has been derived from the wayneandlayne link above. I have added the commands needed to download missing packages and made one or two corrections. All thats needed now is for someone to write a shell script that can be run easily.

Please try this out for yourself.



Thanks. I am right now half way through setting up a Ubuntu Electronic Remix (UER) VMWare virtual machine based on Ubuntu 10.10. There is no ISO for UER, so you have to build up a normal Ubuntu workstation, link it to the UER sources, then install any of the UER packages.

The main reason is I would like to take a look at gEDA and it doesn't run well on Windows - it really needs Linux.

I have got used to using the Daily builds for my Windows KiCad, so I will probably want the same newer versions on Ubuntu. All your notes should work as well on Ubuntu as Mint. I am looking forward to comparing Linux KiCad to Windows KiCad.


Thanks for posting this David!

The command sudo apt-get build-dep kicad didn't work for me.  The first error I got was:
--- Quote ---E: You must put some 'source' URIs in your sources.list
--- End quote ---
This was solved by making sure that the Update Manager -> Edit -> Software Sources -> LinuxMint Software -> Source Code box was checked.  After that, the error I got was:
--- Quote ---E: Unable to find a source package for kicad.
--- End quote ---

However, none of this really mattered because the list of apt-get packages you gave above was thorough enough that kicad built without complaint.


[0] Message Index

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod