Author Topic: Earth changed to +5V  (Read 1596 times)

0 Members and 1 Guest are viewing this topic.

Offline gilbenl

  • Regular Contributor
  • *
  • Posts: 170
  • Country: us
Earth changed to +5V
« on: April 15, 2016, 07:16:33 pm »
Due to a glut of components, I implemented hierarchical sheets in my CAD. I used global labels for all power rails. Now, the netlist is trying to change all "Earth" pins to "+5V." Any ideas assuming I don't have something crossed?
What doesn't kill you, probably hurts a lot.
 

Offline Wilksey

  • Super Contributor
  • ***
  • Posts: 1153
Re: Earth changed to +5V
« Reply #1 on: April 15, 2016, 07:55:12 pm »
Sounds like you have a crossed wire.

I have multi sheet schematics in KiCAD without any issues, I'd suggest double checking all of your rails.

Did you do ERC checking with power flags etc?  That normally picks up quite a lot of issues.
 

Offline gilbenl

  • Regular Contributor
  • *
  • Posts: 170
  • Country: us
Re: Earth changed to +5V
« Reply #2 on: April 15, 2016, 08:37:57 pm »
I do use power flags w/ERC and it only returned a single warning, which was on purpose. Went to the IC causing the issue and resaved it in the footprint editor wo changing anything. Everything's fixed. Odd...
What doesn't kill you, probably hurts a lot.
 

Offline Wilksey

  • Super Contributor
  • ***
  • Posts: 1153
Re: Earth changed to +5V
« Reply #3 on: April 16, 2016, 09:47:39 pm »
It is odd, are you using the latest version? 4.0.2?
You could try asking on the KiCAD forum, and checking the bug tracker to see if anyone else has had a similar issue, it's not one I've experienced though.
 

Offline ElektroQuark

  • Supporter
  • ****
  • Posts: 1214
  • Country: es
    • ElektroQuark
Re: Earth changed to +5V
« Reply #4 on: April 17, 2016, 05:34:28 am »
Can you share the Eeschema file?


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf