Electronics > KiCad

Freerouter not doing dual layer

(1/2) > >>

Simon:
I layered a board out in kicad and then went to free router to run the routing. it won't put any vias in and do two layer routing although the bottom of the board is all clear. Is it a kicad or free router thing ? i have dual layer in both from what i can tell.

djsb:
Are you using the latest stable version of Kicad? Freerouter normally does double sided boards by default. As I usually make single sided I have to go to the parameters and autorouter dialogs to turn OFF one of the layers. Are you using any copper flood fills or keepout areas on your board. That may make it more difficult to route.

David.

Simon:
Well i had problems with "the" latest so went back to my usual version that had worked no problem where like you i had to disable the top layer for single sided. So is it a compatibility problem ?

I'll give it a go.

Simon:
nope, still no joy, it is faffing around instead of doing it in a split second as it is just a basic PWM generator using an atmega328 so not even much to route and bags of room.

djsb:
Have you tried different (smaller?) track widths. Or reduce the clearance in your custom design rules if your using them. I think there an option for prefered routing direction as well somewhere. I usually go back into Kicad and re-position the components near the place where the routing fails and then reimport back into freerouter.
Keep doing that and EVENTUALLY it will do all the tracks.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version