Electronics > KiCad

Having Trouble With Imported PCB Shape//KICAD *SOLVED*

(1/1)

atomicdreamer:
I have been struggling for a while trying to figure out how to import a file correctly into KiCad to use as a board outline. I am copying a rather complex design from another board -- essentially, I wanted to purchase a premade board from a manufacturer; they are out of business; I am recreating their board, having it produced, and then putting all the parts on it. I converted the PDF of the board shape into a vector image and exported as SVG via InkScape (dxf files don't work at all) and it works but I keep getting extra lines that aren't part of the image and it separates the board outline into separate parts, meaning I cant connect parts or wires from one part of the board to the other. It is quite frustrating and I have come here in hopes that someone has an answer for me. I will attach some pictures to give you more to go off of.               

jpanhalt:
I do not know KiCad, only Eagle.  I always import complex outlines as DXF files.  Is that a possibility with KiCad?  Be sure your units are consistent.  Then, it is only a matter of getting aligned to the grid.

Welcome to EEVBlog.

atomicdreamer:
I tried using eagle for this project and it got much too complex with the footprints etc that I had to find and download. For some reason when I export as dxf it imports nothing but a tiny little circle which is mindboggling to me because I searched for that error and I've not seen anyone who has had the same experience.

jpanhalt:
I use a user language program (ulp): import-dxf-1_6.ulp

Never had a problem (Eagle 7.x) even with boards to fit inside complex cases.

Don't know how your version vorks, if at all.  Besure to define the layer you want and that the units are the same.  Do not use a signal layer.

EDIT:  Here's the ulp
EDIT2: If you will post the dxf file, I will convert to Eagle 7.x for you.  Alignment with the grid will be up to you as a learning exercise.

atomicdreamer:
OH MY GOD I JUST FIGURED IT OUT. All I had to do was unfill the inside and keep the border outline in InkScape and I re-imported it and the lines were gone. THANK YOU FOR COMMENTING I APPRECIATE IT!

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version