Author Topic: How do you get out of foot print mode after you've saved a foot print to new lib  (Read 1363 times)

0 Members and 1 Guest are viewing this topic.

Offline Red Squirrel

  • Super Contributor
  • ***
  • Posts: 2177
  • Country: ca
 Trying to learn Kicad but I find some aspects are really unintuitive especially when it comes to component/footprint library management.   So I went ahead and created just a test foot print, and then saved it to a new library.  It created the files, but after that, I can't seem to go anywhere from there.  If I go to create a new foot print,  it tells me the current one will be lost. There does not seem to be an actual save function, just save to new library.   How do I go about getting out of that mode so I can make another foot print and store it in the new library?    Also when I go to "set current library" my custom one does not show up, and I don't see any option to browse.  So I wonder if that may be part of the problem.
 

Offline Thor-Arne

  • Supporter
  • ****
  • Posts: 503
  • Country: no
  • tinker - tinker, little noob.....
To save a footprint you must first select a library (File->Set active library) then Save Footprint in Active Library or Save Footprint in New Library. Just use Ctrl-S for this, and answer Yes to everything.

When you have created the new  footprint library file, you need to add that library to the fp_lib_table. This is done in the Preferences->Footprint Libraries Manager in pcbnew.

After the file is saved, pcbnew complains about library not saved (current one will be lost). This is an artifact that lingers from the old footprints libraries format where all footprints was in one file. Just use Ctrl-S as mentioned and you'll be ok.
 

Offline Wilksey

  • Super Contributor
  • ***
  • Posts: 1153
When you save your footprint to a new library, you are asked for the destination etc, which you should have done by looking at your post, when you create a new footprint if anything has changed (or if KiCAD thinks anything has changed) then it will say "changes will be lost" blah blah, this is quite common.

Now, as you have noticed in your "current library" list it isn't there!  This is a common annoyance in KiCAD, but it does allow you finer control - even if you don't want it! You have to add it to the footprint / library list.

Within the footprint editor, go to Preferences -> Footprint Library Manager.

You will see 2 tabs, one for "global" and one for "project specific", the difference is simply, the global tab will allow you to use your library on all projects, project specific is for your existing project only.

Once you have determined which option you want, you click the "Append with wizard" button, it will then bring up a dialog box asking if you want to look on your local machine or a GIT repository, follow the screens from there.

Once complete, it should appear in your "set active library" list, and you can then work with your new library from there.

HTH
 

Offline Red Squirrel

  • Super Contributor
  • ***
  • Posts: 2177
  • Country: ca
Oh I see so I still have to import the library even if I just created it?  And I can ignore the message saying it's not saved?  I'll have to play around with that. 
 

Offline Wilksey

  • Super Contributor
  • ***
  • Posts: 1153
Yes, once you have created it into a new library, KiCAD still doesn't see it as "saved" as there is no active library - this is what i've deduced anyway!
It's always been in the new library when I have added it.
It's one of those quirks about KiCAD which you feel it should add your newly created library automatically as a local library (rather than global, although a option could be created for this), maybe they'll get around to it one day, it doesn't bother me as I know the workflow to know I have to add it each time, but I can see why it would be a bit of a learning curve for beginners.

Have a play with a new library that you don't really care about and see what you can get from it, figure out how it works etc, then you will be able to make libraries all day every day without any hassle!
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf