Electronics > KiCad

How to move all layers at the same time

<< < (3/4) > >>

ataradov:
1. Yes, this is how CADs worked for ages.
2. Cursor does snap to the grid, the component center does not. Let's say I have a 0.1" grid and a resistor that is currently at a coordinate (1.15, 3.21). If I select it, I can move it to coordinates (1.25, 3.21) or (7.15, 3.61). But I can't move it to (1.1, 3.2).

So, mouse snaps to the grid. But if you are moving a component that is already not on the grid, it never will be on the grid with this approach.

Once I manually edit component location to be on the grid, all following movements are working as expected.

bpiphany:
Now you coerced me into installing the nightlies..

I seem to be able to "break" the snap by unchecking

Preferences -> Preferences -> Editing -> Warp mouse to origin of moved object



(I have had an annoying bug where rendering stops working while moving things (plus some other random graphic updates) when switching between programs. Requiring a restart of Kicad to fix. That seems to have gotten worse than ever in the nightlies, bordering on unusable.)

ataradov:
This is it. Now things work as expected. I tried all the settings I could find, but I missed that one because it is in "Common", not in PCB options specifically.

So far in my experiments I don't see any rendering bugs.

The only real annoyance that remains is very limited ability to manually enter coordinated for graphical items in a symbol editor. But that seems like it is how it is designed.

Doctorandus_P:
If you move or drag a footprint then the "current attachment point" is placed on the grid. If the attachment point is a pad, then it uses the pad center, but if you drag it by the footprint center, then the footprint center gets put on the grid.

ataradov:
Another strange issue came up. For some reason all my ratsnests disappeared. They are still drawn when a component is moved, and a curved/straight setting also takes effect. But toggling Show Ratsnest does absolutely nothing.

I can find some very old issue where ratsnests would disappear on OpenGL drivers, but it does not look like it is the issue here, enabling  fallback graphics does not fix the issue.

It is possible that it is nightly build issue, of course, but may be there is a setting I'm missing?

Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version