Author Topic: KiCAD 5.1.10_1 - Does not properly print gerber files...  (Read 1010 times)

0 Members and 1 Guest are viewing this topic.

Offline Uky

  • Contributor
  • Posts: 28
  • Country: se
KiCAD 5.1.10_1 - Does not properly print gerber files...
« on: May 15, 2021, 02:33:07 pm »
I am using KiCAD as a free standing tool to view and print Gerber files (X274). Noted that V 5.1.10_1 released in May will not print certain pads in a Gerber file. (The preview also will not display these pads) If this is an expected behavior if the Gerber file was created using another tool I cannot say. Generating the Gerber file "normal" or "mirrored" does not matter. The pads are used in several locations on the board so it cannot be a question of a missing or uninterpretable D-code. The pads are correctly displayed and printed using  Pentalogix "Viewmate". (The reason why I unistalled that software was that is always opened a web-page with advertistments.)


 
 

Offline SiliconWizard

  • Super Contributor
  • ***
  • Posts: 7165
  • Country: fr
Re: KiCAD 5.1.10_1 - Does not properly print gerber files...
« Reply #1 on: May 15, 2021, 10:35:30 pm »
I suppose you're talking about GerbView?
I don't use it, so I can't tell whether this is a new behavior or not, but I just tried a couple Gerber files with it, and indeed it looks like some pads show up weirdly.

Could you post one of your Gerber files not displaying properly so I could take a look?
 

Offline Bassman59

  • Super Contributor
  • ***
  • Posts: 2020
  • Country: us
  • Yes, I do this for a living
Re: KiCAD 5.1.10_1 - Does not properly print gerber files...
« Reply #2 on: May 16, 2021, 07:20:39 pm »
I am using KiCAD as a free standing tool to view and print Gerber files (X274). Noted that V 5.1.10_1 released in May will not print certain pads in a Gerber file. (The preview also will not display these pads) If this is an expected behavior if the Gerber file was created using another tool I cannot say. Generating the Gerber file "normal" or "mirrored" does not matter. The pads are used in several locations on the board so it cannot be a question of a missing or uninterpretable D-code. The pads are correctly displayed and printed using  Pentalogix "Viewmate". (The reason why I unistalled that software was that is always opened a web-page with advertistments.)

Report the bug!
 

Online retiredfeline

  • Regular Contributor
  • *
  • Posts: 241
  • Country: au
Re: KiCAD 5.1.10_1 - Does not properly print gerber files...
« Reply #3 on: May 16, 2021, 10:56:40 pm »
Have you tried other viewers like gerbv from gEDA or the online tracespace.io one?
 

Offline Uky

  • Contributor
  • Posts: 28
  • Country: se
Re: KiCAD 5.1.10_1 - Does not properly print gerber files...
« Reply #4 on: May 18, 2021, 07:12:59 am »
After the initial post, I discovered that traces were missing too.
Not being a user of KiCAD, I uninstalled it and went back to Viewmate.

The regular software I use is Cadence Allegro which can do Gerber Import
(only from files created by itself - It checks the header for "proper" source...)
but the risk of it being buyist makes me want to use a viewer from another vendor.

 

Offline julian1

  • Frequent Contributor
  • **
  • Posts: 416
  • Country: au
Re: KiCAD 5.1.10_1 - Does not properly print gerber files...
« Reply #5 on: May 27, 2021, 02:13:38 am »
Crappy bug. the rendering is completely screwy for me. switching to modern toolset (fallback), seems ok though. 
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf