Electronics > KiCad

KiCad 6.0.8 ERC issues (newbie)

(1/2) > >>

I have used KiCad before to produce a simple board design (it was of a simple interface to program PIC 40DIP MCUs via ICSP header) that I printed with my manufacturer of choice (JLCPCB), but years later now I'm back at it and see that I cannot even pass simple ERC checks.
Don't know if it's due to major KiCad changes since I can't remember what version I used the last time.

Having seen that I couldn't pass ERC with more complex diagram, I drew something simple as in the screenshot below which still fails ERC. I don't really understand what Kicad wants of me.

After reading through some forums, I ended up connecting the PWR_Flag to my 5V source which got rid of one of the errors, but still fails with same error for the GND connection.

Can someone please enlighten me what I'm doing wrong?

You need power flags on all power lines. This includes grounds.

And it also includes all power connections that are not traceable by the ERC. For example if you have power flag on a battery before the power switch, you need a power flag on the connection after the switch, since ERC can't tell that they are the same thing.

The only time you don't need a power flag is when the line is explicitly driven by the pin marked as power output (typically output pin of voltage regulators).

Yep, and it's nothing new. Has been like this for a long time in KiCad.


--- Quote from: SiliconWizard on January 15, 2023, 07:50:01 pm ---Yep, and it's nothing new. Has been like this for a long time in KiCad.

--- End quote ---

Thanks, it worked after adding the PWR_FLAG to GND connection as well!

How about rules for not connected pins? i.e.: ERC fails if I connect unused pins to ground (because I don't want them floating). It only passes if I add the "no-connection" flag to those pins.
I'm actually not clear how KiCad checks them, it lets me connect some pins of MCU to GND, but others it throws errors and only ERC only passes if I add the no-connection flag.

It's no problem connecting input pins to ground.
The issue occurs if the pins are outputs or bidirectional or tri-state (which is also an output).
Use the "-x" symbol on the right screen side to deactivate the pins for ERC, and consider your design again.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod